Partage
  • Partager sur Facebook
  • Partager sur Twitter

A lire absolument pour installer Qt !

Le cours C++ du site contient des erreurs pour l'installation de Qt

    12 mai 2018 à 19:43:45

    Bonjour gbdivers.

    J'essaierai dans mon message de ne pas être condescendant.

    Je vais expliquer ma situation : je suis totalement novice en C++. Je suis encore plus novice avec Qt. Il faut savoir qu'avant de faire appel au forum, j'ai dû essayer d'installer 4 ou 5 fois Qt à l'aide du tuto du cours sur C++. Je suis tombé soit sur des erreurs (kits manquants, ou erreurs lors de lancer de programmes de tests) soit sur une quantité phénoménale de données à installer sur mon modeste disque dur (40, 50, 60 Go).

    Du coup, ne comprenant d'où viennent les soucis, et malgré mes essais-erreurs, je me suis retrouvé paumé.

    J'ai alors parcouru le tuto de long en large, mais en arrivant au point délicat que je mentionnais dans mon précédent post, j'ai saturé.

    C'est comme si tu te retrouvais à chercher à réparer une pièce de moteur de ta bagnole et que l'explication textuelle de la notice ne correspondait pas à la photo qui est censée l'illustrer.

    Mon intention n'était donc pas de démonter intégralement ton tuto (d'ailleurs j'explique que pour l'option "tools", ça me paraît un peu plus clair et cohérent entre les captures d'écran et les commentaires.). Mais te soulever une interrogation, une incertitude de la part de quelqu'un qui avance dans l'inconnu.

    J'ai peut-être été véhément en exprimant mon désespoir par un gros "je sature". Je m'en excuse.

    Je comprends aussi que de ton côté, le fait que je ne sois pas le premier à avoir appelé au secours, tu "satures" également.

    Cordialement.

    • Partager sur Facebook
    • Partager sur Twitter
      16 mai 2018 à 2:38:44 - Message modéré pour le motif suivant : Message complètement hors sujet


      1 ou 0 ? Tel est la question.
      Anonyme
        18 mai 2018 à 1:24:32

        ok merci  du  partage.
        • Partager sur Facebook
        • Partager sur Twitter
          16 juillet 2018 à 14:45:08

          bon eh bien merci pour cette information :D
          • Partager sur Facebook
          • Partager sur Twitter
          std::cout << "Hello World" << std::endl;
            16 juillet 2018 à 18:36:39

            Bonjour, je voulais savoir, lors de l'instalation de Qt, j'ai omis de cocher la case pour installer le debugger.

            Je ne trouve pas sur internet un moyen de l'installer. Il y en a t-il un ? Ou je suis obligé de désinstaller puis de réinstaller Qt ?

            • Partager sur Facebook
            • Partager sur Twitter
            Toujours plus
              16 juillet 2018 à 18:59:57

              Pour mettre a jour l'installation de Qt, il faut lancer le Qt Maintenance Tools. Si c'est le debugeur de MSVC, il faut installer le Windows SDK de memoire.
              • Partager sur Facebook
              • Partager sur Twitter

              Rejoignez le discord NaN pour discuter programmation.

                17 juillet 2018 à 10:32:03

                Super merci :)

                Une autre question, j'ai installé exactement pareille que sur un autre ordi Qt, mais là, ça ne marche pas, j'ai ce message d'erreur :

                Could not determine which "make" command to run. Check the "make" step in the build configuration.

                Error while building/deploying project nvr (kit: Desktop Qt 5.11.1 MSVC2015 32bit)

                When executing step "qmake"

                Une idée ? J'ai juste créé un nouveau projet. De toute manière, même avec les projets d'exemple ça m'affiche la même chose

                -
                Edité par bozo6919 17 juillet 2018 à 10:39:34

                • Partager sur Facebook
                • Partager sur Twitter
                Toujours plus
                  17 juillet 2018 à 11:19:55

                  As tu installé MSVC 2015 ?
                  • Partager sur Facebook
                  • Partager sur Twitter

                  Rejoignez le discord NaN pour discuter programmation.

                    17 juillet 2018 à 11:22:07

                    Comment je peux voir ça ?
                    • Partager sur Facebook
                    • Partager sur Twitter
                    Toujours plus
                      17 juillet 2018 à 11:32:43

                      Ben... tu ne sais pas si tu as installé MSVC ?
                      • Partager sur Facebook
                      • Partager sur Twitter

                      Rejoignez le discord NaN pour discuter programmation.

                        17 juillet 2018 à 11:50:39

                        je sais plus :/

                        Edit : Voici ce que j'ai :

                        -
                        Edité par bozo6919 17 juillet 2018 à 12:23:30

                        • Partager sur Facebook
                        • Partager sur Twitter
                        Toujours plus
                          17 juillet 2018 à 13:15:22

                          Ok, non. Relis le tuto. Pour installer Qt pour MSVC, il faut installer Qt (avec l'installeur, c'est l'image que tu montres) ET MSVC (qu'il faut telecharger sur le site de Microsoft)

                          Et tu as installé les 33Go de Qt ? Tu as besoin de toutes les versions de MSVC, de Android, de UWP, les sources, les add-ons, etc ?

                          Et si tu as tout installé, tu as au moins un kit qui fonctionne. Pourquoi ne pas selectionner ce kit plutot que selectionner un kit qui ne fonctionne pas ?

                          As tu réellement lu le tuto ?

                          • Partager sur Facebook
                          • Partager sur Twitter

                          Rejoignez le discord NaN pour discuter programmation.

                            17 juillet 2018 à 13:46:51

                            Ok ok

                            Oui j'ai installé les 33Go, j'aurai besoin de tout ça pour après

                            Et au niveau des kits même un projet d'exemple ne fonctionne pas alors qu'il sélectionne directement le bon kit, enfin même pas besoin du kit pour voire qu'il ne marche pas, les fichiers ne se téléchargent pas :

                            On voit bien qu'il n'y a ni les fichiers source ni les headers

                            • Partager sur Facebook
                            • Partager sur Twitter
                            Toujours plus
                              17 juillet 2018 à 14:15:54

                              Un problème a la fois. Si tu as eu un problème d'installation des codes d'exemple, il faudra reinstaller. Pour le moment, il faut regler ton probleme de kit.

                              Si tu crées un projet widget par defaut, est-ce que cela fonctionne avec au moins un des kits ? (Normalement avec le kit mingw)

                              Peux tu faire des copies d'ecran de tes configs de kits.

                              • Partager sur Facebook
                              • Partager sur Twitter

                              Rejoignez le discord NaN pour discuter programmation.

                                17 juillet 2018 à 14:38:15

                                Bon... Ba je sais pas ce qu'il s'est passé... J'ai éteinds puis rallumer l'ordi et tout marche :/

                                Tant mieux mais bon, j'aurai bien aimé comprendre mon problème ^^'

                                Merci tout de même :)

                                • Partager sur Facebook
                                • Partager sur Twitter
                                Toujours plus
                                  18 juillet 2018 à 18:16:47

                                  Bonjour à tous

                                  je suis débutant en ce qui concerne le language c++.

                                  je suis le cours de matheo 21 et je suis arrivé à la 3e partie : la création des fenêtres avec Qt

                                  j'ai suivi les nouveau tuto d'installation présenté ici.

                                  tout à bien marché, j'ai avancé dans le cours et depuis hier je ne peut ni créer de nouveau projet(il m'affiche canot create file...unknown error), ni exécuter un programme déjà compiler qui marché auparavant(le débuger affiche que je ne peut pas executer car "accès refusé"

                                  j'agoute egalement que je trouve birarre la version de qt créatif que j'utilise car la moitié des mot(fichier,Edition,...)est en anglais et l'autre est en français 

                                  j'utilise un Windows 64BIT et j'ai téléchargé la version mingw de qt 5.11.1 et mingw 3.0 dans les tools

                                  J'ai desinstaller et réinstaller plusieurs fois les versions de s'y mais en vain

                                  en espérant que quelqu'un trouve une solution 

                                  et merci d'avance pour vos futures reponse 

                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                    27 juillet 2018 à 4:08:19

                                    Bonjour,

                                    je suis le cours de C++ et je viens de commencer la partie avec Qt, mon problème c'est que quand j'essaie d’exécuter un des exemples en utilisant le fichier ".exe" et après avoir ajoute le fichier "dll" demandé, le programme montre une erreur avec le code 0xc000007b,mais à l'intérieur de Qt le programme marche sans problème.

                                    je ne comprends pas où est le problème,

                                    merci pour votre aide

                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                      21 août 2018 à 21:51:04

                                      Bonjour, je suis débutant avec, et déjà mon premier programme ne marche pas. je sais où pourrait se trouver le problème.Merci d'avance pour vos propositions.

                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        3 septembre 2018 à 13:38:41

                                        salut mon problème est au niveau de la creation d'un nouveau projet 

                                         quand je veux enregistrer un projet , on me dit que j'ai pas de kit comme un compileur ou un debugger

                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          25 septembre 2018 à 14:25:28

                                          Sinon pourquoi pas eviter les IDE, mais plutôt utiliser des fichiers "makefile". On peut le faire aussi sous Windows grace à Mingw.

                                          Un editeur de texte leger du type Notepad++ ou TextAdept, une fenetre de terminal ouverte à côté et en avant Gingamp.

                                          -
                                          Edité par Dri2N 25 septembre 2018 à 14:30:33

                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            25 septembre 2018 à 15:22:17

                                            1. parce que utiliser QtCreator fonctionne en 1 click (tout est deja configuré)

                                            2. parce que ecrire un makefile est chiant

                                            3. parce que ecrire des makefile a notre epoque, c'est une perte de temps

                                            • Partager sur Facebook
                                            • Partager sur Twitter

                                            Rejoignez le discord NaN pour discuter programmation.

                                              25 septembre 2018 à 18:08:57

                                              Peut être bien mais il faut esperer ne pas avoir la masse de problemes que les gens semblent avoir à en croire ce topic.
                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                25 septembre 2018 à 19:09:40

                                                1. Si tu relis les messages, tu verras que beaucoup ont des problèmes parce qu'ils n'ont pas lu le tuto. L'installation de Qt, c'est presque 2-3 clics (bon, j'exagere un peu)

                                                2. avoir des problème avec cette methode ne veut pas dire qu'une methode alternative, comme les makefiles, n'aura pas de problème. Et vu comment les makefiles, c'est chiant et complexe, on peut meme s'attendre a avoir plus de problème avec ca. (C'est pas pour rien qu'on a arreté de faire des makefiles a la main)

                                                • Partager sur Facebook
                                                • Partager sur Twitter

                                                Rejoignez le discord NaN pour discuter programmation.

                                                  28 janvier 2019 à 23:07:47

                                                  Bonjour,

                                                  Merci pour le tuto et les explications. Malheureusement je suis aussi bloqué sur Qt lors de la compilation. J'ai bien lu le tuto, désinstallé et réinstallé le logiciel.

                                                  Il y a quelques écarts par rapport au tuto car je suis sur Linux (Lubuntu) 32 bits.

                                                  Voici ma version de Qt : Qt 3.5.1 basé sur Qt 5.5.1 (GCC 4.9.1 20140922 (Red Hat 4.9.1-10), 32 bit)

                                                  Lorsque je clique sur le triangle vert en lançant le projet test présenté dans le tuto, voici le message d'erreur qui s'affiche :

                                                  Impossible de démarrer le processus "make"

                                                  Erreur lors de la compilation/déploiement du projet test-qt (kit : Desktop Qt 5.5.1 GCC 32bit)

                                                  When executing step "Make"


                                                  J'ai pourtant bien installé le compilateur g++ à l'aide de la commande : sudo apt-get install g++.


                                                  Je vous remercie d'avance si vous avez une idée d'où vient le problème car là je bloque complètement.



                                                  • Partager sur Facebook
                                                  • Partager sur Twitter
                                                    29 janvier 2019 à 1:52:35

                                                    Je n'ai pas testé l'installation sur Linux depuis longtemps. Installes le paquet "build-essential" peut etre.
                                                    • Partager sur Facebook
                                                    • Partager sur Twitter

                                                    Rejoignez le discord NaN pour discuter programmation.

                                                      29 janvier 2019 à 21:59:50

                                                      Merci, j'ai installé le paquet build-essential et cette fois-ci la compilation démarre bien mais j'ai un nouveau message d'erreur et la fenêtre ne s'ouvre pas...

                                                      /usr/bin/ld: cannot find -lGL

                                                      Makefile:220: recipe for target 'test-qt' failed

                                                      collect2: error: ld returned 1 exit status

                                                      make: *** [test-qt] Error 1

                                                      21:56:15: Le processus "/usr/bin/make" s'est terminé avec le code 2.

                                                      Erreur lors de la compilation/déploiement du projet test-qt (kit : Desktop Qt 5.5.1 GCC 32bit)

                                                      When executing step "Make"

                                                      -
                                                      Edité par QuentinZ 29 janvier 2019 à 22:00:33

                                                      • Partager sur Facebook
                                                      • Partager sur Twitter
                                                        29 janvier 2019 à 22:32:19

                                                        Ok. Ca, c'est dû a OpenGL, qui est manquant sur ton ordi. Il faut installer les paquets de développement d'OpenGL. Je ne suis pas sur de ce qu'il faut installer au minimum, essaies "libglu1-mesa-dev".

                                                        (Désolé, je compile Qt sur Linux donc j'ai installé tous les outils de devs. C'est pour ça que je n'avais pas ces erreurs. Je mets a jour le tutoriel. Merci)

                                                        Hors sujet : Qt 5.5.1 est une veille version. La version actuelle est 5.12. Tu devrais peut etre installer Qt via directement le site officiel qt.io et pas depuis les paquets. (Ubuntu est souvent en retard pour les paquets)

                                                        -
                                                        Edité par gbdivers 29 janvier 2019 à 22:33:53

                                                        • Partager sur Facebook
                                                        • Partager sur Twitter

                                                        Rejoignez le discord NaN pour discuter programmation.

                                                          29 janvier 2019 à 22:49:28

                                                          J'ai donc installé OpenGL avec la commande "sudo apt-get install libglu1-mesa-dev" sur le terminal.

                                                          Et parfait cela fonctionne enfin ! Plus de message d'erreur et la fenêtre s'affiche bien !

                                                          Merci beaucoup pour ces infos !

                                                          Pour la version de Qt, je l'ai bien installée depuis le site. J'imagine que la version 32-bits n'est plus mise à jour...

                                                          • Partager sur Facebook
                                                          • Partager sur Twitter
                                                            29 janvier 2019 à 22:59:42

                                                            Pourquoi 32b ?
                                                            • Partager sur Facebook
                                                            • Partager sur Twitter

                                                            Rejoignez le discord NaN pour discuter programmation.

                                                              29 janvier 2019 à 23:21:31

                                                              Parce qu'a priori la version 64bits ne tournera pas sur mon vieux pc...

                                                              Je l'ai donc téléchargé ici.

                                                              https://www.qt.io/download-thank-you?os=linux32

                                                              • Partager sur Facebook
                                                              • Partager sur Twitter

                                                              A lire absolument pour installer Qt !

                                                              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                              • Editeur
                                                              • Markdown