Partage
  • Partager sur Facebook
  • Partager sur Twitter

Ansible - Problème avec install-apache.yml

Sujet résolu
    12 avril 2022 à 12:47:15

    Bonjour,

    J'essaye de revenir sur la formation https://openclassrooms.com/fr/courses/2035796-utilisez-ansible-pour-automatiser-vos-taches-de-configuration  que j'avais commencé il y a quelques mois. 

    Mais au moment d'exécuter les playbook, Je rencontre un problème le playbook d'installation d'apache install-apache.yml

    J'ai un message d'erreur m'indique un conflit. 

    fatal: [http1]: FAILED! => {"changed": false, "failures": [], "msg": "Depsolve Error occured: \n Problem: conflicting requests\n  - nothing provides redhat-release >= 8.5 needed by remi-release-8.5-3.el8.remi.noarch", "rc": 1, "results": []}

    (ansible) [user-ansible@node-manager ~]$ ansible-playbook -i inventaire.ini --user user-ansible --become --ask-become-pass install-apache.yml
    [DEPRECATION WARNING]: Ansible will require Python 3.8 or newer on the controller starting with Ansible 2.12. Current version: 3.6.8 (default, Dec  5 2019, 15:45:45) [GCC 8.3.1 20191121 (Red Hat 8.3.1-5)]. This
    feature will be removed from ansible-core in version 2.12. Deprecation warnings can be disabled by setting deprecation_warnings=False in ansible.cfg.
    BECOME password:
    
    PLAY [Installation apache] ***********************************************************************************************************************************************************************************************
    
    TASK [Gathering Facts] ***************************************************************************************************************************************************************************************************
    ok: [http1]
    
    TASK [apache : apache installation] **************************************************************************************************************************************************************************************
    ok: [http1]
    
    TASK [apache : apache service activation] ********************************************************************************************************************************************************************************
    ok: [http1]
    
    TASK [apache : epel activation] ******************************************************************************************************************************************************************************************
    ok: [http1]
    
    TASK [apache : epel repo activation] *************************************************************************************************************************************************************************************
    ok: [http1]
    
    TASK [apache : remi repo activation] *************************************************************************************************************************************************************************************
    fatal: [http1]: FAILED! => {"changed": false, "failures": [], "msg": "Depsolve Error occured: \n Problem: conflicting requests\n  - nothing provides redhat-release >= 8.5 needed by remi-release-8.5-3.el8.remi.noarch", "rc": 1, "results": []}
    
    PLAY RECAP ***************************************************************************************************************************************************************************************************************
    http1                      : ok=5    changed=0    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0
    

    Voici le contenu de mon role roles/apache/tasks/php-install.yml 

    #1. Cette tâche installe le dépôt EPEL (Extra Packages for Enterprise Linux)
    - name: "epel activation"
      dnf:
        name: "epel-release"
        state: present
    
    #1a. Cette tâche installe le dépôt EPEL pour les paquets PHP7
    - name: "epel repo activation"
      dnf:
        name: "https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm"
        state: present
    
    #2. Cette tâche installe le dépôt REMI pour bénéficier du paquet PHP7
    - name: "remi repo activation"
      dnf:
        name: "https://rpms.remirepo.net/enterprise/remi-release-8.rpm"
        state: present
    
    #3. Cette tâche installe PHP7 et ses extensions
    - name: "install php70 packages"
      dnf:
        name: "php,php-mysqlnd,php-xml,php-mbstring,php-mcrypt,php-gd,php-intl"
        state: latest
        enablerepo: "remi-php70"
        changed_when: yes
        notify: [ "apache restart" ]
    
    


    Pourriez vous m'éclairer sur ce sujet svp 


    Merci d'avance


    • Partager sur Facebook
    • Partager sur Twitter
      13 avril 2022 à 10:09:25

      Bonjour,

      le cours utilise CentOS7 et pas CentOS8. J'ai fait une erreur similaire il y a quelques semaines.

      Voici une piste: https://openclassrooms.com/forum/sujet/ansible-failed-to-validate-gpg-signature-for-remi

      Bye.

      • Partager sur Facebook
      • Partager sur Twitter
        13 avril 2022 à 12:18:16

        Bonjour, 

        Oui en effet c'étati ça le conflit.

        Merci 

        • Partager sur Facebook
        • Partager sur Twitter

        Ansible - Problème avec install-apache.yml

        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
        • Editeur
        • Markdown