Partage
  • Partager sur Facebook
  • Partager sur Twitter

ARDUINO QUI S'ALLUME TOUT SEUL

    22 juin 2019 à 13:28:21

    Bonjour,
    J'ai crée il n'y a pas longtemps un distributeur à croquettes (commandé part l'aduino) et avec un distributeur à eau intégré. Mais avant, quand j'appuyais sur le bouton pour faire tomber les croquettes, je devais appuyer longtemps dessus, j'ai donc remarqué que le programme dans l'Arduino avait une petite erreur. Je l'ai donc modifiée et maintenant, quand j'appuie sur le bouton, les croquettes tombent instantanément mais le seul problème c'est quand j'appuie sur le bouton pour l'eau (l'eau coule aussi très bien), et bien c'est l'Arduino qui se met à faire tomber les croquettes. 
    Je rappelle que la carte Arduino n'est pas du tout connectée à la pompe à eau ni à son bouton, ce sont deux circuits différents mais brancher sur le même secteur.
    Je vous laisse : le schéma de la machine; des photos du câblage; le programme arduino.
    On m'avait dit que cela serait dû peut-être au parasite.
    https://drive.google.com/drive/folders/1cChNct_II55wluMHiRM95hv5rXCEaG8z?usp=sharing
    • Partager sur Facebook
    • Partager sur Twitter
      Staff 22 juin 2019 à 14:28:27

      Bonjour,

      Majuscules abusives

      L'écriture en majuscules est considérée comme une parole criée et diminue autant la lisibilité du texte que sa compréhension. Les majuscules abusives sont donc interdites aussi bien dans les titres que dans les messages.

      Merci de modifier votre titre.

      • Partager sur Facebook
      • Partager sur Twitter
        22 juin 2019 à 15:08:52

        Bonjour,

        le programme semble utiliser l'entrée 2, mais on ne voit pas ce qui est connecté dessus et comment c'est fait.

        • Partager sur Facebook
        • Partager sur Twitter
          23 juin 2019 à 10:39:31

          Bonjour,

          Dans mon cas, c'est le bouton qui est en pin 2, sauf que quand je met le 2 en pinMode 2 le programme ne fonctionne plus.

          • Partager sur Facebook
          • Partager sur Twitter
            Staff 23 juin 2019 à 10:49:42

            @MaximeDavid9 bonjour, mon message plus haut n'est pas la pour faire joli, merci de modifier votre titre, dans le cas contraire je serais contrains de fermer ce sujet.
            • Partager sur Facebook
            • Partager sur Twitter
              23 juin 2019 à 16:36:39

              MaximeDavid9 a écrit:

              Dans mon cas, c'est le bouton qui est en pin 2, sauf que quand je met le 2 en pinMode 2 le programme ne fonctionne plus.

              Oui, mais comment est-il connecté ? Entre la masse et la broche 2 ou entre VCC et la broche 2 et surtout y-a-t'il une résistance de pull-up (s'il est connecté à la masse, entre la broche 2 et VCC) ou de pull-down (s'il est connecté à VCC, entre la broche 2 et la masse) pour définir l'état de la broche 2 quand le bouton n'est pas appuyé. Sans résistance de pull-up/pull-down, la broche et le fil qui la connecte au bouton font office d'antenne radio et les perturbations électromagnétiques aux alentours (comme un moteur) peuvent modifier l'état de la broche.

              Je t'invite à consulter un tuto sur l'utilisation des boutons avec l'arduino: https://eskimon.fr/tuto-arduino-204-un-simple-bouton

              • Partager sur Facebook
              • Partager sur Twitter

              ARDUINO QUI S'ALLUME TOUT SEUL

              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
              • Editeur
              • Markdown