Partage

Balise <img> ne fonctionne pas

7 janvier 2018 à 19:31:50

Bonsoir,

Je fais un site WP, et j'ai besoin d'afficher une image dans un lien ( un bouton youtube en jpg, dans un lien pour pouvoir amener le visiteur vers la vidéo en question ).

Pour rendre les choses plus simples j'ai mis toutes les images du site dans un dossier  "pic" dans le dossier thème enfant du site. 

Donc j'ai mis ça comme code :

<a href="<?php echo $videoID ?>"><img class="ytButton" src="pic/bouton_youtube.jpg" alt="bouton youtube"></a>
                        
                        <img src="pic/ytbutton.jpg"/>

                        <a href="https://www.w3schools.com"><img border="0" alt="W3Schools" src="pic/bouton_youtube.jpg" width="100" height="100"></a>

J'ai essayé 3 versions. ( celle du centre étant juste une version de " débug " avec une image différente, juste histoire de voir si mon image a un problème ou pas ).

Le résultat : 

http://prntscr.com/hxafgq

Je sais pas du tout ce qui cloche :( 

Des idées ?

Merci !

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
en ligne
Financée
à 100%
7 janvier 2018 à 21:54:13

Salut,

Le dossier "pic" se trouve dans le dossier de ton thème, je présume ? 

https://codex.wordpress.org/Function_Reference/get_template_directory 

Il n'y a pas de mauvais navigateur, il n'y a que du mauvais code !
13 janvier 2018 à 0:42:30

Salut !

Désolé pour le retard, et oui "pic" se trouve à la racine du thème enfant. Je vais essayer ça demain : 

<a href="<?php echo $videoID ?>"><img class="ytButton" src="<?php get_stylesheet_directory() ?>/pic/bouton_youtube.jpg" alt="bouton youtube"></a>


Merci :) !

Staff 13 janvier 2018 à 8:00:23

Bonjour,

makmal, c'est plutôt get_stylesheet_directory_uri qu'il te faudra, car get_stylesheet_directory renvoie un chemin "serveur" (voir l'exemple sur  https://codex.wordpress.org/Function_Reference/get_stylesheet_directory et toi tu veux une URI.

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!

Balise <img> ne fonctionne pas

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown