Partage
  • Partager sur Facebook
  • Partager sur Twitter

[Code::Blocks] La touche espace ne fonctionne plus

uniquement avec code::blocks

Sujet résolu
    23 avril 2008 à 19:28:04

    Bonjour,

    voilà j'ai un petit problème depuis ce matin : lorsque je tape du code dans Code::Blocks tout fonctionne sauf la barre d'espace. Le seul moyen que j'ai d'inclure un espace est de copier/coller un espace que j'avais tapé ultérieurement. De plus les espaces fonctionnent correctement dans les autres programmes (firefox, openoffice.org, gedit, ...). Je ne comprend pas puisque je n'ai rien touché (ou alors je m'en suis pas rendu compte). Hier encore tout fonctionnait. Je suis actuellement sur Ubuntu 8.04.

    Ha oui, j'ai posté ce message dans la section C++ parce que je ne savais pas trop où le mettre, mon problème concernant un IDE particulier, milles excuses s'il n'est pas au bon endroit.
    • Partager sur Facebook
    • Partager sur Twitter
      23 avril 2008 à 23:35:30

      Regarde dans les raccourcis clavier de Code Blocks, tu as peut etre introduit la touche "espace" comme raccourci pour faire un truc sans t'en rendre compte...du coup normal qu'elle ne fasse pas ce qu'on attend d'elle.
      • Partager sur Facebook
      • Partager sur Twitter
        24 avril 2008 à 11:58:20

        J'ai essayé de désinstaller Code::Blocks, de supprimer tous les fichiers de configuration puis de tout réinstaller et rien n'y fait, j'ai toujours le même problème. Je ne comprend pas d'où il peut venir. J'ai cherché mais n'ai pas trouvé le menu pour changer les racourcis (il semblerait qu'il y ait un plugin le permettant mais celui-ci n'est pas installé, je ne comprend donc pas pourquoi, du jour au lendemain cette fichue touche espace ne fonctionne plus correctement.
        En fait quand j'appuie dessus, cela ouvre la liste déroulante des propositions (pour l'auto-complétion de code), comme si j'appuyais sur ctrl + espace. J'ai vérifié et le racourci dans les paramètres pour l'auto-complétion est bien ctrl + espace, donc pourquoi quand j'appuie sur espace il se produit cela ...

        J'ai oublié de le préciser, peut-être que cela est important, je suis sur un portable ASUS.
        • Partager sur Facebook
        • Partager sur Twitter
          25 avril 2008 à 7:09:25

          Bonjour,

          j'ai le même problème sous ubuntu depuis la migration vers la 8.04, si quelqu'un avait la soluce ca serait sympa.

          merci.
          • Partager sur Facebook
          • Partager sur Twitter
            25 avril 2008 à 14:15:24

            heu en fait, je viens de me rendre compte que pour faire un espace il faut faire la combinaison ctrl + alt + espace.
            Avouez que c'est tout de même pas très pratique, ça ralentit grandement la frappe. Personnellement j'ai arrêté de chercher, après de nombreuses recherches en vain je suis un peu découragé. Je me suis donc mis à emacs, je découvre peu à peu ...

            Si quelqu'un avait la solution pour faire revenir la touche espace ce serait fort aimable à lui de nous en faire part :D .
            • Partager sur Facebook
            • Partager sur Twitter
              25 avril 2008 à 21:27:44

              Si tu veux quelque chose de simple et TRES pratique, si tu es sous windows, prend notepad++ (pour la coloration syntaxique et autre) et installe mingw32, tu seras vraiment tranquille et tu te rendras compte que pour n'importe quel projet, tu n'as PAS besoin d'un IDE, à part pour le mode debug.

              Si tu es sous linux, tu as Gedit sous gnome et Kate sous Kde qui font ça très bien, suffit de compiler avec gcc/g++.

              Sous Mac, Xcode est bien, et gcc/g++ sont encore là.

              • Partager sur Facebook
              • Partager sur Twitter
                26 avril 2008 à 16:38:26

                oui oui, je sais mais bon ... j'aime bien avoir une seule fenêtre pour tout faire. En plus le débuggeur est bien pratique pour trouver certaines erreurs :-° . M'enfin bon, pour l'instant je code avec emacs, découvrant peu à peu les options et je dois dire que j'en suis plutôt satisfait.

                Sinon j'ai cherché un peu et il semblerait que cela vienne d'ubuntu lui même ... d'autres personnes ont le même problème avec la recherche dans rhythmbox (je viens de vérifier et moi aussi), impossible de taper un espace dans la barre de recherche.
                • Partager sur Facebook
                • Partager sur Twitter
                  27 avril 2008 à 16:24:11

                  Je confirme, cela vient de Ubuntu. Depuis que je suis passé à Hardy, impossible d'utiliser la touche espace sous CodeBlock :(
                  J'utilise Geany en remplacement. Il est léger et permet de compiler facilement ses projets, puisque il fait appel à g++ ou gcc tout seul (F8 F9 et c'est bon :))
                  De plus on peut les executer directement depuis Geany. C'est une sorte de mini IDE supportant de nombreux langages (je m'en sers aussi pour Python).
                  • Partager sur Facebook
                  • Partager sur Twitter
                  Anonyme
                    27 avril 2008 à 17:08:37

                    J'ai eu ce problème : il suffit de désactiver le plugin Code Completion dans le menu Plugins -> Manage plugins -> Disable.
                    • Partager sur Facebook
                    • Partager sur Twitter
                      27 avril 2008 à 17:45:51

                      Dans le fichier /etc/X11/xorg.conf pour les linuxiens, commenter la ligne 'Option "XkbVariant" "oss"' et relancez X ;)
                      • Partager sur Facebook
                      • Partager sur Twitter
                        27 avril 2008 à 18:00:19

                        merci beaucoup, ca remarche parfaitement
                        • Partager sur Facebook
                        • Partager sur Twitter
                          1 mai 2008 à 22:49:21

                          ha voilà une bonne nouvelle, je n'avais pas cherché depuis quelques jours et maintenant le problème est réglé,merci Truffaut ^^ .
                          • Partager sur Facebook
                          • Partager sur Twitter
                            3 mai 2008 à 16:00:21

                            Salut à tous! :)

                            J'ai eu le même problème, et après pas mal de recherche, j'ai trouvé une autre solution, ne nécessitant ni la modification du xorg, ni la désactivation d'un quelconque plugin :
                            Système>Préférence>Clavier
                            Onglet arrangement
                            Bouton "Options de l'agencement..."
                            Dernier menu déroulant "Using space key to input non breakable character"

                            L'option est "Par défaut"
                            je coche la seconde option : "Space key output usual space at any level", et la touche espace remarche correctement avec C::B!

                            Pour moi, ça à été la seule solution (La modification du xorg ne marchait pas, et à part désactiver le plugin (mais ça, j'ai pas voulu ^^ ), rien n'à marché, sauf ça.)

                            ;)

                            Ps: j'ai la version SVN 5027.
                            • Partager sur Facebook
                            • Partager sur Twitter
                              4 mai 2008 à 16:13:23

                              Citation : Dagrut

                              Salut à tous! :)

                              J'ai eu le même problème, et après pas mal de recherche, j'ai trouvé une autre solution, ne nécessitant ni la modification du xorg, ni la désactivation d'un quelconque plugin :
                              Système>Préférence>Clavier
                              Onglet arrangement
                              Bouton "Options de l'agencement..."
                              Dernier menu déroulant "Using space key to input non breakable character"

                              L'option est "Par défaut"
                              je coche la seconde option : "Space key output usual space at any level", et la touche espace remarche correctement avec C::B!

                              Pour moi, ça à été la seule solution (La modification du xorg ne marchait pas, et à part désactiver le plugin (mais ça, j'ai pas voulu ^^ ), rien n'à marché, sauf ça.)

                              ;)

                              Ps: j'ai la version SVN 5027.


                              merci a toi c'est moi que modifier ce truc :-° j'ai essayé et ça marche super
                              • Partager sur Facebook
                              • Partager sur Twitter
                                19 juillet 2008 à 9:21:14

                                Merci beaucoup !
                                J'ai eu le même probleme mais je n'ai pas été si courageux j'ai craqué et je programmé sous Xp.Je vais enfin pouvoir rebooté sous Ubuntu.

                                SOULAGEMENT...

                                Merci encore

                                -
                                Edité par Benux12 10 mai 2013 à 21:24:44

                                • Partager sur Facebook
                                • Partager sur Twitter
                                  24 août 2008 à 22:01:56

                                  Citation : Dagrut

                                  Salut à tous! :)

                                  J'ai eu le même problème, et après pas mal de recherche, j'ai trouvé une autre solution, ne nécessitant ni la modification du xorg, ni la désactivation d'un quelconque plugin :
                                  Système>Préférence>Clavier
                                  Onglet arrangement
                                  Bouton "Options de l'agencement..."
                                  Dernier menu déroulant "Using space key to input non breakable character"

                                  L'option est "Par défaut"
                                  je coche la seconde option : "Space key output usual space at any level", et la touche espace remarche correctement avec C::B!

                                  Pour moi, ça à été la seule solution (La modification du xorg ne marchait pas, et à part désactiver le plugin (mais ça, j'ai pas voulu ^^ ), rien n'à marché, sauf ça.)

                                  ;)

                                  Ps: j'ai la version SVN 5027.



                                  sous linux, il n'y a plus d'auto-complétion apres la modification suivant cette méthode ... quelqu'un peut me dire si c'est le meme cas si on bidouille le fichier xorg.conf?
                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                  Anonyme
                                    11 juin 2010 à 0:36:40

                                    Moi c'est la touche ">" qui ne marche plus. J'ai chercher sur internet mais personne ne semble avoir le même problème que moi.J'ai vérifier mes raccourci clavier et pourtant rien de spécial.
                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                      20 avril 2012 à 13:41:46

                                      pour ceux qui on une version dubuntu plus récente il faut aller dans paramètre système>clavier>paramètres d'agencement>réinitialiser aux valeurs par défaut.
                                      cela devrais résoudre tous les problèmes de clavier.
                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                      Anonyme
                                        5 mai 2012 à 20:27:18

                                        Bonjour,
                                        Il est également possible de supprimer le clavier actuel (dans Système>Clavier>Options d'agencement), puis d'en ajouter un nouveau, en sélectionnant le clavier Français, sans les variantes entre parenthèses que propose Ubuntu. Pour moi, j'avais un "Français (Variante)", je l'ai supprimé en ai ajouté le "Français", et maintenant tout marche.
                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          15 mai 2012 à 17:45:59

                                          Merci Gerum le grand, votre solution est simple et fonctionne sur les versions récentes d'Ubuntu
                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            3 septembre 2012 à 10:07:18

                                            Merci Gerum le grand pour l'info.
                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                              21 décembre 2016 à 18:54:37

                                              J'ai un petit problème : quand j'écris des mails (et uniquement  la!) mon clavier de tablette  tactile refuse de faire les espaces  entre les mots....que faire??? J'ai  cherché  dans les paramètres  du clavier, mais j'ai  rien trouvé!!! Et j'avais  rie touché en plus!!! Ça me fait le coup que j' écris en français  ou dans une autre  langue. Comment faire pour arranger ça? Merci d' avance!
                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                22 décembre 2016 à 15:31:52

                                                Faudrait peut-être arrêter de déterrer les posts de plus de 4 ans...
                                                • Partager sur Facebook
                                                • Partager sur Twitter

                                                Si vous ne trouvez plus rien, cherchez autre chose.

                                                [Code::Blocks] La touche espace ne fonctionne plus

                                                × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                                • Editeur
                                                • Markdown