Partage

Commande :hover qui ne fonctionne pas

Sujet résolu
31 décembre 2017 à 15:05:55

Bonjour,

J'aimerai que tous mes liens passent en gras quand on pointe avec la souris, cependant quand je tape la commande :hover cela ne fait rien du tout, comme si le logiciel ne le reconnaissait pas... Voici un screenshot:

Merci pour votre aide !

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
en ligne
Financée
à 100%
31 décembre 2017 à 15:10:26

Merci pour ta réponse, mais ca ne change rien, la commande :hover semble toujours inactive ... :(
31 décembre 2017 à 15:12:15

peut-on voir ton code HTML aussi ? 

Dans la capture ton onglet est à l'état avec un point -> non enregistré.

Tenter de vider le cache du navigateur au cas ou...

-
Edité par Lucky13 31 décembre 2017 à 15:13:24

31 décembre 2017 à 15:17:41

Bon je n'arrive plus à envoyer de réponse du coup je vous remercie ici ! J'ai renommé le fichier et vidé le cache et ca fonctionne maintenant ! Merci beaucoup !! ^^

-
Edité par Madylune 31 décembre 2017 à 15:33:18

31 décembre 2017 à 15:20:16

j'aurai préféré que tu postes ton code via l'icône </> + choix du langage de l'éditeur ^^ 

je répète :

- Dans la capture je vois un point dans l'onglet CSS -> est-il bien enregistré.

- Travailles tu sur le bon fichier .css

- Tenter de vider le cache du navigateur...

-
Edité par Lucky13 31 décembre 2017 à 15:21:50

31 décembre 2017 à 15:23:49

1) Le nom de tes fichiers .html ne doit pas contenir d'espace donc déjà renomme en page_1.html ou page1.html

2) Ouvres ton fichier html avec ton navigateur et fais ctrl + u, cliques sur le lien style.css et vérifies qu'il y a bien le a:hover (pour vérifier le problème de cache)

-
Edité par Delboar 31 décembre 2017 à 15:24:12

31 décembre 2017 à 15:36:58

Sous windows cela  ne pose pas de problème, page 1 chapitre 2.html est valide. (j'ai testé)

C'est un espace avec l'extension qui serait problématique.

Après tu as raison, il faut l'éviter et les remplacer par un tiret- ou undescore 

31 décembre 2017 à 15:40:28

Le problème est réglé merci !!

J'ai renommé le fichier et vidé le cache :)

-
Edité par Madylune 31 décembre 2017 à 15:40:51

31 décembre 2017 à 15:47:13

Cool,

Bon quand tu travaille utilise la console web de ton navigateur, c'est très très utile, et vider le cache de temps en temps.

Sinon petite astuce :

<link rel="stylesheet" href="style.css?v=1" />

Le paramètre évite le problème de MàJ du cache (on peut aussi le générer en JS ou langage serveur)

Bonne fête de fin d'année.

31 décembre 2017 à 19:13:08

Astuce: quand tu fais un truc en css, pour actualiser ta page, fais ctrl+f5, ça recharge tout a 0, contrairement au refresh normal. bonne année 2018 :)
1 janvier 2018 à 12:03:21

Merci pour ces astuces !!

Meilleurs vœux pour 2018 ! ;)

Commande :hover qui ne fonctionne pas

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown