Partage

Conformité Explorer 8 et antérieurs

6 février 2018 à 13:04:57

Bonjour,

J'ai un souci avec le site qui ne veux plus s'afficher dans les anciens navigateurs explorer. Voilà 3 jours que je cherches et essayes des solutions mais rien ne fonctionne...pourriez-vous m'aider?

Merci.

Et que vive le cirque! www.lesfeesbohemes.com

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
en ligne
Financée
à 100%
Staff 6 février 2018 à 13:25:22

Bonjour,

tu ne donnes pas de code, et encore moins l'adresse du site. Tu ne décris pas ce qui se passe exactement ("ne veut plus s'afficher", ça veut tout et rien dire). Comment pourrions-nous t'aider ?

Et tu as vraiment besoin de supporter Internet Explorer 8 sur ton site ? Il est utilisé à hauteur de 0.2% en France…

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
10 février 2018 à 15:27:09

Bonjour et pardon de répondre si tard, je ne sais comment activer les notifications par mail des réponses aussi je pensais ne pas en avoir eu...

Oui, il m'importe de pouvoir afficher sous IE8,ne serais-ce que pour nos "anciens" qui ont encore xp juste pour les mails et les photos et à qui cette configuration suffit, donc j'aimerais qu'ils aient accès au site...

Vous avez l'air d'avoir de très bon niveaux de codage aussi c'est pour cela que je pose ma question ici.

Effectivement "Ne veux plus s'afficher" c'est vague, c'est à dire que je pouvais le visualiser avant, au départ de sa conception, je suis passée ensuite il y a quelques années à firefox, sans me soucier de la compatibilité,jusqu'à ce qu'on me signale qu'il n'était pas visible sous IE, donc je ne sais pas ce que j'ai pu toucher (surement dans les entêtes car aucunes pages ne vient) pour que cela soit ainsi.

Le site est: www.lesfeesbohemes.com.

Quel code dois-je mettre, vu qu'il s'agit de "tout le site"...

Merci

Et que vive le cirque! www.lesfeesbohemes.com
10 février 2018 à 17:12:11

Salut,

Il n'y a pas "un code à mettre" pour qu'un site devienne fonctionnel. Il faut que l'ensemble du code soit bon et pensé pour la rétrocompatibilité.

Et la première chose, c'est d'avoir un code html valide: https://validator.w3.org/check?uri=https%3A%2F%2Fwww.lesfeesbohemes.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0 

Il n'y a pas de mauvais navigateur, il n'y a que du mauvais code !
Staff 10 février 2018 à 17:25:06

> Oui, il m'importe de pouvoir afficher sous IE8,ne serais-ce que pour nos "anciens" qui ont encore xp juste pour les mails et les photos et à qui cette configuration suffit, donc j'aimerais qu'ils aient accès au site...

Ça se comprend :) Mais peut-être qu'un peu d'éducation desdits anciens, en leur indiquant des navigateurs plus sûrs, moins passoires, et supportant les nouveautés, ça serait pas mal ?

Quoi qu'il en soit : premier point, corriger les erreurs de validation du HTML. Tu peux les voir là : https://validator.w3.org/check?uri=https%3A%2F%2Fwww.lesfeesbohemes.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

IE8 est très sensible à ces erreurs, et va cesser très vite de créer le rendu s'il en rencontre une.

(ah, grillée : voilà ce que c'est d'écrire avant manger et d'oublier de poster)

-
Edité par Lamecarlate 10 février 2018 à 17:25:40

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
10 février 2018 à 18:15:48

Le validateur je suis dessus en ce moment, si ça peux venir de là le souci alors ça me rassure un peu, IE6 aussi y est sensible? Ou juste il n'accepte pas les doctypes récents?
Et que vive le cirque! www.lesfeesbohemes.com
Staff 10 février 2018 à 18:18:38

Oui alors IE6, il faut vraiment oublier… Il n'y a plus personne avec ça - ne serait-ce que parce que Windows XP force la mise à jour vers le 8.
Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
11 février 2018 à 15:20:42

...Ok...

C'est moi ou le validateur W3C valide tout aujourd'hui?

Même les erreurs volontaires il me les accepte...

https://validator.w3.org/unicron

et

https://jigsaw.w3.org/css-validator/validator?uri=https%3A%2F%2Fwww.lesfeesbohemes.com&profile=none&usermedium=all&warning=2&vextwarning=&lang=fr

Ou je n'ai pas les bons liens?

Et que vive le cirque! www.lesfeesbohemes.com
Staff 11 février 2018 à 15:23:31

C'est parce que "Jigsaw" c'est pour le CSS :)

rhooManu et moi-même t'avons donné le bon lien.

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
13 février 2018 à 6:30:14

c'est pourtant bien dans le style que j'incluais des erreurs...avant-hier encore il y avait des "erreurs grammaticales"
Et que vive le cirque! www.lesfeesbohemes.com

Conformité Explorer 8 et antérieurs

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown