Partage

[ Cordova ] Changer la cible de déploiement

Sujet résolu
9 mai 2018 à 12:19:49

Bonjour, je développe une application Cordova et pour android j'utilise le SDK avec l'API 21 à l'API 26

Mais Cordova me build l'appli avec pour cible l'API 26 et je peux donc pas déployer sur une version inférieur à Android Nougat,

Comment puis-je changer cela ? ( Je voudrais déployer sur Lollipop, Marshmallow et Nougat)

Merci

L'informatique n'est pas parfait mais l'être humain non plus !

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
certifiante
Financée
à 100%
9 mai 2018 à 13:03:56

Salut. Dans le fichier si tu modifies cette ligne dans le fichier config.xml ça donne quoi?

<preference name="android-minSdkVersion" value="21" />



9 mai 2018 à 14:30:38

Je pense pas que ce soit cela car ça change rien et que dans mon AndroidManifest.xml j'ai android-minSdkVersion="16"

Le problème se pose sur la cible de build et je vois comment faire ...

L'informatique n'est pas parfait mais l'être humain non plus !
15 mai 2018 à 9:14:30

Bonjour, avec ceci ?

<preference name="android-targetSdkVersion" value="21" />
<preference name="android-minSdkVersion" value="21" />



15 mai 2018 à 12:01:17

J'ai l'impression que cela fonctionne, merci :)
L'informatique n'est pas parfait mais l'être humain non plus !
16 mai 2018 à 18:02:53

Même si ton problème est résolu je me permets de préciser que Google à annoncer a la Google IO que à partir de novembre les applications devront obligatoirement être target 26 mini.

Donc si ton application est destiner à être sur le playstore, mieux vaut le faire maintenant histoire de prendre du recul sur d'éventuels bugs ;)

Prepare for the upcoming Play requirement for target API level

As we have announced, Google Play will require new apps (from August 2018) and app updates (from November 2018) to target API level 26 or higher. For more information and practical guidance on preparing for the new requirement, watch the I/O session, Migrating your existing app to target Android Oreo and above, and review our migration guide. If you develop an SDK or library that's used by developers, make sure it's ready to target Oreo too and sign up to receive news and updates for SDK providers.

17 mai 2018 à 11:01:17

Merci pour l'info
L'informatique n'est pas parfait mais l'être humain non plus !

[ Cordova ] Changer la cible de déploiement

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown