Partage
  • Partager sur Facebook
  • Partager sur Twitter

Créer une app VueJS P2C3 Probleme avec router

Sujet résolu
    4 janvier 2021 à 15:12:44

    Bonjour a tous, 

    Je suis au niveau P2C3 du cours sur VueJS.

    Pour s'exercer il faut télécharger l'exercice Begin et Solution. 
    Quand je vais sur Begin, 
    je me positionne sur cafe-with-vue>vli-version 
    Je tape la commande 

    add vue router 

    Et j'ai cette erreur

     ERROR  Error: The project seems to require yarn but it's not installed.
    Error: The project seems to require yarn but it's not installed.
        at checkYarn (C:\Users\Wil\AppData\Roaming\npm\node_modules\@vue\cli\node_modules\@vue\cli-shared-utils\lib\env.js:46:43)
        at exports.hasProjectYarn (C:\Users\Wil\AppData\Roaming\npm\node_modules\@vue\cli\node_modules\@vue\cli-shared-utils\lib\env.js:42:10)
        at new PackageManager (C:\Users\Wil\AppData\Roaming\npm\node_modules\@vue\cli\lib\util\ProjectPackageManager.js:109:11)
        at add (C:\Users\Wil\AppData\Roaming\npm\node_modules\@vue\cli\lib\add.js:50:14)
        at processTicksAndRejections (internal/process/task_queues.js:97:5)

    Ducoup je n'arrive pas a m'exercer sur les routes ... 

    • Partager sur Facebook
    • Partager sur Twitter

    Seul on va plus vite, ensemble on va plus loin. 'KawaBunga'

      29 janvier 2021 à 12:06:30

      J’ai eu le même problème et je l’ai finalement résolu en recréant un projet cli-version de zéro et en récupérant les fichiers de la P2C3-Begin qu’il fallait. Il y en a suffisamment peu pour que ça se fasse bien.
      • Partager sur Facebook
      • Partager sur Twitter
        17 avril 2021 à 17:44:39

        Même problème de mon coté !

        J'ai pu résoudre le problème en installant Yarn: 

        • depuis un terminal, se placer sous le dossier 'cli-version'
        • faire : 
        npm install --global yarn
        yarn install

        -
        Edité par GaelGoogle 17 avril 2021 à 17:45:10

        • Partager sur Facebook
        • Partager sur Twitter
          20 avril 2021 à 11:35:45

          Même problème, je vais essayer vos solutions si j'en trouve pas d'autres
          • Partager sur Facebook
          • Partager sur Twitter
            10 mai 2022 à 10:55:39

            GaelGoogle a écrit:

            Même problème de mon coté !

            J'ai pu résoudre le problème en installant Yarn: 

            • depuis un terminal, se placer sous le dossier 'cli-version'
            • faire : 
            npm install --global yarn
            yarn install

            -
            Edité par GaelGoogle 17 avril 2021 à 17:45:10

            Cette solution a fonctionner pour moi, merci beaucoup :)



            • Partager sur Facebook
            • Partager sur Twitter

            Créer une app VueJS P2C3 Probleme avec router

            × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
            • Editeur
            • Markdown