Partage
  • Partager sur Facebook
  • Partager sur Twitter

Fonctionnement ecran avec arduino.

26 février 2015 à 19:45:59

Bonjour,

J'ai deux écran que je n'arrive pas a faire fonctionner. Le premier est l'ecran robot lcd A000096 Arduino, et l'autre un écran QVGA 2.2 TFT SPI 240*320. Le premier quand je le cable selon les explications du site arduino, j'ai des traits qui s'affiche et rien d'autre. Sur le second j'ai suivi plusieurs schéma et code adafruit et j'ai un écran blanc. Est ce que l'on pourrait m'aider s'il vous plait? 

Merci d'avance.

  • Partager sur Facebook
  • Partager sur Twitter
27 février 2015 à 23:33:05

Salut,

je possède également un QVGA 2.2 TFT SPI 240*320

J'ai rencontré les même problème que toi, c'est à dire écran blanc, mais maintenant ça marche.

J'utilise la bibliothèque "Adafruit ILI9340".

Pour le branchement, j'ai fait comme suit:

SCK - Arduino Pin 13
SDO(MISO) - Arduino Pin 12
SDI(MOSI) - Arduino Pin 11
CS - Arduino Pin 10
D/C - Arduino Pin 9
RESET - Arduino Pin 8
LCD - 3.3V
VCC - 3.3V
GND - GND

Mais si tu fais comme ça, ça ne marche pas, écran blanc.

Ce qu'il faut savoir, c'est que l'écran doit être alimenté en 3.3V (pas juste VCC, mais tout l'écran) et non en 5V comme c'est le cas sur les sortie des pins Arduino. Pour remédier à ça, j'utilise un 74HC4050 qui permet de passer le signal de 5V à 3.3V.

VDD correspond à la tension de sortie souhaité, ici 3.3V, tu branches la sortie 3.3V de l'Arduino à VDD, et  GND à GND sur l'arduino.

Ensuite, il faut brancher tes sorties Arduino sur les entrées A du 4050 (5V), et tu auras sur les sortie Q du 4050 le même signal qu'en A, mais dans la même tension que VDD, ici 3.3V.

Par exemple, pour brancher D/C, tu branches la Pin 9 de l'Arduino sur A1 du 4050 (signal 5V), et la Pin D/C de l'écran sur Q1 (même signal mais en 3.3V), pin 10 sur A2 et Q2 sur sur CS, etc. (en respectant le branchement présenté ci dessus)

Tu fais ça pour toutes les Pins de l'écran sauf GND et MISO que tu branches direct au pins GND et 12 de l'arduino, et tu peux utiliser la même sortie du 4050 pour VCC et LED, car signal continu.

Si tu n'as pas de 4050, tu peux également faire des ponts diviseur avec des résistances. Mais il faut un pont diviseur pour chaque pins de l'écran sauf (comme pour le 4050) GND et MISO que tu branches en direct sur l'arduino, et tu peux utiliser le même pont pour VCC et Led (soit 6 pont diviseur au total).

Pour chaque pont, il faut une résistance R1 et une résistance R2 qui vaut environ 2 fois R1.

Pont diviseur de tension

Sur l'image, Ve correspond à 5V, et VS correspond à 3.3V, en dessous de R2 c'est la masse (GND), au milieu c'est ou tu branches sur l'écran, et en haut c'est la sortie de l'Arduino.

La formule est Vs = Ve * (R2 / (R1+R2)).

Si tu prends par exemple R1 = 4.7k et R2 = 10k, tu auras Vs = 5 *( 10 / (10+4.7)) = 3.4V ~ 3.3V

En espérant que ça peut t'aider.

Sfritz

-
Edité par sfritz 27 février 2015 à 23:56:23

  • Partager sur Facebook
  • Partager sur Twitter
2 mars 2015 à 20:54:23

Merci de ta réponse et désolé pour le retard. Donc si je comprend bien il faut que toute les pins de l'écran reçoivent un signal en 3,3V ? Si c'est sa je trouve que c'est un peu dommage de faire un écran pour lequel un convertisseur de tension est nécessaire.

En tout cas merci pour l'explication qui est bien faites ;). 

Et pour le second écran que j'ai indiqué tu aurais une idée? 

  • Partager sur Facebook
  • Partager sur Twitter
23 mai 2015 à 21:05:35

Bonjour

pour le second ecran A000096  je vient juste de l'achetter c'est celui qui est sur le site arduino le A000096

 http://www.arduino.cc/en/Tutorial/TFTBitmapLogo   http://www.arduino.cc/en/Guide/TFT   

http://www.selectronic.fr/c/robotique-moteurs-accessoires/modules-d-affichage-et-de-visualisation/modules-tft/arduino-afficheur-1-7-pour-la-carte-esplora.html

http://www.gotronic.fr/art-ecran-lcd-1-77-arduino-20517.htm

j'ai eu pareil que toi des bande noir épaissess et des intervalles blanc entre elles, c'est la librairie TFT de aruino 1.0.5r2 ou 1.0.6 qui est mauvaise...

va sur ce lien et télécharge la version proposé

http://www.jameco.com/1/1/52373-a000096-tft-lcd-screen-the-screen-runs-5vdc-shields.html

 tu doit recuperer un zip de 126Ko car le lien en debut de texte de sort un fichier de 5ko qui  n'est pas exploitable

lien de download (prend celui qui est dans le corps du texte dans le bas)  http://www.jameco.com/Jameco/Products/ProdDS/2193459AdditionalFiles.zip

et tu ecrase tout le repertoire TFT que tu as dans ta version de l IDE Arduino attention j'ai testé que sur la version 1.05.r2 et la 1.0.6 seulement (faisant une copie avant si tu veut)

et maintenant ca marche nickel

esperant que ca ira pour toi aussi

 à aufaite j'ai suivi une recommendation j'ai pas raccordé l'ecran au pin +5V de l'arduino Uno mais au PIN +3.3V de l'arduino uno et j'ai de plus pour le connecteur BL juste au dessus du ground sur la plaque de l'ecran, je l'ai raccordé lui aussi au positif 3.3V  (l'image est moins brillante mais peut etre l'ecran aura une meilleur duré de vie)....  (c'est en regardant plusieurs info sur different site dont sur le site arduino.cc (un des lien) que j'ai vu cela (par rapport au lien principale)

par contre j'ai zappé le lien lui meme, dans tout mes recherches donc fait comme tu le sens, mais on dit toujours qui peut le plus, peut le moins.... et l'inverse non..

j'ai trouver un des lien du meme modele ou presque...  http://www.adafruit.com/products/618

 Amuse toi bien

++ perry rhodan

-
Edité par perryrhodan1 23 mai 2015 à 22:19:13

  • Partager sur Facebook
  • Partager sur Twitter
24 mai 2015 à 1:10:52

Hey merci j'étais toujours bloquer avec cet écran je vais enfin pouvoir le tester ^^ Merci bien ;) je te dirais quoi des que j'ai essayé.
  • Partager sur Facebook
  • Partager sur Twitter
21 décembre 2015 à 23:11:38

salut est ce que vous avez trouvé la solution ou pas encore ??
  • Partager sur Facebook
  • Partager sur Twitter
22 décembre 2015 à 10:42:23

bonjour, je n'ai pas encore essayer les solutions proposé :/
  • Partager sur Facebook
  • Partager sur Twitter
30 avril 2019 à 14:46:16

Bonjour avez vous trouvé la solution ?
  • Partager sur Facebook
  • Partager sur Twitter
18 novembre 2019 à 5:03:57

slt jai un problème particulier. je boss sur un projet ou je veut realisé un multimètre(inductance,capacitance,flux) pilté par arduino uno ou a laffichage jutilise un TFT (lcd2ili9341). le TFT me pose un serieux pb au cablage. svp si quelqun pourrait avoir ce travail dja effectué quil maide pour plus de comprehension. merci
  • Partager sur Facebook
  • Partager sur Twitter
Staff 18 novembre 2019 à 8:23:33

Bonjour,

Déterrage

Citation des règles générales du forum :

Avant de poster un message, vérifiez la date du sujet dans lequel vous comptiez intervenir.

Si le dernier message sur le sujet date de plus de deux mois, mieux vaut ne pas répondre.
En effet, le déterrage d'un sujet nuit au bon fonctionnement du forum, et l'informatique pouvant grandement changer en quelques mois il n'est donc que rarement pertinent de déterrer un vieux sujet.

Au lieu de déterrer un sujet il est préférable :

  • soit de contacter directement le membre voulu par messagerie privée en cliquant sur son pseudonyme pour accéder à sa page profil, puis sur le lien "Ecrire un message"
  • soit de créer un nouveau sujet décrivant votre propre contexte
  • ne pas répondre à un déterrage et le signaler à la modération

Je ferme ce sujet. En cas de désaccord, me contacter par MP.

  • Partager sur Facebook
  • Partager sur Twitter