Partage
  • Partager sur Facebook
  • Partager sur Twitter

hebergeur

ou aller

Sujet résolu
    26 novembre 2005 à 23:49:34

    je l'ai supprimé toute cette ligue vu que j'ai mis une photo et ca change rien
    • Partager sur Facebook
    • Partager sur Twitter
      26 novembre 2005 à 23:51:59

      Tu as supprimé ../ ????
      • Partager sur Facebook
      • Partager sur Twitter
        26 novembre 2005 à 23:54:04

        oui il servait a rien je l'ai rajouter juste pour tester mais avant il n'y etais pas le truc black vu que j'ai un fnd en image rien ne sert d'ecrire que je veux un fond noir
        • Partager sur Facebook
        • Partager sur Twitter
          26 novembre 2005 à 23:57:20

          Essaye en remplaçant ton code par ceci :

          body
          {
          width: 760px;
          margin: auto; /* Pour centrer notre page */
          margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
          margin-bottom: 20px; /* Idem pour le bas du navigateur */
          background : #FFFFFF url(image/windowsxp3.jpg) moved;
          }
          • Partager sur Facebook
          • Partager sur Twitter
            27 novembre 2005 à 0:00:20

            Bon deja on va avoir du mal à afficher l'image, normalement si on est logique, on fait l'url du site ( donc http://membres.lycos.fr/guillaumedoare/ ) + le lien de l'image qui est mi dans le fichier css ( donc image/windowsxp3.jpg ).
            Ceci donne : http://membres.lycos.fr/guillaumedoare/image/windowsxp3.jpg
            Et la page n'est pas trouvé, donc le lien vers l'image n'est pas bon! :)
            • Partager sur Facebook
            • Partager sur Twitter
              27 novembre 2005 à 0:00:54

              Tu es certain d'avoir uploadé l'image windowsxp3.jpg dans le dossier image de ton ftp ?

              Le dossier est bien image, et pas images ?

              Le format de l'image est bien jpg ?

              Le fichier css s'appelle bien css.css ?
              • Partager sur Facebook
              • Partager sur Twitter
                27 novembre 2005 à 0:01:33

                mais non moi je l'ai en fon d'ecran de mon site si il n'est pas sur internet (je lance ma page et hop je vois bien ma page normale et bien avec tout)

                sur que j'au telechargé car elle avec tous

                mon dossier dans lequel il est s'pelle image et non images

                sur que c'est une jpg car je me suis meme embrouillé au debt car je croyais que c'etais une .png



                oui il s'apelle css.css tout comme mon html s'apelle html.html
                • Partager sur Facebook
                • Partager sur Twitter
                  27 novembre 2005 à 0:03:39

                  Tu n'as pas envoyé l'image sur ton serveur, DONC on ne peut pas la voir sur le Net !

                  Tu la vois chez toi en local, car ton PC la trouve grâce au chemin relatif de l'image...

                  Tu dois créer le répertoire "image" sur ton FTP et ensuite envoyer l'image dedans.

                  EDIT :
                  Avec Filezilla, tu fais un clic droit dans la partie droite (site distant) et tu choisi "créer un nouveau dossier".
                  • Partager sur Facebook
                  • Partager sur Twitter
                    27 novembre 2005 à 0:06:07

                    Sinon on peut faire une manière très simple :

                    http://www.imageshack.us

                    Uploade ton image dessus puis prend l'url de l'image ( la dernière url qu'ils nous donne je crois ) et met la dans ton fichier css à la place de image/windowsxp3.jpg.
                    Je pense que sa marchera à coup sure :D

                    PS : essai d'abord ce que t'a dis lg63
                    • Partager sur Facebook
                    • Partager sur Twitter
                      27 novembre 2005 à 0:11:57

                      je te copie ce que j'ai sur le serveur

                      ...
                      image
                      css.css
                      cssblague1.css
                      cssblague2.css
                      htmlblague1.html
                      htmlblague2.html
                      index.html

                      dans image j'ai
                      halologo.gif
                      sonic.PNG
                      windowsxp3.jpg

                      http://img371.imageshack.us/img371/7901/windowsxp31sj.jpg
                      • Partager sur Facebook
                      • Partager sur Twitter
                        27 novembre 2005 à 0:14:37

                        Copie la partie du css qui concerne le body... Il doit rester une erreur.
                        • Partager sur Facebook
                        • Partager sur Twitter
                          27 novembre 2005 à 0:15:39

                          sa marche toujours pas

                          body
                          {
                          width: 760px;
                          margin: auto; /* Pour centrer notre page */
                          margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                          margin-bottom: 20px; /* Idem pour le bas du navigateur */
                          background-attachment: moved;
                          background-image: url(../image/windowsxp3.jpg);
                          }


                          http://img371.imageshack.us/img371/7901/windowsxp31sj.jpg

                          body
                          {
                          width: 760px;
                          margin: auto; /* Pour centrer notre page */
                          margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                          margin-bottom: 20px; /* Idem pour le bas du navigateur */
                          background-attachment: moved;
                          background-image: url(http://img371.imageshack.us/img371/7901/windowsxp31sj.jpg );
                          }

                          marche toujours pas
                          • Partager sur Facebook
                          • Partager sur Twitter
                            27 novembre 2005 à 0:20:03

                            Utilise le code que je t'ai donné plus haut... Ton css me semble erronné...


                            body
                            {
                            width: 760px;
                            margin: auto; /* Pour centrer notre page */
                            margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                            margin-bottom: 20px; /* Idem pour le bas du navigateur */
                            background : #FFFFFF url(image/windowsxp3.jpg) moved;
                            }
                            • Partager sur Facebook
                            • Partager sur Twitter
                              27 novembre 2005 à 0:21:57

                              il n'est pas erroné sinon je l'aurais pas dans mon pc quand je l'ouvre moi meme sinon j'ai essayé avec ton option et c'est pas mieux

                              pourquoi ca ne marche pas avec mou ouinnn
                              • Partager sur Facebook
                              • Partager sur Twitter
                                27 novembre 2005 à 0:23:46

                                Tu as remplacer ton code par celui donné ci-dessus (depuis que l'image est sur le serveur) ?

                                Normalement, ça doit marcher, ton image est bien en place maintenant.

                                Remplace bien TOUT ton code par celui-ci...
                                • Partager sur Facebook
                                • Partager sur Twitter
                                  27 novembre 2005 à 0:26:16

                                  body
                                  {
                                  width: 760px;
                                  margin: auto; /* Pour centrer notre page */
                                  margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                                  margin-bottom: 20px; /* Idem pour le bas du navigateur */
                                  background : #FFFFFF url(image/windowsxp3.jpg) moved;
                                  }
                                  #en_tete
                                  {
                                  width: 800px;
                                  height: 200px;
                                  background-image: url(../image/sonic.PNG);
                                  background-repeat: no-repeat;
                                  margin-bottom: 10px;
                                  }
                                  #menu
                                  {
                                  float: left; /* Le menu flottera à gauche */
                                  width: 120px; /* Très important : donner une taille au menu */
                                  }

                                  .element_menu
                                  {
                                  background-repeat: repeat-x;

                                  border: 2px solid black;

                                  margin-bottom: 20px; /* Pour éviter que les éléments du menu ne soient trop collés */
                                  }
                                  .element_menu h3 /* Tous les titres de menus */
                                  {
                                  color: #B3B3B3;
                                  font-family: Arial, "Arial Black", "Times New Roman", Times, serif;
                                  text-align: center;
                                  }

                                  .element_menu ul /* Toutes les listes à puces se trouvant dans un menu */
                                  {
                                  list-style-image: url(../image/halologo.PNG); /* On change l'apparence des puces */
                                  padding: 0px; /* Tous les côtés ont une marge intérieure de 0 pixels */
                                  padding-left: 20px; /* ... mais on modifie ensuite la marge de gauche, donc celle-là fera finalement 20 pixels */
                                  margin: 0px; /* Idem pour margin, ça nous évite d'avoir à en écrire 4 (margin-left, margin-right...) */
                                  margin-bottom: 5px; /* Même chose que tout à l'heure, on modifie ensuite juste margin-bottom, mais tous les autres sont à 0px */
                                  }

                                  .element_menu a /* Tous les liens se trouvant dans un menu */
                                  {
                                  color: #B3B3B3;
                                  }

                                  .element_menu a:hover /* Quand on pointe sur un lien du menu */
                                  {
                                  background-color: black;
                                  color: red;
                                  }
                                  #corps
                                  {
                                  margin-left: 140px; /* Une marge à gauche pour pousser le corps, afin qu'il ne passe plus sous le menu */
                                  margin-bottom: 20px; /* Ca c'est pour éviter que le corps colle trop au pied de page en-dessous */
                                  padding: 5px; /* Pour éviter que le texte à l'intérieur du corps ne colle trop à la bordure */
                                  color: black;
                                  background-repeat: repeat-x; /* Une petite image de fond qui se répètera horizontalement en haut */

                                  border: 2px solid black; /* Une bordure pour bien marquer les limites du corps et pour faire joli */
                                  }

                                  #pied_de_page
                                  {
                                  padding: 5px;

                                  text-align: center;

                                  color: #B3B3B3;
                                  background-repeat: repeat-x;

                                  border: 2px solid black;
                                  }
                                  em
                                  {
                                  color: red
                                  }

                                  et toujours rien mais je crois que j'ai trouve le blem

                                  comment on fait pour mettre la nouvelle page css ?? elle se met automatiquement moi je la supprime et je la recherge peut etre qu'elle ne se met pas a jour
                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                    27 novembre 2005 à 0:27:34

                                    Ce n'est pas le fichier css que je trouve sur Internet...

                                    EDIT :

                                    Au passage, enlève le "moved" qui est visiblement erroné d'après le W3C.
                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                      27 novembre 2005 à 0:31:48

                                      comment sa tu ne trouve pas le fichier css sur internet moi c'est celui que j'ai envoyé

                                      sinon je met quoi a la place de movet c'etais pour que le fond soit fixe
                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        27 novembre 2005 à 0:33:53

                                        1/ tu remplace moved par fixed.

                                        2/ tu remplace bien ton code css "body" par le mien (en mettant fixed, donc).

                                        3/ tu envoi ce nouveau fichier css.css sur le serveur en utilisant filezilla.

                                        Actuellement, le fichier css qui est en ligne est le tien, pas celui avec mon morceau de code.

                                        Le tien marche sur ton PC, mais pas sur le Net !
                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          27 novembre 2005 à 0:36:43

                                          j'ai envoyé le nouveau fichier avec marqué fixed mais cela n'a rien changé et pour le renvoyer j'ai supprimer l'ancien et j'ai telecharger le nouveau


                                          tu es sur que je dois mettre toutes mes images dans un dossier et pas directement ?
                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            27 novembre 2005 à 0:38:52

                                            Voilà le contenu actuel de ton fichier css :

                                            body
                                            {
                                               width: 760px;
                                               margin: auto; /* Pour centrer notre page */
                                               margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                                               margin-bottom: 20px;    /* Idem pour le bas du navigateur */
                                               background-color: #BBD3C7;
                                               background-attachment: moved;
                                               background-image: url(../image/windowsxp3.jpg);
                                            }


                                            Tu n'as donc pas correctement envoyé le nouveau fichier...

                                            Il est bien dans le bon dossier (pas dans image par exemple) ?

                                            Tu as bien copié/collé le code que je t'ai donné ?
                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                              27 novembre 2005 à 0:41:17

                                              j'ai envoyé le nouveau comme je t'ai dit

                                              euh tu parle de quoi la ? il est la ou j'ai mis tt mes fichiers html c'est a dire que j'ai mes fichers html.html et les autres , j'ai un dossier et dedans l'ai mes photos d'ou le lien photo/image.png

                                              et ou ijai copié collé ton code

                                              depuis le debut je n'enregistrai au mauvais endroit mais sa a rien changé sauf que l'ecran est blanc
                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                27 novembre 2005 à 0:44:12

                                                Je te parle du fichier css.css, qui doit se trouver au même endroit que tes fichiers html.

                                                Voici le lien vers ton fichier en ligne : http://membres.lycos.fr/guillaumedoare/css.css

                                                Tu dois absolument faire les changements en rouge :

                                                Citation

                                                body
                                                {
                                                width: 760px;
                                                margin: auto; /* Pour centrer notre page */
                                                margin-top: 20px; /* Pour éviter de coller avec le haut de la fenêtre du navigateur. Essayez d'enlever pour voir ! */
                                                margin-bottom: 20px; /* Idem pour le bas du navigateur */
                                                background : #FFFFFF url(image/windowsxp3.jpg) fixed;
                                                background-color: #BBD3C7;
                                                background-attachment: moved;
                                                background-image: url(../image/windowsxp3.jpg);

                                                }



                                                Ajoute ce qui est en rouge et supprime ce qui est rayé...
                                                • Partager sur Facebook
                                                • Partager sur Twitter
                                                  27 novembre 2005 à 0:47:16

                                                  sa change rien sauf que au lieu d'avoir un espace qu niveau du tutre car cette autre image aussi ne fonctionne pas eh bien je n'ai plus l'espace
                                                  • Partager sur Facebook
                                                  • Partager sur Twitter
                                                    27 novembre 2005 à 0:48:29

                                                    Chez moi, j'ai bien ton image en fond.

                                                    !Je te fais une capture que je rajoute en edit...

                                                    EDIT : Image utilisateur
                                                    • Partager sur Facebook
                                                    • Partager sur Twitter
                                                      27 novembre 2005 à 0:50:52

                                                      ben sa alors moi je voit rien
                                                      • Partager sur Facebook
                                                      • Partager sur Twitter
                                                        27 novembre 2005 à 0:53:27

                                                        Tu as bien raffraichi la page (F5) ?

                                                        Des fois ton navigateur le fais mal, dans ce cas, vide l'historique et le cache.
                                                        • Partager sur Facebook
                                                        • Partager sur Twitter
                                                          27 novembre 2005 à 0:54:17

                                                          comment tu fais une capture d'ecran je vais te montrer la VRAIE image

                                                          et dis moi si tu voi encore comme avant



                                                          AHHH MAIS TU AS MOZILLA PEUT ETRE C'EST POUR SA KE SA MARCHE PO CHEZ MOI
                                                          • Partager sur Facebook
                                                          • Partager sur Twitter

                                                          hebergeur

                                                          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                          × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                                          • Editeur
                                                          • Markdown