Partage
  • Partager sur Facebook
  • Partager sur Twitter

il manque libgdk-3-0.dll.

    18 juin 2019 à 13:15:09

    bonjour,

    j'ai crée un  programme et pour l'interface graphique j'ai utilisé GTK+ .j'ai utilisé inno setup pour créer une instalation; le problème est quand j'installe mon application sur un autre ordinateur il m'affiche un message d'erreur :impossible de démarrer le programme car il manque libgdk-3-0.dll.

    j'ai met le fichier dll dans le meme repertoire que le .exe ,avant de créer l'instalation mais le problème persiste .

    s'il vous plait help me.

    • Partager sur Facebook
    • Partager sur Twitter
      19 juin 2019 à 21:35:37

      Salut,

      Dans la partie [Files] de ton fichier.iss as-tu rajouté le fichier .dll comme ceci ?

      Source: "C:\chemin\du\fichier\libgdk-3-0.dll"; DestDir: "{app}"; Flags: ignoreversion



      -
      Edité par Major_Zero 19 juin 2019 à 21:35:55

      • Partager sur Facebook
      • Partager sur Twitter

      Testez mes jeux : Kaaris vs BoobaPush Crate ; Bomberman.

        22 juin 2019 à 21:38:51

        bonsoir , 

        je m'excuse d'avoir réagi assez tard ,  

        Dans la partie [Files] de ton fichier.iss as-tu rajouté le fichier .dll comme ceci ?

        Source: "C:\chemin\du\fichier\libgdk-3-0.dll"; DestDir: "{app}"; Flags: ignoreversion

        ça ne marche tjrs pas . le seul truc qui marche c'est d'installer GTK+ runtime  sur l'autre machine  avant d'installer l'app.





        -
        Edité par asmacherana 22 juin 2019 à 22:39:50

        • Partager sur Facebook
        • Partager sur Twitter
          27 juin 2019 à 22:09:35

          asmacherana a écrit:

          bonsoir , 

          je m'excuse d'avoir réagi assez tard ,  

          Dans la partie [Files] de ton fichier.iss as-tu rajouté le fichier .dll comme ceci ?

          Source: "C:\chemin\du\fichier\libgdk-3-0.dll"; DestDir: "{app}"; Flags: ignoreversion

          ça ne marche tjrs pas . le seul truc qui marche c'est d'installer GTK+ runtime  sur l'autre machine  avant d'installer l'app.





          -
          Edité par asmacherana 22 juin 2019 à 22:39:50

          Alors dans ce cas il faut que ton installateur installe aussi GTK+

          • Partager sur Facebook
          • Partager sur Twitter

          Testez mes jeux : Kaaris vs BoobaPush Crate ; Bomberman.

          il manque libgdk-3-0.dll.

          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
          • Editeur
          • Markdown