Partage

Image qui ne s'affiche pas

Sujet résolu
11 octobre 2017 à 15:56:07

Bonjour, mon image ne s'affiche pas sur mon site web, et je ne comprends pas pourquoi. (J'avais réussi auparavant) 

Voici mon code:

<!DOCTYPE html>
<html>
    <head>
        <!-- En-tête de la page -->
        <meta charset="utf-8">
        <link rel="stylesheet" href="style.css">
        <title> Titre </title>
    </head>
       

    <body>
        <!-- Corps de la page -->
        <h1> CV en ligne </h1>
        <!-- Photo de profil -- >
        <figure>
            <a href="photo.jpg"><img src="photo.jpg" alt="Photo de profil" title="Cliquez pour agrandir" /></a>
        </figure>
    </body>
    </html>

Mon fichier .html et la photo.jpg sont dans le même dossier, mais elle ne s'affiche pas. (Rien ne s'affiche en fait, mis à part le titre "CV en ligne"

Merci de m'éclairer!

11 octobre 2017 à 16:05:11

Bonjour,

Plusieurs pistes/correction :

- Ton image a bien comme extension .jpg? et non .jpg.jpg ou .jpeg? Tu dois afficher les extensions de fichier sur ton système d'exploitation pour vérifier cela.

- <img> n'as pas de title, seulement un alt. Le title est dans ton cas pour le <a>

- Quel navigateur utilises-tu ?

- Testes tu cela en local ou en ligne?

Lord Morpheus, Seigneur Morphée, Dieu Grecs des Songes, Fils de la Nuit et du Sommeil
11 octobre 2017 à 16:23:02

Bonjour, merci pour votre réponse

-Mon image a bien .jpg comme extension

-J'utilise Mozilla Firefox

-Je testes cela en local

(J'ai continué mon code, et il s'avère que RIEN d'autre ne s'affiche à part le titre... pourquoi ??)

Edit: j'ai trouvé pourquoi.

Le commentaire "Photo de profil" ici :


    <body>
        <!-- Corps de la page -->
        <h1> CV en ligne </h1>
        <!-- Photo de profil -- >

bloquait l'apparition du reste de mon code. Savez-vous pourquoi ? Je pensais qu'un commentaire n'était pas pris en compte par le navigateur ??

-
Edité par KillianVanhumbeeck2 11 octobre 2017 à 16:29:56

Staff 11 octobre 2017 à 16:31:28

Bonjour,

c'est probablement parce que la fermeture de commentaire se fait avec "-->" et non "-- >". Donc le navigateur ne devait pas considérer le commentaire comme fermé, et continuait à cacher la suite.

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
11 octobre 2017 à 16:36:02

D'accord j'ai compris !

Merci beaucoup !

11 octobre 2017 à 22:19:53

Avec n'importe quel éditeur de code et sa colorisation syntaxique, tu te serai rendu compte de l'erreur :) (tout comme nous)

https://jsfiddle.net/8et8g4uL/

-
Edité par Lord Morpheus 11 octobre 2017 à 22:21:19

Lord Morpheus, Seigneur Morphée, Dieu Grecs des Songes, Fils de la Nuit et du Sommeil

Image qui ne s'affiche pas

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown