Partage
  • Partager sur Facebook
  • Partager sur Twitter

Impossible d'afficher l'image en htlm

Sujet résolu
    4 mai 2021 à 15:04:00

    Bonjour,

    J'essaie en vain d'ajouter une image, j'ai regardé je ne sais combien de post à ce sujet mais rien ne fonctionne.

    L'image apparait cassée quoi que je fasse.

    J'ai bien vérifié le nom du fichier, l'extension, le chemin du fichier.

    J'ai essayé de changer l'image aussi mais rien n'y fait et je suis à court de solutions :/

    Pour info je débute :)

    Merci d'avance pour votre aide!

    • Partager sur Facebook
    • Partager sur Twitter
      4 mai 2021 à 15:11:21

      Bonjour,

      Le message qui suit est une réponse automatique activée par un membre de l'équipe. Les réponses automatiques leur permettent d'éviter d'avoir à répéter de nombreuses fois la même chose, ce qui leur fait gagner du temps et leur permet de s'occuper des sujets qui méritent plus d'attention.
      Nous sommes néanmoins ouverts et si vous avez une question ou une remarque, n'hésitez pas à contacter la personne en question par Message Privé.

      Pour plus d'informations, nous vous invitons à lire les règles générales du forum

      Merci de colorer votre code à l'aide du bouton Code

      Les forums d'Openclassrooms disposent d'une fonctionnalité permettant de colorer et mettre en forme les codes source afin de les rendre plus lisibles et faciles à manipuler par les intervenants. Pour cela, il faut utiliser le bouton Code de l'éditeur, choisir un des langages proposés et coller votre code dans la zone prévue. Si vous utilisez l'éditeur de messages en mode Markdown, il faut utiliser les balises <pre class="brush: xml;">Votre code ici</pre>.

      Merci de modifier votre message d'origine en fonction.

      Liens conseillés


      Bonjour, pour ne pas me répéter merci de lire mon message dans ce sujet.

      PS :  c'est <html> pas <htlm> Pour voir vos erreurs passer votre code au validateur => https://validator.w3.org/

      -
      Edité par AbcAbc6 4 mai 2021 à 15:12:37

      • Partager sur Facebook
      • Partager sur Twitter
        4 mai 2021 à 15:53:49

        Bonjour

        Ca peut surement venir des balises <html>, vos balises sont <htlm>ainsi que dans le DOCTYPE

         Si ça fonctionne toujours pas 

        Je sais que vous avez déjà vérifiée, mais je ne vois pas d'où ca peut venir autrement. 

        Il faut s'assurer que l'image est dans le bon dossier, vérifiez également le nom de l'image ainsi que l'extension de l'image (.jpg), il faut que tout correspondent à l'image de votre dossier. Le problème peut venir du chemin de l'image dans le src.

        -
        Edité par Clément.Pa 4 mai 2021 à 16:28:12

        • Partager sur Facebook
        • Partager sur Twitter

        "Pose ta question maintenant tu seras bête 1 seconde là pose pas tu seras bête toutes ta vie" 

          4 mai 2021 à 17:28:07

          Bonjour,

          Merci pour votre retour.

          J'ai bien modifié le html ...

          Toujours pas :/

          J'ai mis l'image dans le même dossier que le fichier html pour être sûre mais rien n'y fait.

          J'ai également vérifié le nom de l'image et l'extension et c'est bien .jpg

          Peut-être est-ce dû à un paramétrage du navigateur?

          Merci!

          • Partager sur Facebook
          • Partager sur Twitter
            4 mai 2021 à 17:44:08

            Bonjour,

            Aucun paramétrage du navigateur à effectuer ici.

            Si l'image ne s'affiche pas c'est soit parce que le chemin est faux soit à cause de l'extension du fichier.

            Pourrais-tu stp nous fournir des screenshots de ton architecture de dossiers et de fichiers stp ?

            • Partager sur Facebook
            • Partager sur Twitter
              4 mai 2021 à 18:37:36

              Euh... Ok...

              Mais où sont tous tes autres fichiers ?

              • Partager sur Facebook
              • Partager sur Twitter
                4 mai 2021 à 18:43:51

                Il faut que votre dossier image soit à la racine de votre dossier site pour qu'il puisse la trouver.

                -
                Edité par Clément.Pa 4 mai 2021 à 18:44:06

                • Partager sur Facebook
                • Partager sur Twitter

                "Pose ta question maintenant tu seras bête 1 seconde là pose pas tu seras bête toutes ta vie" 

                  4 mai 2021 à 18:57:16

                  Comment ca à la racine ...?

                  Voici tous les fichiers:

                  • Partager sur Facebook
                  • Partager sur Twitter
                    4 mai 2021 à 19:06:49

                    Je suppose que ton fichier HTML est dans le dossier "Exercices" ? 

                    Si oui alors c'est normal que ton image ne s'affiche pas.

                    <img src="images/photo_melo.jpg"  />

                    En écrivant ainsi ton code HTML, tu dis au navigateur d'aller dans le dossier "images" situé au même niveau que ton fichier HTML, puis de chercher dans ce dossier l'image nommée photo_melo.jpg.

                    <img src="../images/photo_melo.jpg"  />

                    Ce code devrait fonctionner : tu demandes au navigateur de sortir du dossier "Exercices", puis d'entrer dans le dossier "images" et enfin de rechercher ton image dans ce dernier. 

                    Voir ce schéma du cours pour plus d'infos : https://openclassrooms.com/fr/courses/1603881-apprenez-a-creer-votre-site-web-avec-html5-et-css3/1604646-creez-des-liens#/id/r-1609677

                    -
                    Edité par Mewen_bzh 5 mai 2021 à 9:08:22

                    • Partager sur Facebook
                    • Partager sur Twitter
                      4 mai 2021 à 19:12:01

                      hallelujah !!!

                      Ca fonctionne merci mille fois! :)

                      Je pense que j'ai compris le principe maintenant

                      • Partager sur Facebook
                      • Partager sur Twitter
                        4 mai 2021 à 19:41:23

                        Bonjour,

                        Sujet résolu

                        Tu peux passer le sujet à "résolu" (bouton en haut à droite du sujet) et cliquer sur les pouces levés des messages qui t'ont aidé⋅e ;)
                        • Partager sur Facebook
                        • Partager sur Twitter

                        Impossible d'afficher l'image en htlm

                        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                        • Editeur
                        • Markdown