Partage
  • Partager sur Facebook
  • Partager sur Twitter

Impossible de mettre à jour

Sub-process /usr/bin/dpkg returned an error code (1)

    25 juin 2022 à 7:41:29

    Bonjour j'essaie actuellement de mettre à jour mon pc sous Ubuntu 20.04.4 LTS mais j'ai plein de problémes:

    Logiciel et mises à jour ne se lance pas: je peux le rechercher mais lorsque je fait ce qu'il faut pour l'ouvrir, il ne se passe rien.

    Lorsque je fait un sudo apt update, j’obtiens ceci:

    Atteint :1 http://dell.archive.canonical.com focal InRelease
    Ign :2 http://dl.google.com/linux/chrome-remote-desktop/deb stable InRelease   
    Atteint :3 http://dl.google.com/linux/chrome-remote-desktop/deb stable Release 
    Atteint :4 http://security.ubuntu.cergy.eisti.fr/ubuntu focal-security InRelease
    Atteint :5 http://archive.ubuntu.cergy.eisti.fr/ubuntu focal InRelease         
    Réception de :6 http://vbox.debian.cergy.eisti.fr focal InRelease [4 428 B]    
    Réception de :7 http://deb.playonlinux.com precise InRelease [2 592 B]         
    Atteint :8 https://brave-browser-apt-release.s3.brave.com stable InRelease     
    Atteint :9 http://google.debian.cergy.eisti.fr stable InRelease                
    Atteint :10 http://docker.ubuntu.cergy.eisti.fr focal InRelease                
    Atteint :11 http://archive.ubuntu.cergy.eisti.fr/ubuntu focal-updates InRelease
    Atteint :12 https://packages.microsoft.com/repos/ms-teams stable InRelease     
    Atteint :13 http://archive.ubuntu.cergy.eisti.fr/ubuntu focal-backports InRelease
    Atteint :15 https://download.sublimetext.com apt/stable/ InRelease             
    Err :7 http://deb.playonlinux.com precise InRelease       
      Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 73F0D6E88E3D6C3A
    Lecture des listes de paquets... Fait
    W: Erreur de GPG : http://deb.playonlinux.com precise InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 73F0D6E88E3D6C3A
    E: Le dépôt http://deb.playonlinux.com precise InRelease n'est pas signé.
    N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
    

    Lorsque je fait : sudo apt-get install -f J'obtiens ceci:

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    4 partiellement installés ou enlevés.
    Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
    Paramétrage de update-notifier-common (3.192.30.10) ...
    Traceback (most recent call last):
      File "/usr/lib/update-notifier/package-data-downloader", line 29, in <module>
        import apt_pkg
    ModuleNotFoundError: No module named 'apt_pkg'
    dpkg: erreur de traitement du paquet update-notifier-common (--configure) :
     installed update-notifier-common package post-installation script subprocess returned error exit status 1
    Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                      Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                        dpkg: des problèmes de dépendances empêchent la configuration de update-notifier :
     update-notifier dépend de update-notifier-common (= 3.192.30.10) ; cependant :
     Le paquet update-notifier-common n'est pas encore configuré.
    
    dpkg: erreur de traitement du paquet update-notifier (--configure) :
     problèmes de dépendances - laissé non configuré
    dpkg: des problèmes de dépendances empêchent la configuration de ubuntu-desktop :
     ubuntu-desktop dépend de update-notifier ; cependant :
     Le paquet update-notifier n'est pas encore configuré.
    
    dpkg: erreur de traitement du paquet ubuntu-desktop (--configure) :
     problèmes de dépendances - laissé non configuré
    dpkg: des problèmes de dépendances empêchent la configuration de ubuntu-desktop-minimal :
     ubuntu-desktop-minimal dépend de update-notifier ; cependant :
     Le paquet update-notifier n'est pas encore configuré.
    
    dpkg: erreur de traitement du paquet ubuntu-desktop-minimal (--configure) :
     problèmes de dépendances - lAucun rapport « apport » écrit car MaxReports a déjà été atteint
                 aissé non configuré
    Des erreurs ont été rencontrées pendant l'exécution :
     update-notifier-common
     update-notifier
     ubuntu-desktop
     ubuntu-desktop-minimal
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Si je fait sudo apt install --reinstall apt_pkg j'obtiens E: Impossible de trouver le paquet apt_pkg

    Si je fait update-notifier-common --configure j'obtiens bash: update-notifier-common : commande introuvable
    Sauriez vous comment je peux résoudre mes problémes? 
    Merci d'avance!
    • Partager sur Facebook
    • Partager sur Twitter
      28 juin 2022 à 9:52:06

      Hello, un petit moment que je n'ai pas lancé une ubuntu mais tu sembles avoir beaucoup de dépôts dis donc.

      Playonlinux semble poser soucis, essaye de commenter les lignes concernant ce dépôt dans /etc/apt/sources.list


      Puis apt-get update && apt-get upgrade

      A voir si playonlinux n'est pas dejà présent dans les dépôts de ubuntu, auquel il n'est pas forcement indispensable...

      J'espère que cela t'aidera !

      -
      Edité par GMA_74 28 juin 2022 à 9:56:00

      • Partager sur Facebook
      • Partager sur Twitter
        28 juin 2022 à 16:30:19

        En général ce qui cause ce soucis sur Debian et dérivées, c'est que les clés qui ne sont pas au bon format ne sont plus installées pour des raisons de sécurité.

        Souvent maintenant il faut des clés de packages au format .gpg (c'est l'extension mais surtout le forme d'encodage de la clé)

        Pour la suite l'installation du package foire, du coup ça cause des problèmes de dépendances par la suite...Rien de grave mais on peut convertir les clés de packages au bon format avec la commande...gpg (je me souviens plus de la commande exacte pour changer le format de la clé de chiffrement par contre)

        Même si on peut forcer l'installation de packages non signés, c'est pas recommandé, mieux vaut mettre la clé de chiffrement au bon format.

        • Partager sur Facebook
        • Partager sur Twitter

        Impossible de mettre à jour

        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
        • Editeur
        • Markdown