Partage
  • Partager sur Facebook
  • Partager sur Twitter

Installer Qt 4.7.4

    25 novembre 2021 à 22:05:17

    Bonjours à tout le monde

    Comment installer manuellement Qt 4.7.4 sur Windows 10 64 bits

    Merci d'avance

    • Partager sur Facebook
    • Partager sur Twitter
      26 novembre 2021 à 0:47:34

      Pas sur que ce soit possible, c'est trop vieux. Les archives sont la : https://download.qt.io/archive/qt/4.7/
      • Partager sur Facebook
      • Partager sur Twitter

      Rejoignez le discord NaN pour discuter programmation.

        26 novembre 2021 à 3:37:51

        Je l'ai installé, mais il ne fonctionne pas. n'y-a-t-il pas de solutions ?

        • Partager sur Facebook
        • Partager sur Twitter
          26 novembre 2021 à 4:19:25

          Qt 4.6 n'est pas concu pour Window 10. Tu peux t'amuser a prendre les sources et essayer de compiler toi même, mais ca va te prendre des jours (voire semaine) pour faire ca. Et ce n'est meme pas sur que tu y arrives.
          • Partager sur Facebook
          • Partager sur Twitter

          Rejoignez le discord NaN pour discuter programmation.

            26 novembre 2021 à 13:32:01

            Salut,

            La version "officielle" disponible actuellement est la version ... 6.1, rendue disponible en mai 2021.

            La version 4.7 date quant à elle de ... septembre 2010, c'est à dire d'il y a plus de onze ans.(==>sources <== )

            Depuis ces onze années, il y a eu

            • quatre nouvelles versions du standard C++ (en 2011, 2014, 2017 et 2020)
            • trois nouvelles versions de windows (windows 7, windows 8 et windows 10 + windows vista qui était la version "officielle" à l'époque de la sortie de Qt 4.6), sans même compter les "sous versions" de windows 8 et de windows 10 ==>sources <==

            Sachant que les évolutions du C++ ont eu énormément d'impact sur la manière dont Qt est développé et utilisé, et que les "anciennes" versions de windows (vista, seven, et height) ne sont plus supportées, la véritable question que l'on se pose est donc: pourquoi voudrais tu absolument utiliser une version tellement vieille de Qt?

            Si c'est pour pouvoir suivre un cours quelconque, tu  peux déjà très certainement te dire que le cours en question est au moins aussi vieux et en retard que la version de Qt sur laquelle il se base, et que ce n'est donc clairement pas le genre de cours qui te permettra de débuter de manière efficace.

            C'est d'autant plus vrai que certains mécanismes (comme le système de signaux et de slots) ont été entièrement revus depuis la version 5 de Qt, du fait des nouvelles possibilités offertes par le langage et que ce sont les "nouvelles versions" de ces mécanismes qui seront le plus souvent utilisées.

            • Partager sur Facebook
            • Partager sur Twitter
            Ce qui se conçoit bien s'énonce clairement. Et les mots pour le dire viennent aisément.Mon nouveau livre : Coder efficacement - Bonnes pratiques et erreurs  à éviter (en C++)Avant de faire ce que tu ne pourras défaire, penses à tout ce que tu ne pourras plus faire une fois que tu l'auras fait
              27 novembre 2021 à 23:18:04

              Merci à tout le monde.

              He bien, grâce à vaux conseilles  je vais chercher un livre sur Qt 6.

              vous pouvez me conseiller d'un livre à ce sujet ?

              Merci

              • Partager sur Facebook
              • Partager sur Twitter

              Installer Qt 4.7.4

              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
              • Editeur
              • Markdown