Partage
  • Partager sur Facebook
  • Partager sur Twitter

installer SDL 1.2

Encore possible?

    18 mai 2020 à 12:25:16

    Bonjour,

    Je suis un vieil étudiant qui, à 56 ans, va commencer un BTS SIO. Je prends donc de l'avance en m'initiant aux langages de programmation. Plein d'élan, je suis arrivé au milieu du cours sur le langage C et je le trouve excellent, comme les autres cours d'OpenClassRoom, du reste. Cependant, malgré mon acharnement et des recherches de toutes sortes, impossible d'installer SDL 1.2 dans CodeBlocks. Festival du bug. Même avec des templates. J'ai fini par laisser tomber en voyant que, sur les forums, ce sujet était très ancien... Alors j'enchaîne sur C++. Mais quelle déception de ne pas pouvoir aller au bout du cours de C!

    Ma question : SDL 1.2 est-ce dépassé? Est-il impossible d'aller jusqu'au bout du cours de langage C?

    Bien à vous!

    F

    • Partager sur Facebook
    • Partager sur Twitter
      18 mai 2020 à 13:42:30

      Ça devient lassant cette question existentielle sur SDL 1.2 et code::blocks. Personne ne recherche sur le forum avant de poster, ce problème a été maintes et maintes fois déjà posé.

      De plus :

      • SDL 1.2 est obsolète depuis plus de 8 ans ;
      • Code::Blocks est un IDE antédiluvien que personne utilise de nos jours (sauf les habitués qui ne veulent pas changer).

      À vrai dire, ce n'est pas vraiment la faute des gens, mais plutôt de ce cours préhistorique qui continue de rapporter de l'argent et donc n'est pas supprimé. Pourtant le cours du C comme celui du C++ de ce site sont à fuire comme la peste et devraient vraiment être purement supprimés.

      Si tu souhaites apprendre le C++, il y a un cours moderne sur zeste de savoir qui a le mérite d'être à jour.

      Autre remarque : il est inutile de suivre un cours de C avant le C++, ce sont deux langages bien différent et lorsqu'on code en C++ il ne faut pas coder en C. Le C++ a largement changé la manière de développer et à part la syntaxe et la compatibilité ils ne possèdent plus grand chose en commun.

      • Partager sur Facebook
      • Partager sur Twitter

      l'azerty est aux dispositions ce que subversion est aux SCM

      installer SDL 1.2

      × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
      × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
      • Editeur
      • Markdown