Partage
  • Partager sur Facebook
  • Partager sur Twitter

Installer une archive .tar.gz

Anonyme
    11 novembre 2012 à 21:48:04

    Bonjour tout le monde j'ai récemment enlevé Windows 7 Starter (Sans faire expres je l'ai ecrase a la place de Xubuntu au moment du "copie des fichiers" j'ai eteint l'ordi car je me suis dis "mince sa se trouve je suis entrain d'ecrase Windows" et j'ai reallumé mon pc et je n'avais plus aucun OS, ensuite j'ai installe Linux Mint, je pourrai reprendre les configuration d'usine avec une fonction ?) mais je n'arrive pas a installer une application ayant .tar.gz pour lamp ici, pourriez-vous m'aider ?
    Merci d'avance.
    • Partager sur Facebook
    • Partager sur Twitter
      11 novembre 2012 à 21:57:45

      Il faut faire un truc du genre :

      tar -zxvf archive.tar.gz
      cd archive
      make
      make install


      La dernière commande est a exécuter en root (avec sudo par exemple).

      C'est facilement trouvable avec Google.
      • Partager sur Facebook
      • Partager sur Twitter
        11 novembre 2012 à 22:16:03

        rien ne dit qu'il est les dépendances de construction installer.
        et rien ne dit si l'archive est une archive source ou binaire.
        • Partager sur Facebook
        • Partager sur Twitter
          11 novembre 2012 à 22:47:19

          Euh, évite d'installer directement des tar.gz. En général, tu n'en as pas besoin. C'est une méthode à n'utiliser qu'en dernier recours.

          En général, LA méthode à utiliser, c'est avec ton gestionnaire de paquets. Sur Mint, en mode graphique, c'est Synaptics, en mode console c'est apt-get. Tu peux avoir plus d'informations dans le mode d'emploi.


          Pour lampp, il y a plusieurs méthodes. Ma préférée personnellement ce serait d'utiliser apt-get pour télécharger tous les logiciels qui composent le serveur :
          sudo apt-get install apache php5 mysql-server phpmyadmin
          ou de la même manière, une méthode que je ne garantis pas :
          sudo tasksel lamp-server

          L'autre méthode, qui est peut-être plus simple pour un débutant, et qui est celle recommandée par M@teo21 et par ubuntu-fr.org, est de télécharger directement xamp. C'est ce que tu sembles avoir fait, dans ce cas, je te recommande de suivre les instructions de site où tu as trouvé cette recommandation. À savoir le tuto de M@teo21 ou alors ici.
          • Partager sur Facebook
          • Partager sur Twitter
          Anonyme
            12 novembre 2012 à 18:45:36

            Il y a marque ça pour ta technique preferée : sudo apt-get install apache php5 mysql-server phpmyadmin
            [sudo] password for lucas:
            Lecture des listes de paquets... Fait
            Construction de l'arbre des dépendances
            Lecture des informations d'état... Fait
            Aucune version du paquet apache n'est disponible, mais il existe dans la base
            de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
            ou qu'il n'est disponible que sur une autre source

            E: Le paquet « apache » n'a pas de version susceptible d'être installée
            • Partager sur Facebook
            • Partager sur Twitter
              12 novembre 2012 à 19:36:14

              EDIT : en fait Millman m'a devancé.


              Ah oui, apparemment, c'est plutôt apache2 (j'avais tapé ça de mémoire). Du coup, si cette méthode t'intéresse, tu peux même reprendre directement la doc ubuntu :

              installation du tout (assez long)
              • Partager sur Facebook
              • Partager sur Twitter
              Anonyme
                12 novembre 2012 à 21:03:49

                sur mysql server je crois il mettent : certains packages sont indisponibles sur le reseau, voulez-vous ignorer ? je met oui et il y a marque impossible d'ignorer
                • Partager sur Facebook
                • Partager sur Twitter

                Installer une archive .tar.gz

                × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                • Editeur
                • Markdown