Partage
  • Partager sur Facebook
  • Partager sur Twitter

j'ai besoin du port 80 qui est déjà utilisé

comment le libérer ? merciii

    6 octobre 2008 à 0:37:02

    Bonjour,
    Je commence à apprendre le PHP en suivant le tutoriel de Mateo, et j'ai installé WampServeur.
    Le problème c'est que quand je mets la souris sur l'icone, ils me mettent "serveur hors ligne".
    Wampserveur est sensé se connecter sur le port 80, et le port 80 est utilisé par lOrdiDeMarie (mon ordi quoi).

    Ca ne doit pas etre sorcier pourtant je n'arrive pas à trouver d'aide sur internet, aidez moi même si c'est une question bete svppp !


    1) ce n'est pas grave de le desactiver? mon ordi n'en a pas besoin ?
    2) comment faire pour que mon port 80 soit a nouveau dispo ?

    Merci merci merci !

    Marie
    • Partager sur Facebook
    • Partager sur Twitter
    Anonyme
      6 octobre 2008 à 8:18:04

      Bonjour,

      Tu utilises Skype ?
      • Partager sur Facebook
      • Partager sur Twitter
        6 octobre 2008 à 9:08:00

        Il faut peut-être que tu coupes IIS.
        Il s'agit du serveur Web de microsoft qui est parfois installé par défaut sur les machines ayant Windows XP SP2 ou simplement Windows XP pro.

        Pour le stopper tu as plusieurs solutions :
        Click droit sur poste de travail => gérer => et puis là il doit y avoir une section qui va bien avec IIS dedans.

        Ou alors
        tu vas dans démarrer => éxécuter => tu tapes services.msc => et tu paramètres le service "IIS quelque chose" pour qu'il ne soit plus démarré au démarrage de l'ordi, et par la même occasion tu le stoppes pour la session en cours...
        • Partager sur Facebook
        • Partager sur Twitter
        Si y'a pas d'accents dans mes messages c'est parce que je suis sur un clavier norvegien :)
          6 octobre 2008 à 9:09:13

          Avant de faire quelque manip' que se soit il faut que quelqu'un reponde a la premiere question ^^(moi je n'ai aucune idee de la réponse).

          Je sais que tu peux ouvrir et fermer des ports viaz la console DOS, mais je me souviens que d'une commande (avec une tite recherche sur internet tu devrais trouver le reste ^^ ).
          Avec netstat tu affiche la liste des port ouvert et utilisé, et avec netstat -a tu affiche tout les port ouvert, je pense qu'avec un autre suffixe de netstat tu pourra fermer le port que tu veux.

          En esperant t'avoir aider ^^
          • Partager sur Facebook
          • Partager sur Twitter
            6 octobre 2008 à 11:46:46

            Bonjour et merci de m'aider,
            Bon alors je ne comprend pas, mais ce IIS dont tout le monde me parle, eh ben je ne le trouve pas!
            j'ai fait comme tu m'as dit mrjay42, le truc c'est que non, je ne trouve pas ce "IIS quelque chose"...
            je sais pas :'( je desespere !
            marie
            • Partager sur Facebook
            • Partager sur Twitter
              6 octobre 2008 à 16:27:41

              IIS = Internet Information Services ? regarde si tu as un truc comme sa
              • Partager sur Facebook
              • Partager sur Twitter
                6 octobre 2008 à 17:37:36

                Bah si tu ne le trouve pas c'est qu'il n'est pas installé

                Sinon tu peux utiliser un autre port que le 80 (configuration d'apache)
                • Partager sur Facebook
                • Partager sur Twitter
                  6 octobre 2008 à 18:02:55

                  Tu cherche le dossier apache ou apache2 a l interieur tu a un fichier "ports.conf" tu l ouvre et tu a un truc comme ca :

                  Listen 80

                  tu change le numero de port par celui que tu veut. pas un qui est deja occupé biensur ...

                  Apres pour y acceder tu tape:

                  http://localhost:numero que tu a choisi

                  Dans le navigateur
                  • Partager sur Facebook
                  • Partager sur Twitter
                    18 juin 2013 à 1:58:54

                    voila la solution:

                    1. Launch RegEdit

                    2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP

                    3. Change the value of "start" to 4 (disabled)

                    4. Reboot your computer

                    • Partager sur Facebook
                    • Partager sur Twitter
                      18 juin 2013 à 7:01:20

                      Non mais n'importe quoi la ! Un serveur web qui n'écouterais pas sur le port 80, non, non et non ! Tu dois avoir un logiciel qui utilise ton port 80, la plupart du temps il s'agit de skype. Si ce n'est pas skype, liste les processus en cours quand tu as l'erreur stp.
                      • Partager sur Facebook
                      • Partager sur Twitter
                        22 juin 2013 à 23:52:20

                        Il est possible de connaitre les ports utilisés :

                        Permet de chercher les ports d'écoute

                        netstat -ano | find ":80"

                        Avec l'ID renvoyé tu peu trouver ton processus qui l'utilise 

                        tasklist | find "ID du processus"

                        • Partager sur Facebook
                        • Partager sur Twitter
                          1 avril 2014 à 12:37:05

                          panneau de configuration; ensuite activer désinstaller fonctionnalité . chercher IIS ........
                          • Partager sur Facebook
                          • Partager sur Twitter
                            2 avril 2014 à 22:43:21

                            Salut,

                            Sur wamp tu à un outil pas mal qui test le port 80 et liste touts les appli qui l'utilise

                            Clique gauche(pour souris droitier) sur Icône WampServer dans le sysTray(coté horloge) => Apache => Service => Test port 80

                            ;)

                            • Partager sur Facebook
                            • Partager sur Twitter
                            Infoxp ici depuis 2007
                              7 avril 2014 à 13:11:51

                              Si tu pouvais répondre à la question qui t'a été posée plusieurs fois, ça serait super : utilises-tu Skype?

                              Skype utilise le port 80, il te suffit de l'arrêter si c'est le cas.

                              • Partager sur Facebook
                              • Partager sur Twitter
                              System test engineer
                                19 mai 2016 à 22:51:39

                                Bonjour. Moi aussi j'ai le même problème mais quand je fait le test avec l'invite de commande (cmd) de apache et le port 80 , mais ça me met "Your port 80 is not actually used".

                                Je ne peut pas utiliser Wamp a cause de ça.

                                L'icône reste en rouge et n'est pas en vert.

                                Skype n'est pas ouvert, j'ai désactivé l'IIS (Internet Information Services ).

                                Tout ça est un problème car j'ai besoin d'utiliser Wamp le plus tôt possible pour mon projet personnel.

                                Si quelqu'un peut me répondre, merci.

                                • Partager sur Facebook
                                • Partager sur Twitter
                                  20 mai 2016 à 2:36:01

                                  demaistos a écrit:

                                  Il est possible de connaitre les ports utilisés :

                                  Permet de chercher les ports d'écoute

                                  netstat -ano | find ":80"

                                  Avec l'ID renvoyé tu peu trouver ton processus qui l'utilise 

                                  tasklist | find "ID du processus"

                                  Bonjour,

                                  Ce que Demaistos avait proposé à l'époque est exactement ce que tu dois faire pour trouver qu'est-ce qui utilise le port 80 sur ton ordinateur. Au lieu de tirer dans toutes les directions, commence par faire cette commande. Il y a une tonne d'applications qui utilise le port 80, cette commande te trouvera en quelques secondes la source...

                                  WalterB

                                  -
                                  Edité par WalterB 20 mai 2016 à 2:38:34

                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                    20 mai 2016 à 11:30:07

                                    Ce n'est pas le port 80 qui pose probleme, actuellement le message que tu as indique que "actuellement le port 80 n'est pas utilisé"

                                    Donc si Wamp reste en rouge c'est que tous les services ne démarre pas, donc accède au log de apache pour savoir ce qu'il se passe en faisant

                                    clique sur l'icon wamp dans le systray (horloge) => onglet Apache => Apache error log

                                    Regarde si le service MySql se lance en le forçant dans wamp => Onglet MySQL => Administration des services => Démarrer le service

                                    Ensuite regarde si PHP démarre

                                    Même si apache ne démarre pas normalement les autres services se lancent

                                    -
                                    Edité par Infoxp 20 mai 2016 à 11:33:08

                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                    Infoxp ici depuis 2007
                                      20 mai 2016 à 12:11:37

                                      Bonjour, 

                                      J'ai installé WAMP sur mon PC, l'icône apparaît bien dans ma barre des tâches, seulement au lieu d'être de couleur verte elle est de couleur orange, et un message indique : Serveur local - 1 service sur 2 lancé

                                      J'ai testé le Port 80. Voici ce que cela me dit: 

                                      ***** Test which uses port 80 *****

                                      ===== Tested by command netstat filtered on port 80 =====

                                      Test for TCP

                                      Your port 80 is used by a processus with PID = 4

                                      The processus of PID 4 is 'System' Session: Services

                                      The service of PID 4 for 'System' is 'N/A'

                                      *** ERROR *** This service IS NOT from Wampserver - Should be: 'wampapache'

                                      Test for TCPv6

                                      Your port 80 is used by a processus with PID = 4

                                      The processus of PID 4 is 'System' Session: Services

                                      The service of PID 4 for 'System' is 'N/A'

                                      *** ERROR *** This service IS NOT from Wampserver - Should be: 'wampapache'

                                      ===== Tested by attempting to open a socket on port 80 =====

                                      Your port 80 is actually used by :

                                      Server: Microsoft-IIS/10.0

                                      Donc en gros si je comprends bien (je suis une débutante de chez débutante...), le port 80 est utilisé par un autre programme ce qui empêche donc le plein fonctionnement de WAMP, c'est bien cela ou je suis à côté de la plaque???

                                      Et le pb a l'air de venir de Server: Microsoft-IIS/10.0

                                      Puis-je le désactiver ou alors le faire fonctionner sur un autre port? 

                                      Si oui, quel est le process à suivre pour le désactiver??

                                      MErci beaucoup à ceux/celles qui voudront bien m'aider :)

                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        20 mai 2016 à 13:50:00

                                        Et le pb a l'air de venir de Server: Microsoft-IIS/10.0

                                        Windows 10 Home si je ne m'abuse ? Il est "pré-installé" par défaut... Mode pas-si-conspirationniste-que-ça: c'est dans une tentative vicieuse de la part de Microsoft de faire revenir les devs amateurs vers des produits de chez eux faute de pouvoir mettre des outils tiers correctement. Verrouiller le système en gros. Ou faire payer la licence Win10 pro qui n'a pas ce problème -- j'avoue, ~240€ TTC la pro, ça pique.

                                        Essaie de passer par le panneau de config > ajout suppression de programmes > composants windows... et là faut fouiller parce qu'il ne s'appelle pas exactement IIS mais "Instance principale web des Internet Information Services (IIS)" (j'aurais dit IPWI2S "hipweetoose", ça en jette !) -- bel essai, Microsoft, tenter de planquer tes produits installés façon bloatware (coucou candy crush saga), mais ça ne suffira pas. Un peu de doc ici: http://forum.wampserver.com/read.php?1,135222,135228

                                        Option 2: Services (démarrer > exécuter > services.msc), service IIS (quelque soit son nom), arrêter, état: désactivé, hopla, adieu :p

                                        -
                                        Edité par Ze Thriller 20 mai 2016 à 13:51:05

                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                        Si vous voyez ce message non édité, c'est un miracle !
                                          20 mai 2016 à 15:47:04

                                          Merci @ZeThriller

                                          Et en effet habile tentative de Windows... 

                                          cependant lorsque je vais dans panneau de config etc.. il se trouve que Instance principale web des Internet Information Services (IIS) n'est pas activé.....bizarre bizarre .... mais je vais explorer le lien que tu m'as envoyé http://forum.wampserver.com/read.php?1,135222,135228

                                          Et également essayer la 2ème option dont tu parles!

                                          Je te tiens au courant si cela marche! 

                                          Merci :)

                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            20 mai 2016 à 16:11:32

                                            Super, j'ai trouvé mon bonheur sur le lien que tu avais envoyé @ZeKiller

                                            Et ce qui m'a servi est le point suivant : 

                                            En plus de désactiver IIS il faut aussi désactiver : 

                                            (W10) Décocher :
                                            -- Instance principale Web des Internet Information Services (IIS)
                                            -- Tous les items de la branche : Internet Information Services
                                            -- Tous les items de la branche : Service d'activation des processus Windows

                                            Pour ceux qui sont comme moi sous Windows 10 et qui font face au même pb que moi, je vous encourage à visiter ce lien : 

                                            http://forum.wampserver.com/read.php?1,88043

                                            Cela m'a permis de faire passer mon icône Wamp de orange à vert!! Grande avancée pour moi!

                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                              10 mai 2017 à 1:31:36

                                              J'avais un service system impossible à arrêter (le service microsoft-httpapi/2.0 sur windows 10) 

                                              Merci chaoswow., ton post du 18 juin 2013 à 1:58:54 était la solution à mon problème extreme !!!

                                              En prenant en compte que ceci était décoché : 

                                              -- Instance principale Web des Internet Information Services (IIS)
                                              -- Tous les items de la branche : Internet Information Services
                                              -- Tous les items de la branche : Service d'activation des processus Windows

                                              J'ai même utilisé ces lignes de commande (Vérifier si un autre programme utilise le port 80 et le tuer) :

                                              • Lancez l'invite de commande de Windows en tant qu'administrateur, et tapez netstat -ano | find "0.0.0.0:80". Retenez le dernier nombre de la ligne.
                                              • Entrez la commande tasklist et faites Entrée pour afficher la liste de tous les processus actifs.
                                              • tuer un processus en spécifiant son PID : taskkill /PID 4
                                              • ou tskill 4

                                              J'avais toujours le même message "le processus n'a pas pu être arrêté accès refusé" !

                                              Encore merci pour ta solution.

                                              • 1. Launch RegEdit
                                              • 2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
                                              • 3. Change the value of "start" to 4 (disabled)
                                              • 4. Reboot your computer

                                              Mon serveur wamp fonctionne ;)

                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                13 mai 2017 à 13:32:18

                                                Skype utilise le port 80, quitte le et relance les services wamp.
                                                • Partager sur Facebook
                                                • Partager sur Twitter
                                                  18 juillet 2017 à 12:12:17

                                                  Bonjour 

                                                  donc j'ai fixé mon problème de la port 80 sachant que je sous  Win_10 ,ainsi je tiens a vous remercie ;) 

                                                  Pour ceux qui sont comme moi sous Windows 10 et qui font face au même pb que moi, je vous encourage à visiter ce lien : 

                                                  http://forum.wampserver.com/read.php?1,88043

                                                  -
                                                  Edité par OussamaBatouche 18 juillet 2017 à 12:13:07

                                                  • Partager sur Facebook
                                                  • Partager sur Twitter
                                                    8 décembre 2017 à 12:44:34

                                                    Le remède : exécuter Invité de Commandes en Mode Administrateur, avec la commande : NET stop HTTP, 
                                                    la liste des processus utilisant le port 80 s'affiche, U KiLL Them ALL!!
                                                    That's All Folks.

                                                    -
                                                    Edité par houssamhamouda 8 décembre 2017 à 12:46:33

                                                    • Partager sur Facebook
                                                    • Partager sur Twitter

                                                    j'ai besoin du port 80 qui est déjà utilisé

                                                    × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                    × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                                    • Editeur
                                                    • Markdown