Partage

Ma page de démarre pas sur index.html

12 août 2017 à 0:47:21

Bonjour, 

Je me permets de vous demander de l'aide. Je débute tout juste dans le développement Web. Après avoir suivi le cours de HTML5/CSS de Mateo, j'ai ensuite pris un nom de domaine sur 1&1 sur lequel j'ai transférer mon fichier index.html et style.css. Ce qui m’embête c'est que pour arriver sur la l'index je suis obliger d'inscrire "www.lenomdemonsite.fr/index.html". Je vous demande donc comment faire pour arriver directement sur l'index en notant www.lenomdemonsite.fr.

Je vous remercie infiniment.

Bonne soirée.

12 août 2017 à 1:06:13

Salut!

C'est étrange il me semblent que normalement quand tu ouvre un fichier ou fait une demande sur le serveur il ouvre automatiquement index.html (à condition qu'il soit pas dans un fichier).

Sinon je pense que si tu passe par un fichier htacces ça devrait pourvoir ce faire du genre :

RewriteRule ^$ index.php [L]

Et du coup si un lien doit pointer vers index tu marque "url/" à la place de "url/index.html"

-
Edité par HadockB 12 août 2017 à 1:06:34

Je vous parraine sur Star Citizen (et vous gagnez 5000uec) >>STAR-VZXT-ZQVN<< - coffeecode
16 août 2017 à 18:56:38

Salut,

J'ai eu le même problème sur un hébergeur gratuit. J'avais mis toute les pages html à la racine. Ensuite j'ai vu qu'il y avait un dossier public_html. J'ai donc déplacer tout mes fichiers et dossiers dedans et le problème était réglé.

16 août 2017 à 19:05:24

Et la c'est quoi les dossier que tu as sur ton ftp?

https://assistance.1and1.fr/hebergement-c65619

Je vous parraine sur Star Citizen (et vous gagnez 5000uec) >>STAR-VZXT-ZQVN<< - coffeecode
17 août 2017 à 21:44:13

Voici un article intéressant de 1&1 :

https://assistance.1and1.fr/hebergement-c65619/acces-a-l-espace-web-c65660/http-c85263/les-noms-de-fichier-autorises-pour-la-page-d-accueil-par-defaut-a793345.html

Ils disent clairement que index.html est un format valide. A mon avis, tes fichiers ne sont tout simplement pas au bon endroit. Si tu as un dossier qui s'appel "public" ou "inetpub", tu dois les déplacer là dedans.

17 août 2017 à 23:49:19

si t'as toujours pas trouvé , vérifie que t'as pas mis index avec un i majuscule ^^ j'ai fais cette erreur lors de mon premier site :D
Commit du soir, espoir. Build du matin, chagrin
18 août 2017 à 0:03:16

hello,

Pas besoin de règle htaccess, le problème est autre...

- Comme dit Mamax64 pour commencer.

- As-tu bien associé ton dossier (qui contient les fichiers du site) au nom de domaine ? 

- Supprimer le fichier index.html placé par défaut (pub 1&1)

-
Edité par Lucky13 18 août 2017 à 0:04:41

Ma page de démarre pas sur index.html

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown