Partage
  • Partager sur Facebook
  • Partager sur Twitter

Maîtrisez vos applications et réseaux TCP/IP

Fil d'échange sur le cours

    18 avril 2020 à 11:47:15

    Bonjours,

    quand je fais la commande: sudo apt-get install net-tools sur linux il me renvoie l'erreur : Des erreurs on été rencontrées pendant l'exécution :

                                                                                                                                             faraday

                                                                                                                                             python-faraday

                                                                                                                                          E: Sud-process /usr/bin/dpkg returned an error code (1)

    Pouvez vous m'aider ?
    • Partager sur Facebook
    • Partager sur Twitter
      18 avril 2020 à 18:57:18

      Salut, je pense que ce lien te seras utile :

      https://phoenixnap.com/kb/fix-sub-process-usr-bin-dpkg-returned-error-code-1

      En général on trouve facilement des solutions juste en copiant le message d'erreur et de faire une recherche google sans modifier le message. Donc si le lien ne t'as pas aider à résoudre le problème tu peut essayer une recherche google tu auras plusieurs résultats, si tu n'arrive toujours pas à le résoudre tu pourras revenir sur le forum.

      • Partager sur Facebook
      • Partager sur Twitter
        30 avril 2020 à 22:12:15

        sitaberete : le lien vers la page Phoronix n'apporte aucune information utile.

        Dans le cas de ArmanLemee il semblerait plutôt qu'il manque une ou des dépendances.

        Ou peut-être une version particulère des bibliothèques dont il dépend.

        Et pour avoir une vue plus précise du problème il faudrait connaître la version de Debian ou de Ubuntu (ou Mint ?) utilisée

        de sorte à pouvoir aller voir dans les bases de données des paquets, quelle version de net-tools est appelée

        et trouver à partir de là le nom précis des paquets d'éventuelles dépendances manquanttes.

        Question pour ArmanLemee : le retour de la commande "sudo apt-get install net-tools" est-il complet ? J'ai l'impression qu'il n'y a pas dans toutes les informations retournées dans la console dans votre post.

        Si j'ai raison sur ce point pourriez-vous le refaire et utiliser le copié/collé pour fournir un retour complet ?

        • Partager sur Facebook
        • Partager sur Twitter
          6 mai 2020 à 8:27:36

          yannn a écrit:

          Apprenez le fonctionnement des réseaux TCP/IP

          bonjour

          Je bloque déjà à la fin du chapitre 1 :---)) . Le simulateur de réseaux proposé est pour Windows!

          j'ai pensé trouver facilement l'équivalent pour ubuntu... Nada queneni rien!!

          Est ce que GNS3 ferait l'affaire?

          si oui avez vous un lien pour l'installer


          Bonjour, ici GNS3 est installé sur une Debian 11 et cela fonctionne à merveille :)

          Votre machine est capable de virtualiser avec assez de mémoire ? 8Gb est un minimum si grosse archi à simuler, le cpu ne fait pas grand chose par contre :D

          Un lien ? Ben la doc officielle... Avez-vous recherché un tout petit peu ?

          https://docs.gns3.com/1QXVIihk7dsOL7Xr7Bmz4zRzTsJ02wklfImGuHwTlaA4/index.html#h.1qr8n6j2iplt

          Juste un point afin d'être clair : un simple copié-collé des commandes indiquées ne suffira pas, il faut comprendre ce que l'on fait et surtout penser qu'on peut bousiller son environnement si la machine est dédiée au travail.

          • Partager sur Facebook
          • Partager sur Twitter
            11 mai 2020 à 10:49:31

            Je viens de voir votre message , merci à vous

            je me suis débrouillé autrement ( en fait j'ai simulé le réseau sous windows)

            • Partager sur Facebook
            • Partager sur Twitter
              18 mai 2020 à 20:43:01

              Bonjour, 

              Je suis à l'étape 3 de l'exercice de routage. J'essaye de ping ma machine 10.0.10.1/24 depuis la machine 192.168.11.1/24, mais rien ne se passe.

              Et je n'arrive pas à comprendre pourquoi. 

              Dans ma table de routage de mes routeurs, j'ai pourtant bien précisé ceci :

              Routeur 1 :

              0.0.0.0  10.0.0.1

              10.0.10.0  192.168.10.253

              192.168.10.0  0.0.0.0

              192.168.11.0  0.0.0.0

              Routeur 2 :

              0.0.0.0  10.0.0.1

              10.0.10.0 0.0.0.0

              192.168.10.0  0.0.0.0

              192.168.11.0  192.168.10.254

              De plus, je ne comprends pas pourquoi quand je ping depuis la machine 10.0.10.1/24 vers la machine 192.168.10.1/24, je perds des paquets en cours de route :/

              Merci d'avance pour votre aide !

              Edit :

              J'ai trouvé apparemment. Enfin, j'ai réussi à ping depuis ma machine 192.168.11.1 vers 10.0.10.1.

              J'ai pas mal changé de truc donc j'arrive pas à savoir quel est le facteur qui bloquait.

              Je vais devoir refaire le processus proprement !

              Merci quand même :)

              -
              Edité par Sedatyf 18 mai 2020 à 23:25:43

              • Partager sur Facebook
              • Partager sur Twitter
                12 novembre 2020 à 18:03:17

                Bonjour à tous

                J'ai un souci avec le vdi de Debian que j'ai eu à télécharger en suivant le cours "apprenez le fonctionnement des réseaux tcp/ip ", la distributiion a un problème de connectivité internet. quand je lance la commande ifconfig voilà ce que ça affiche :

                mais lorsque j'installe une autre distribution qui n'est pas celle fournie dans le cours, je n'ai pas de problème de connectivité.

                Merci d'avance

                • Partager sur Facebook
                • Partager sur Twitter
                  25 novembre 2020 à 21:16:34

                  Bonjour,j'ai  une erreur pour la création de (création_utilisateurs_messagerie.sql):ERROR 1062 (23000) at line 1:Duplicate entry '1' for key 'PRIMARY'.

                  Merci pour la réponse.

                  • Partager sur Facebook
                  • Partager sur Twitter
                  • Azazele4
                    5 décembre 2020 à 3:52:21

                    slt comment on ajoute un routeur dans un projet gns3
                    • Partager sur Facebook
                    • Partager sur Twitter
                      10 janvier 2021 à 13:15:21

                      bonjour, je suis bloqué sur la partie 

                      "Mettez en place une solution de messagerie" 

                      lors de la mise en place de rainloop. Lorsque je tape rainloop.domaine.com dans l'URL, j'ai un site web qui n'a rien à voir qui s'affiche. J'ai pourtant fait la manip dans le fichier hosts (cf capture écran) mais le comportement n'est pas  celui attendu. Toutes les étapes précédentes ses ont bien déroulées donc je ne sais pas d'où vient l'erreur.

                      -
                      Edité par VivienRuas4 10 janvier 2021 à 13:16:16

                      • Partager sur Facebook
                      • Partager sur Twitter
                        23 avril 2021 à 15:47:47

                        VivienRuas4 a écrit:

                        bonjour, je suis bloqué sur la partie  (…)

                        Qu'est-ce qui s'affiche dans le navigateur web et qu'attendiez-vous comme résultat ?  Où est supposé se trouver "10.211.55.10" ? (les adresses IP qui commencent par "10" sont souvent des machines virtuelles).

                        /Curieux que personne ne vous aie répondu depuis janvier ?
                        /Je suis une apprenante comme vous, mais pas connectée sur ce cours en ce moment.

                        -
                        Edité par JoyceMarkoll1 23 avril 2021 à 15:49:49

                        • Partager sur Facebook
                        • Partager sur Twitter
                          11 mai 2021 à 0:50:43

                          Bonjour,

                          J'ai une question concernant la configuration du serveur web. Celui-ci n'est pas en local.

                          Comment puis-je faire en sorte d'accéder directement au répertoire www.monsite.com/repertoirevisé avec l'url repertoirevisé.www.mon site.com?

                          Suis-je obligé de créer un sous-domaine et donc de demander son enregistrement à celui qui gère mon domaine? Ou existe-t- il une astuce avec les alias ou autre?

                          Merci d'avance

                          • Partager sur Facebook
                          • Partager sur Twitter
                            18 mai 2021 à 0:32:50

                            Je n'ai jamais vu de sous-domaine avant un www. La pratique serait plutôt repertoirevise.mon site.com

                            Pour faire ce que vous souhaitez faire vous avez besoin de créer une redirection: redirection temporaire ou redirection permanente en fonction de ce que vous avez besoin de réaliser. Regardez quelques pages : https://duckduckgo.com/?t=ffsb&q=redirection+temporaire+ou+permanente+.htdoc&ia=web



                            -
                            Edité par JoyceMarkoll1 18 mai 2021 à 0:39:06

                            • Partager sur Facebook
                            • Partager sur Twitter
                              15 juillet 2021 à 7:59:45

                              bonjour Cher Monsieur, 

                              j'arrive pas à télécharger l'image de DEBIAN LINUX pour faire la pratique des TP dans le cours.

                              veuillez s'il vous plaît m'aider à en avoir.

                              attendant votre réponse, recevez mes salutations.

                              • Partager sur Facebook
                              • Partager sur Twitter
                                9 août 2021 à 20:38:19

                                KapankuMuyaya a écrit: j'arrive pas à télécharger l'image de DEBIAN LINUX pour faire la pratique des TP dans le cours.

                                veuillez s'il vous plaît m'aider à en avoir.


                                Je vous propose mon tutoriel sur le téléchargement des distributions Linux : https://orditux.org/bentovillage/2015/11/16/telecharger-et-graver

                                et un tutoriel plus spécifique pour choisir votre image disque de Debian, sur le site Debian Facile : https://debian-facile.org/doc:install:install
                                • Partager sur Facebook
                                • Partager sur Twitter
                                  26 novembre 2021 à 23:47:53

                                  Bonjour,

                                  Il y a un moment je bloque sur l'affichage de la page d'accueil de rainloop. J'ai le même problème que @VivienRuas4

                                  Merci pour votre aide 

                                  • Partager sur Facebook
                                  • Partager sur Twitter

                                  Maîtrisez vos applications et réseaux TCP/IP

                                  × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                  • Editeur
                                  • Markdown