Partage

Mettre à jour le MinGW GCC de Code::Blocks

Comment installer un nouveau gcc et le configurer sous Code::Blocks

8 mai 2018 à 1:49:03

> Mais dans tous les cas, pourquoi mingw-w64 et pas mingw ?

Je ne sais pas si ça a été réglé mais la dernière fois que j'ai utilisé MinGW de base, il ne supportait pas la compilation 64bits, t'imposait SJLJ comme modèle d'exception et ne supportait pas les threads de la lib standard. Trois choses réglées du côté de MinGW-w64. 

Nazara Engine | Discord NaN ! (Chat dédié à la programmation) | Ma chaîne Twitch (développement)
8 mai 2018 à 8:38:40

C'est un tuto debutant, je ne suis pas sur que le 64b et SJLJ soient pertinent. Et pour les threads, j'espère que c'est réglé depuis le temps.
Pour poser des questions ou simplement discuter informatique, vous pouvez rejoindre le discord NaN.
8 mai 2018 à 9:26:08

Justement, raison de plus pour rediriger les débutants vers des solutions déjà préparées comme elles le devraient (SEH/DW2) ou autorisant la compilation en 64bits (ce que les débutants veulent souvent faire).
Nazara Engine | Discord NaN ! (Chat dédié à la programmation) | Ma chaîne Twitch (développement)
18 mai 2018 à 16:53:45

Bonjour,

Qu'en est-il exactement avec :

- la version 17.12 de Code::Blocks;

-MinGW installation manager qui propose beaucoup d'options, dont je ne suis pas certain de trouver les bonnes. La preuve, "ça marche pô!";

- enfin tous les "settings" proposés pour Code::Blocks. J'ai ainsi, entre autres "file C++14, message No such file or directory"

En résumé, "Help!"

Merci d'avance,

Cordialement,

JYV

Mettre à jour le MinGW GCC de Code::Blocks

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown