Partage
  • Partager sur Facebook
  • Partager sur Twitter

MOOC Apprenez le fonctionnement des réseaux TCP/IP

A la découverte du fonctionnement d'Internet

    19 mai 2019 à 18:54:45

    Bonjour 

    C'est ce que j'avais fait mais ça reste muet. J'ai pris soin de modifier les tables de routage de chaque poste afin d'y ajouter les routes pour accéder aux réseaux hors d'atteintes 

    Sur mon poste 192.168.1.68 

    sur mon routeur (eth0 : 192.168.1.126 eth1 : 192.168.1.129)

    et enfin sur mon poste serveur de DHCP (192.168.1.130)

    -
    Edité par steph_du_13 20 mai 2019 à 10:00:12

    • Partager sur Facebook
    • Partager sur Twitter
      20 mai 2019 à 12:30:46

      Et dans virtualbox, es-tu sûr que les interfaces sont sur les bons réseaux ? tu peux le voir avec les adresses MAC. Pour toi ce sera au niveau du routeur.

      Et que donne un arp -an après un test de ping ?

      -
      Edité par elalitte 20 mai 2019 à 12:31:14

      • Partager sur Facebook
      • Partager sur Twitter
        20 mai 2019 à 22:15:52

        Bonsoir,

        Je ne comprends pas le lien entre l'@ mac et le réseau. Sur mes vm, j'ai paramétré un réseau par défaut Natnetwork idem pour toutes les interfaces.

        pour mon poste 192.168.1.68, voici le retour de arp

        pour mon poste 192.168.1.130

        et enfin pour le routeur

        • Partager sur Facebook
        • Partager sur Twitter
          21 mai 2019 à 10:35:27

          Parce que tu as deux interfaces, et deux réseaux. Comment savoir que telle ou telle interface est dans tel ou tel réseau ? l'adresse mac peut te le dire vu que tu la vois dans virtualbox et sous linux.
          • Partager sur Facebook
          • Partager sur Twitter
            21 mai 2019 à 12:45:31

            Là tu m'as perdu. Je suis bien obligé d'avoir 2 interfaces sur mon routeur, puisqu'il sert à joindre

            mes 2 réseaux ? C'est l’intérêt du routage non ?

            En tout état de cause merci pour le temps que tu y consacres.

            -
            Edité par steph_du_13 21 mai 2019 à 12:45:53

            • Partager sur Facebook
            • Partager sur Twitter
              21 mai 2019 à 16:53:08

              Bonjour professeur!

              jusque la je ne comprend pas pourquoi mettre en place un serveur DHCP nous même (je fais allusion au TP mise en place d'un serveur DHCP sur debian). je demande cela parce-que chaque ordinateur se vois attribuer une adresse IP lorsqu'il est connecté à un réseau. deuxièmement est-ce le système d'exploitation ou le routeur qui contient le serveur DHCP qui fourni de façon dynamique les adresses IP?

              Merci

              • Partager sur Facebook
              • Partager sur Twitter
                22 mai 2019 à 17:09:42

                @Steph_du_13: En fait, sur virtual box, tu as deux interfaces réseau, une que tu connectes à réseau 1, et une autre à réseau 2 (c'est un exemple)

                Ensuite quand tu démarres la machine, tu as deux interfaces réseau eth0 et eth1, par exemple, mais le seul moyen de savoir laquelle est connectée sur réseau 1 ou réseau 2 est de regarder l'adresse MAC.

                @Raymond: En fait si les machines obtiennent automatiquement une adresse, c'est qu'il y a un serveur DHCP sur le réseau. Cependant, si un jour tu fabriques toi même un réseau, il faudra que tu y ajoutes toi même un serveur DHCP. Très souvent, c'est la box qui donne accès à Internet qui a un serveur DHCP intégré.

                -
                Edité par elalitte 22 mai 2019 à 17:11:08

                • Partager sur Facebook
                • Partager sur Twitter
                  23 mai 2019 à 13:46:56

                  Merci professeur réponse très satisfaisante. cependant comment peut-on  mettre en place un serveur DHCP sous  Windows? faut-il forcement un système d'exploitation Windows serveur? peut-on le faire avec un système linux dans un environnement Windows?
                  • Partager sur Facebook
                  • Partager sur Twitter
                    23 mai 2019 à 17:26:55

                    Oui à toutes tes questions, tu peux mettre en place un serveur DHCP sur à peu près ce que tu veux, et comme c'est lié aux réseaux, c'est indépendant de l'OS.
                    • Partager sur Facebook
                    • Partager sur Twitter
                      29 mai 2019 à 16:33:38

                      bien pris ! merci beaucoup pour le temps à nous consacré
                      • Partager sur Facebook
                      • Partager sur Twitter
                        8 juin 2019 à 17:01:50

                        bonjour,

                        je suis à l’exercice final, ma question est la suivante:

                        l'adressage demandé est en /24, sachant qu'il faut créer un réseau local et une DMZ. Si je choisis par exemple un réseau en 192.168.10.0/24 et que je le divise en deux sous réseaux, le masque va changer , il ne sera plus en /24. est ce que je me trompe. Ou alors je choisi par exemple un réseau en 192.168.10.0/24 et l'autre en 192.168.11.0/24.

                        merci pour votre aide

                        • Partager sur Facebook
                        • Partager sur Twitter

                        Administrateur Systèmes et réseaux informatiques

                          8 juin 2019 à 18:04:39

                          Bonjour,

                          Vous avez un réseau en /24 et non deux. Votre deuxième idée me paraît donc erronée. Je vous conseille également d'optimiser votre découpage pour ne pas perdre trop d'adresses IP.

                          Bonne continuation !

                          -
                          Edité par alban100 8 juin 2019 à 18:04:58

                          • Partager sur Facebook
                          • Partager sur Twitter
                            11 juin 2019 à 13:15:08

                            @Jean-Philippe : Il faut que tu découpes, et donc avec de nouveaux masques. La solution que tu proposes n'est pas bonne car tu sors de la plage proposée.

                            Merci Alban100 pour les bons conseils.

                            • Partager sur Facebook
                            • Partager sur Twitter
                              11 juin 2019 à 16:42:42

                              Quelles sont les conditions d'obtentions du certificat d’étude?
                              • Partager sur Facebook
                              • Partager sur Twitter
                                11 juin 2019 à 17:22:00

                                MEDJEGNANKARABOUE a écrit:

                                Quelles sont les conditions d'obtentions du certificat d’étude?


                                Il suffit de suivre le cours et de valider les Quiz et Activités dédiées à celui-ci.

                                Bien à vous

                                • Partager sur Facebook
                                • Partager sur Twitter
                                La chute n'est pas un échec, l'échec c'est de rester là où on est tombé!
                                  21 juin 2019 à 15:15:38

                                  elalitte a écrit:

                                  @Jean-Philippe : Il faut que tu découpes, et donc avec de nouveaux masques. La solution que tu proposes n'est pas bonne car tu sors de la plage proposée.

                                  Merci Alban100 pour les bons conseils.



                                  • Partager sur Facebook
                                  • Partager sur Twitter

                                  Administrateur Systèmes et réseaux informatiques

                                    24 juin 2019 à 23:09:54

                                    Bonjour à tous, et merci Eric pour ce superbe MOOC passionant !

                                    Je suis au tp final, et comme de nombreuses personnes, il m'a fallu me replonger dans le découpage des plages d'adresse.

                                    En effet, je n'avais pas conceptualisé le fait que le réseau pourrait donner des sous réseaux...

                                    Après calcul des plages d'adresses (que j'ai choisi) et leur masque respectif, cela me donne quelque chose du genre :

                                    J'ai choisi un réseaudu genre :xxx.xxx.x.x et après découpage des plages je trouve un truc du genre :

                                    pour le sous réseau 1 : plage 192.168.0.x à 192.168.0.xx avec masque /28

                                    pour le sous réseau 2 : plage 192.168.0.xxx à 192.168.0.xxx avec masque /29

                                    Est ce qu'éventuellement je suis sur la bonne voie ou est ce que je dois tout reprendre à 0 !

                                    En vous remerciant,

                                    P.

                                    -
                                    Edité par B@rdem il y a moins de 5s



                                    -
                                    Edité par B@rdem 25 juin 2019 à 16:30:33

                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                      25 juin 2019 à 14:42:47

                                      Ca me semble pas mal ;-)

                                      Par contre si tu proposes des solutions, essaye de les mettre en spoiler pour ne pas les donner à des personnes qui feraient les exercices.

                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        25 juin 2019 à 16:50:31

                                        Merci infiniment pour votre réponse. Je commençais à perdre la tête à faire et refaire !

                                        Effectivement, j'ai spoilé sans avoir pourtant l'intention de le faire... cependant, en souhaitant éditer mon message, je n'ai pas trouvé les balises [spoiler] et [/spoiler]...j'ai donc édité le message en remplaçant les octets par des x en attendant mieux !

                                        Encore merci, à bientot !

                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          27 juin 2019 à 19:12:53

                                          Bonjour!

                                          j'ai un souci avec scapy lorsque j'essaie de l’exécuter. en effet lorsque je le lance (./arpcachepoison) pour voir sa syntaxe comme illustrer dans le cours (bien-sur après l'avoir éditer dans l'éditeur "nano" et rendu exécutable avec "chmod 755 aprcachepoison"), j'obtiens une erreur dans le script sur la premiere ligne (from scapy.all import *) et la quatrième comme sur cette image.

                                           Erreur dans le script

                                          voici le script que j'ai pris dans le cours :script scapy

                                          svp besoin d'aide !!!

                                          je tiens a précisé que j'ai installé comme sniffer "python-scapy" au lieu de scapy comme dans le cours cas c'est celui ( python-scapy) que ma fournir la

                                          commande "apt-cache search scapy" et j'ai donc installer. en changeant même dans le script fournir la première ligne "from scapy.all import *" par

                                          "from python-scapy.all import *" j'ai les mêmes erreurs.

                                          Besoin d'aide svp !:(

                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            28 juin 2019 à 8:30:17

                                            Bonjour ,

                                            Je m'excuse si mon question est débile par avance .

                                            Je suis actuellement en train d'utiliser le protocole SSH et d'apprendre son fonctionnement . Pour cela , j'ai paramétré une machine pour que je puisse m'y connecter . Jusque là , aucun soucis .

                                            J'essaye de comprendre le fonctionnement de SSH , donc j'ai sniffé la connexion avec wireshark , et sans que je comprenne pourquoi , lors du sniffing , des paquets TCP comportant comme adresses IP SRC et DST mes 2 machines utilisant SSH s’entremêlent avec les paquets SSH  .

                                            En vous remerciant ,

                                            Cordialement ,
                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                              28 juin 2019 à 11:20:21

                                              @FranGoul: Est-ce que scapy fonctionne ? si tu mets dans la ligne de commande # scapy ?

                                              @charlesdumoureux: c'est normal, les paquets TCP sont des paquets de signalisation, qu'il y a dans la plupart des connexions TCP/IP.

                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                30 juin 2019 à 3:02:58

                                                elalitte a écrit:

                                                @FranGoul: Est-ce que scapy fonctionne ? si tu mets dans la ligne de commande # scapy ?

                                                non pas du tout, cela ne fonctionne pas



                                                -
                                                Edité par FranGoul 30 juin 2019 à 3:04:44

                                                • Partager sur Facebook
                                                • Partager sur Twitter
                                                  15 juillet 2019 à 18:15:20

                                                  Bonjour,

                                                  Merci beaucoup pour votre cours d'une grande qualité.

                                                  J'en suis au chapitre 4.2 Le service DNS et j'ai un petit problème lors de la mise en pratique que je n'arrive absolument pas à résoudre (ni à comprendre d'ailleurs). Jusqu'à présent, toutes les mises en pratiques ont très bien fonctionné, je travaille sous macOS Mojave.

                                                  J'ai lancé 2 machines Debian à l'aide de VirtualBox. J'ai suivi toutes les étapes jusqu'à la partie Vérification (aucun problème pour localiser les fichiers ni pour les modifier).

                                                  Tout d'abord j'exécute : 

                                                  cat /etc/resolv.conf

                                                  J'obtiens : 

                                                  search home
                                                  nameserver 192.168.1.1

                                                  Pourquoi ce ".1.1" et non ".0.1" ? J'ai pourtant bien fait attention à changer l'adresse de mes deux machines en 192.168.0.1 et 192.168.0.2 .

                                                  L'erreur me semble anodine et je ne sais l'expliquer je continue le cours et exécute : 

                                                  host -t ns reseau.fr

                                                  Et obtiens :

                                                  reseau.fr name server ns1.dataxy.fr.
                                                  reseau.fr name server ns0.dataxy.fr.

                                                  Qui est ce ".dataxy" ? Et pourquoi "ns0" et non "ns2" ? Décidément quelque chose ne va pas mais je continue tout de même.

                                                  J'exécute alors :

                                                  host -t a ns1.reseau.fr

                                                  Et obtiens : 

                                                  ns1.reseau.fr has address 5.135.252.9

                                                  Bon, là je me doute que ça ne sert à rien de continuer. Je cherche donc un peu partout qui peut bien être ce 5.135.252.9 et surtout qu'est ce qu'il fait là. Sachant que ma machine virtuelle n'arrive pas à joindre google.fr (donc qu'elle n'est pas connecté à Internet je suppose) j'imagine mal comment cette adresse publique est arrivée ici.

                                                  J'ai ensuite re-vérifié les adresses IP de mes 2 machines, aucune ne ressemble de près ou de loin à 5.135.252.9, elles sont toutes les deux restés à leur état initial (192.168.0.1 et 192.168.0.2).

                                                  Si vous avez une quelconque explication à mon problème je serai ravi de la lire.

                                                  Merci d'avoir consacré votre temps à la lecture de mon problème.

                                                  Cordialement,

                                                  AdrKacz







                                                  • Partager sur Facebook
                                                  • Partager sur Twitter
                                                    16 juillet 2019 à 10:01:50

                                                    @AdrKacz : Ce que tu obtiens est tout à fait normal.

                                                    En gros dans ton fichier resolv.conf, le serveur DNS indiqué n'est pas ta machine, mais sûrement ta box.

                                                    Donc quand tu fais une requête DNS, c'est ta box qui répond et elle répond avec le vrai propriétaire de réseau.fr, tu obtiens donc une adresse IP publique !

                                                    Change dans ton resolv.conf le nameserver pour mettre l'adresse de ton serveur DNS, et tu verras que tu auras alors la bonne réponse.

                                                    Sinon dans ta commande host, tu peux préciser l'adresse du serveur que tu veux interroger à la fin de ta commande, par exemple :

                                                    host -t NS reseau.fr 192.168.0.1

                                                    -
                                                    Edité par elalitte 16 juillet 2019 à 10:02:03

                                                    • Partager sur Facebook
                                                    • Partager sur Twitter
                                                      18 juillet 2019 à 18:20:57

                                                      Merci beaucoup,

                                                      Effectivement tout fonctionne parfaitement maintenant.

                                                      Bonne soirée.

                                                      • Partager sur Facebook
                                                      • Partager sur Twitter
                                                        20 juillet 2019 à 15:42:44

                                                        Bonjour,

                                                        J'ai de nouveau une petite question. Visiblement la fin de ce cours me pose plus de problème que son commencement.

                                                        Je suis entrain de lire le chapitre Le service Web section Mise en place et configuration.

                                                        J'installe donc apache2 ainsi que libapache2-mod-php5 et php5-mysql à l'aide de apt-get, puis je vérifie que le port 80 écoute bien à l'aide de la commande netstat. Jusqu'ici tout fonctionne.

                                                        J'effectue tout cela dans une machine virtuelle lancé sous VirtualBox. J'ai choisi 192.168.0.1 comme adresse IP de ma machine virtuelle. Je travail sous macOS.

                                                        Cependant, lorsque sous Firefox j'entre http://192.168.0.1 (j'ai aussi essayé http://192.168.0.1:80 mais comme je pouvais le deviner le résultat et le même), Firefox me renvoie "Unable to connect" ou "The connection has timed out". (Firefox version 68.0.1)

                                                        Comment pourrais-je faire pour résoudre le problème ?

                                                        Je note cependant un point qui est peut-être la cause du problème (rien n'est moins sur, je ne m'y connais pas du tout).

                                                        Lorsque, dans le terminal de mon ordinateur, j'exécute en ligne de commande ifconfig, je remarque que mon ordinateur semble connecté au réseau via l'interface en0 (et non eth0). Mon ordinateur est connecté à la Box par le Wi-fi (pas de connection filaire possible).

                                                        D'ailleurs que ce que en signifie ? Il n'y a aucune interface eth sur mon ordinateur.

                                                        Cordialement,

                                                        Adrien Kaczmarek

                                                        • Partager sur Facebook
                                                        • Partager sur Twitter

                                                        MOOC Apprenez le fonctionnement des réseaux TCP/IP

                                                        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                        • Editeur
                                                        • Markdown