Partage
  • Partager sur Facebook
  • Partager sur Twitter

MOOC Swift iOS

    2 mai 2020 à 23:00:22

    Cmd - A puis Ctrl - I

    • Partager sur Facebook
    • Partager sur Twitter
      3 mai 2020 à 0:49:47

      Geda a écrit:

      Cmd - A puis Ctrl - I

      Geda, vraiment merci!

      Je n'ai pas vraiment compris pourquoi je me retrouve dans cette situation,

      Avant, seul le "mode auto" ne marchait pas, et je n'avais pas de beug en bas, tout le reste fonctionnait.

      C'est l'activation du mode auto qui a généré mon beug dans le code de fin qui est du Swift 3, avec quelques évolutions.

      Là je sèche! Aurais-tu des solutions à investiguer? 

      Merci à toi de me guider. Pierre


      C'est la boucle qui disfonctionnerait .. mais où?

      Merci et à bientôt

      Pierre

      • Partager sur Facebook
      • Partager sur Twitter
        3 mai 2020 à 4:13:18

        Maintenant que le code en bas est correctement indenté on y voit beaucoup plus clair ! Comme tu peux le voir, il n’y a aucune indentation ligne 56 à 63, ce qui signifie que tes fonctions ne sont déclarés dans une aucune classe. En effet tu fermes ta classe à la ligne 55.

        Pense à bien indenter ton code au fur et à mesure. Je pense que c’est une erreur que tu n’aurais pas faite si tu l’avais fait dès le début. C’est complètement normal d’être perdu dans ces conditions. D’ailleurs tu risques d’avoir d’autre bug, je te conseille de tout relire (s’il n’y a que 56 lignes ça devrait être rapide).

        Pour les messages j’ai rien compris. C’est un crash ? Sur quelle ligne ? quelle est la Stack ? (Le truc qui apparaît en colonne à gauche lors d’un crash et que tu peux afficher en tapant “bt” dans la console de debug lors du crash )

        EDIT : bon j’ai relu, y’a pas d’autre bug. Dans ta fonction textModifie tu fais 3 if alors que tu pourrais n’en faire qu’un :

        if Int(sender.text ?? “”) == 8

        Ou même

        if sender.text == “8”

        Tu n’as pas besoin de vérifier qu’il soit nul ou vide. Ça te retournera faux si c’est le cas.

        -
        Edité par Geda 3 mai 2020 à 4:20:40

        • Partager sur Facebook
        • Partager sur Twitter
          4 mai 2020 à 2:20:04

          Geda a écrit:

          Maintenant que le code en bas est correctement indenté on y voit beaucoup plus clair ! Comme tu peux le voir, il n’y a aucune indentation ligne 56 à 63, ce qui signifie que tes fonctions ne sont déclarés dans une aucune classe. En effet tu fermes ta classe à la ligne 55.

          Pense à bien indenter ton code au fur et à mesure. Je pense que c’est une erreur que tu n’aurais pas faite si tu l’avais fait dès le début. C’est complètement normal d’être perdu dans ces conditions. D’ailleurs tu risques d’avoir d’autre bug, je te conseille de tout relire (s’il n’y a que 56 lignes ça devrait être rapide).

          Pour les messages j’ai rien compris. C’est un crash ? Sur quelle ligne ? quelle est la Stack ? (Le truc qui apparaît en colonne à gauche lors d’un crash et que tu peux afficher en tapant “bt” dans la console de debug lors du crash )

          EDIT : bon j’ai relu, y’a pas d’autre bug. Dans ta fonction textModifie tu fais 3 if alors que tu pourrais n’en faire qu’un :

          if Int(sender.text ?? “”) == 8

          Ou même

          if sender.text == “8”

          Tu n’as pas besoin de vérifier qu’il soit nul ou vide. Ça te retournera faux si c’est le cas.

          -
          Edité par Geda il y a environ 20 heures

          Bonjour Geda,

          j'ai beaucoup évolué, mais ça bug encore..après avoir commencé ce post, j'ai fait une autre modif pour essayer en réfléchissant afin de chercher et trouver l'erreur.

          Je me retrouve avec une autre suggestion de problème!

          Je te mets ça en photo ci dessous.

          J'ai bien avancé grâce à toi, mais j'ai encore besoin de tes pistes, pour réfléchir dans la bonne direction.

          Donc ensuite, avec d'autres modifs,  je me retrouve avec ceci comme erreur.

          Dès que ça fonctionne je simplifierai les 3 if en un, comme tu m'as gentiment informé.

          Encore merci.

          A bientôt

          Pierre



          -
          Edité par Pierre102 4 mai 2020 à 2:23:45

          • Partager sur Facebook
          • Partager sur Twitter
            4 mai 2020 à 6:38:27

            Regarde ce que te dit l’indentation. Le nombre d’espace à gauche t’indique le “niveau de profondeur” d’un bloc. C’est pour t’aider à te repérer rapidement. Tes fonctions devraient etre toutes au même niveau. T’es en train de les imbriquer les unes dans les autres.

            • Partager sur Facebook
            • Partager sur Twitter
              4 mai 2020 à 17:33:24

              Geda a écrit:

              Regarde ce que te dit l’indentation. Le nombre d’espace à gauche t’indique le “niveau de profondeur” d’un bloc. C’est pour t’aider à te repérer rapidement. Tes fonctions devraient être toutes au même niveau. T’es en train de les imbriquer les unes dans les autres.

              Merci à toi, pour ton suivi et ton accompagnement.

              J'ai progressé, j'ai trouvé le manque de parenthèse pour un @Outlet...grâce à l'indentation.

              Il me reste un autre soucis, dès résolu j'édite ce message.

              A plus

              J'édite :

              C'est la catastro..M.... (LOL)

              Je n'ai plus d'erreur dans mon swift, il est impeccablement indenté...Une vrai merveille, j'avais oublié du texte, j'ai bidouillé et pratiquement j'ai tout refait! rien de mieux pour apprendre quand on ne veut pas finir le cours sur le Swift.

              Donc c'est impeccable, mon sourire jusqu'au oreille, je me fais une tisane de grand mère, 2h du matin oblige...et là...je le lance sur Simulator... patatrac.. gros beug écran noir.. je suis basculé sur un swift... 

              Exception?? Terme que je vais aller chercher sur internet, en espérant que tu pourras me guider de nouveau... A dès que tu peux.

              Pierre

               Mon .Swift

              -
              Edité par Pierre102 5 mai 2020 à 3:07:07

              • Partager sur Facebook
              • Partager sur Twitter
                5 mai 2020 à 6:33:40

                À gauche de la console tu as un truc blanc avec des informations sur l’erreur. Il est trop petit donc les informations sont tronquées. Agrandis le.

                Ceci dit, c’est probablement une erreur dans un storyboard : classe mal définie, Outlet mal branché, ...

                -
                Edité par Geda 5 mai 2020 à 6:35:22

                • Partager sur Facebook
                • Partager sur Twitter
                  5 mai 2020 à 11:24:29

                  Geda a écrit:

                  À gauche de la console tu as un truc blanc avec des informations sur l’erreur. Il est trop petit donc les informations sont tronquées. Agrandis le.

                  Ceci dit, c’est probablement une erreur dans un storyboard : classe mal définie, Outlet mal branché, ...

                  -
                  Edité par Geda il y a environ 3 heures

                  Bonjour Geda,

                  je te mets le texte sur fond Blanc. Je regarde,

                  et j’édite ce message une fois l'objectif atteint.


                  C'est mon Bouton.. bFin.. je cherche encore...

                  Je re en éditant

                  -
                  Edité par Pierre102 5 mai 2020 à 11:39:50

                  • Partager sur Facebook
                  • Partager sur Twitter
                    5 mai 2020 à 12:54:06

                    Envoie plutôt des nouveaux messages pour que je reçoive des notifications.

                    C’est ton IBOutlet qui est mal branché comme je disais. Va dans ton storyboard, sélectionne le ViewController, dans le panel de droite, dernier onglet, supprime la connection et refait la. Peut être que tu en as plusieurs pout le même outlet. Dans ce cas supprime les toutes

                    Ou parle en privé si tu veux pas polluer. De toute façon je serai le seul à te répondre ici

                    • Partager sur Facebook
                    • Partager sur Twitter
                      6 mai 2020 à 1:45:30

                      Bonjour Geda,

                      je préfère rester ici si cela ne te dérange pas pour que tu me fasses travailler afin que je puisse finir ce tuto.

                      Je pense tout refaire demain, ne trouvant pas la solution.

                      Y a dix minutes, j'ai trouvé ces panneau jaune de bug.

                      Je les ai supprimé,

                      sinon ca ne marche pas, après avoir refait mas outlet et action deux fois.

                      Demain je refais tout, clean... j'avais obtenu un résultat correct, sans le fonctionnement  du bouton swich.

                      Merci à toi.

                      Je te donne des nouvelles.

                      Pierre

                      • Partager sur Facebook
                      • Partager sur Twitter
                        11 mai 2020 à 2:41:43

                        Bonjour la file , bonjour Geda,

                        Ça y est on est déconfiné..et je n'ai pas réalisé la plupart de mes objectifs...Lol... je m'en étais fixé tellement.

                        Alors merki, c'est ok, ça fonctionne enfin "et merci hein"..j'ai tout refait en faites (Pas été capable de trouver mon beug) et ça fonctionne très bien sous Iphone 8 mais pas sur iphone 11, je n'ai pas le clavier qui s'affiche.. par contre incapable de trouver la solution sur les forums.. Toujours pareil si tu peux me guider pour que je travaille des recherches dans la bonne direction...

                        Je te mets deux photos...qui explique le non fonctionnement sur Iphone 11

                        Ce problème ne m'empêche pas de travailler la suite sur Iphone 8.. je donne des nouvelles

                        Pierre

                        • Partager sur Facebook
                        • Partager sur Twitter
                          12 mai 2020 à 23:59:03

                          Probablement un bug du simulateur. J’ai rencontré le même problème récemment.
                          • Partager sur Facebook
                          • Partager sur Twitter
                            13 mai 2020 à 3:21:22 - Message modéré pour le motif suivant : Merci d'utiliser le bouton code du forum pour insérer votre code


                            MOOC Swift iOS

                            × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                            • Editeur
                            • Markdown