Partage
  • Partager sur Facebook
  • Partager sur Twitter

[nuxt documentation] error

    27 septembre 2021 à 19:57:41

    Bonjour, quand je créer une app create-nuxt-content-docs 

    et que je le lance:

    npm run dev

    il y a cette erreur:

    The `text-current` class does not exist, but `fill-current` does. If you're sure that `text-current` exists, make sure that any `@import` statements are being properly processed before Tailwind CSS sees your CSS, as `@apply` can only be used for classes in the same CSS tree.
    

    tailwind.config.js:

    module.exports = {
      purge: [],
      darkMode: false, // or 'media' or 'class'
      theme: {
        extend: {},
        colors: require('tailwindcss/colors')
      },
      variants: {
        extend: {},
      },
      plugins: [],
    }

    nuxt.config.js:

    import theme from '@nuxt/content-theme-docs'
    
    export default theme({
      docs: {
        primaryColor: '#E24F55'
      }
    })

    package.json:

    {
      "name": "pydocs",
      "version": "1.0.0",
      "private": true,
      "scripts": {
        "dev": "nuxt",
        "build": "nuxt build",
        "start": "nuxt start",
        "generate": "nuxt generate"
      },
      "dependencies": {
        "@nuxt/content-theme-docs": "^0.10.1",
        "nuxt": "^2.15.2"
      },
      "devDependencies": {
        "@nuxtjs/tailwindcss": "^4.2.1",
        "autoprefixer": "^10.3.6",
        "postcss": "^8.3.8",
        "tailwindcss": "^2.2.16"
    
      }
    }

    merci de votre attention




    • Partager sur Facebook
    • Partager sur Twitter

    [nuxt documentation] error

    × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
    • Editeur
    • Markdown