Partage
  • Partager sur Facebook
  • Partager sur Twitter

Ouvrir un port sur Centos 7 avec Plesk

Sujet résolu
    21 juillet 2022 à 17:49:00

    Bonjour à tous,

    Je me heurte à un problème assez embêtant, je m'explique.

    J'ai un serveur qui tourne sous CentOS 7 avec Plesk (chut, j'ai pas le choix :( ) et je dois le monitorer avec Zabbix. Pour ça j'ai installé l'agent sur le serveur sans problème, il tourne bien. En revanche pour que ça fonctionne, le serveur zabbix distant doit communiquer avec mon CentOS par le port 10050, et là, ça se complique. Je ne parviens pas à ouvrir ce port !

    J'ai essayé en passant par le firewall Plesk, ça ne marche pas :

    J'ai testé en désactivant le firewall plesk via :

    service psa-firewall stop

    J'ai testé en désactivant le firewall de centOS :

    sudo systemctl stop firewalld


    Bref, même en coupant tous les firewall, rien ne passe, rien n'est reçu via :

    tcpdump -i any -n tcp port 10050

    J'ai tenté également : 

    firewall-cmd --zone=public --add-port=100050/tcp --permanent
    iptables -I INPUT 1 -p tcp --dport=10050 -j ACCEPT

    Mais rien à faire, ça veut pas ! Pourtant, j'obtient bien ceci :

    # netstat -tulnp | grep 10050
    tcp        0      0 0.0.0.0:10050           0.0.0.0:*               LISTEN      127473/zabbix_agent
    tcp6       0      0 :::10050                :::*                    LISTEN      127473/zabbix_agent
    

    Si quelqu'un a une idée .. car là je sèche, merci ! ;) 




    • Partager sur Facebook
    • Partager sur Twitter
      21 juillet 2022 à 22:54:21

      alantheo a écrit:

      Bref, même en coupant tous les firewall, rien ne passe, rien n'est reçu via :

      tcpdump -i any -n tcp port 10050


      Bah là ça veut clairement dire que ton flux est bloqué avant même d'arriver sur ton CentOS !

      Il y a autre chose qui bloque avant.

      -
      Edité par lecbee 21 juillet 2022 à 22:54:36

      • Partager sur Facebook
      • Partager sur Twitter
        22 juillet 2022 à 9:58:38

        lecbee a écrit:

        Bah là ça veut clairement dire que ton flux est bloqué avant même d'arriver sur ton CentOS !

        Il y a autre chose qui bloque avant.

        Effectivement bien vu, le client avait un pare-feu physique .......... merci !

        -
        Edité par alantheo 22 juillet 2022 à 11:42:51

        • Partager sur Facebook
        • Partager sur Twitter

        Ouvrir un port sur Centos 7 avec Plesk

        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
        • Editeur
        • Markdown