Partage
  • Partager sur Facebook
  • Partager sur Twitter

PHP 5.3 et date.timezone

Sujet résolu
    22 octobre 2009 à 14:29:39

    Bonjour,

    je suis actuellement entrain de créer un serveur web et j'ai installé php 5.3 sans problème. J'ai configuré le fichier php.in mais j'ai un problème avec date.timezone, voilà ce que j'ai mit:

    date.timezone = "Europe/Paris"

    Qu'est ce qui cloche ?

    PS: j'ai remarqué le problème avec la fonction phpinfo qui me dit que ma zone n'est pas configurer


    Je vous remercie pour votre aide :)
    • Partager sur Facebook
    • Partager sur Twitter
      22 octobre 2009 à 14:31:55

      J'ai déjà essayé mais ça n'a pas marché
      • Partager sur Facebook
      • Partager sur Twitter
        22 octobre 2009 à 14:35:45

        Tu as redémarré le serveur entre-temps ?
        Normalement il n'y a pas de raison que ça ne fonctionne pas, j'ai vérifié dans mon php.ini et j'ai exactement la même chose.
        Quel est le message d'erreur affiché ?
        • Partager sur Facebook
        • Partager sur Twitter
          22 octobre 2009 à 14:38:50

          heu non :euh:
          C'est à dire que je n'ai jamais fait de serveur web et donc je ne sais pas redémarrer le module php. Dois je passer par le terminal ?

          Via IIS je redémarre le serveur web mais je ne sais pas si cela redémarre php aussi?
          • Partager sur Facebook
          • Partager sur Twitter
            22 octobre 2009 à 15:01:46

            Personnellement j'utilise Apache, mais à priori ça fonctionne plus ou moins pareil je suppose, IIS doit charger PHP comme module.
            Donc en redémarrant IIS, normalement le php.ini modifié devrait être pris en compte...
            • Partager sur Facebook
            • Partager sur Twitter
              22 octobre 2009 à 15:04:12

              Bon ba alors j'ai un soucis: voilà mon message d'erreur avec phpinfo:

              "PHP Warning: phpinfo () : it is not safe to reply on the system's timezone settings.... "

              J'ai essayé en mettant la fonction date.timezone dans le fichier phpinfo et cela marche très bien mais dès que je reviens au phpinfo basique en une seule ligne, cela me remet le message d'erreur :/

              Edit: voila le code que j'avais trouvé et qui donc marchait correctement
              <?php
              if(date_default_timezone_set('Europe/Stockholm') == 0) {
                          print "<!-- Error uknown timezone using UTC as default -->\n";
                          date_default_timezone_set('UTC');
              }
              phpinfo();
              ?>
              

              • Partager sur Facebook
              • Partager sur Twitter
                22 octobre 2009 à 15:14:00

                Honnêtement je ne vois pas trop, j'ai essayé et ça me donne le même message d'erreur mais quand je laisse le champ vide (j'ai essayé avec les quotes et ça marche aussi en fait...)

                Citation : batou72

                J'ai essayé en mettant la fonction date.timezone dans le fichier phpinfo et cela marche très bien mais dès que je reviens au phpinfo basique en une seule ligne, cela me remet le message d'erreur :/


                Qu'entends-tu par "mettre la fonction date.timezone dans le phpinfo" et "phpinfo basique en une seule ligne" ?
                • Partager sur Facebook
                • Partager sur Twitter
                  22 octobre 2009 à 15:16:21

                  Citation : 999888

                  Honnêtement je ne vois pas trop, j'ai essayé et ça me donne le même message d'erreur mais quand je laisse le champ vide (j'ai essayé avec les quotes et ça marche aussi en fait...)

                  Citation : batou72

                  J'ai essayé en mettant la fonction date.timezone dans le fichier phpinfo et cela marche très bien mais dès que je reviens au phpinfo basique en une seule ligne, cela me remet le message d'erreur :/


                  Qu'entends-tu par "mettre la fonction date.timezone dans le phpinfo" et "phpinfo basique en une seule ligne" ?



                  Oui désolé je me suis mal exprimé. En résumé avec ce code ça marche:
                  <?php
                  if(date_default_timezone_set('Europe/Stockholm') == 0) {
                              print "<!-- Error uknown timezone using UTC as default -->\n";
                              date_default_timezone_set('UTC');
                  }
                  phpinfo();
                  ?>
                  


                  Mais avec celui là, ça ne marche pas:
                  <?php phpinfo();
                  ?>
                  
                  • Partager sur Facebook
                  • Partager sur Twitter
                    22 octobre 2009 à 15:27:44

                    Ok...
                    On va faire un test voir si le php.ini modifié est bien pris en compte.
                    Regarde la valeur de la ligne asp_tags et insère dans ton fichier la ligne <% echo 'salut'; %>.
                    Si elle est sur On, normalement ça devrait t'afficher salut. Si elle est sur Off ça va t'afficher <% echo 'salut'; %>.
                    Une fois que tu as fait le test, change le On en Off (ou inversement) puis redémarre le serveur. Si l'affichage a changé, le php.ini est bien pris en compte, sinon il va falloir trouver comment faire :p
                    • Partager sur Facebook
                    • Partager sur Twitter
                      22 octobre 2009 à 15:33:09

                      Alors quand c'est off, cela m'affiche le code. Et quand c'est on, cela m'affiche salut.
                      Donc apparemment c'est pas me fichier php.ini
                      • Partager sur Facebook
                      • Partager sur Twitter
                        22 octobre 2009 à 15:36:17

                        C'est vraiment louche tout ça...
                        Tu peux faire un copié-collé des quelques lignes avant et après le date.timezone de ton php.ini ?
                        • Partager sur Facebook
                        • Partager sur Twitter
                          22 octobre 2009 à 15:39:13

                          D'accord, voilà:
                          [Date]
                          ; Defines the default timezone used by the date functions
                          ; http://php.net/date.timezone
                          ;date.timezone = Europe/Paris
                          
                          ; http://php.net/date.default-latitude
                          ;date.default_latitude = 31.7667
                          
                          ; http://php.net/date.default-longitude
                          ;date.default_longitude = 35.2333
                          
                          ; http://php.net/date.sunrise-zenith
                          ;date.sunrise_zenith = 90.583333
                          
                          ; http://php.net/date.sunset-zenith
                          ;date.sunset_zenith = 90.583333
                          
                          [filter]
                          ; http://php.net/filter.default
                          ;filter.default = unsafe_raw
                          
                          ; http://php.net/filter.default-flags
                          ;filter.default_flags =
                          
                          [iconv]
                          ;iconv.input_encoding = ISO-8859-1
                          ;iconv.internal_encoding = ISO-8859-1
                          ;iconv.output_encoding = ISO-8859-1
                          
                          [intl]
                          ;intl.default_locale =


                          En tout cas merci pour ton aide 999888
                          • Partager sur Facebook
                          • Partager sur Twitter
                            22 octobre 2009 à 15:41:46

                            Rassure moi, le ; tu l'as enlevé dans ton fichier ? :p
                            • Partager sur Facebook
                            • Partager sur Twitter
                              22 octobre 2009 à 15:45:02

                              euh non pourquoi ?
                              Il est devant toutes les lignes, ce n'est pas normal ?
                              • Partager sur Facebook
                              • Partager sur Twitter
                                22 octobre 2009 à 15:45:51

                                Non, ça signifie que la ligne est en commentaires :D
                                • Partager sur Facebook
                                • Partager sur Twitter
                                  22 octobre 2009 à 15:47:23

                                  Ba pourquoi ils nous font installer un fichier php.ini avec des lignes que en commentaires ?
                                  Devant asp_tags aussi il y a un ; erreur il n'y en a pas :/
                                  Ca marche, merci beaucoup 999888 :D

                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                    14 mai 2014 à 1:41:59

                                    @999888 : Merciiiiiiii :D j'ai le même problème et maintenant tout résolu !
                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                      11 juin 2014 à 15:05:44

                                      Bjr A vous tous?

                                      Voici le message que j'ai dans wampserver2.2 dans php.ini() JE TRAVAIL SUR SPIP

                                      DANS TIME DATE:

                                      ---------------------------------------------------------
                                      Warning: phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in C:\wamp\www\index.php on line 219

                                      ------------------------------------------------
                                      Et quand je vais sur me sites ;
                                      projets spip cela m' affiche en haut des pages de garde home pages de tous les sites le meme exactement message et je ne peux plus aller dans l espace privé en tapant mes MP :

                                      ____________________________________________
                                      Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in C:\wamp\www\spip-v3.0.5\ecrire\inc\log.php on line 62

                                      ________________________________________


                                      Voici la partie de php.ini que j'ai changé , comme ci - dessous svp :

                                      Cela ne marche pas, est ce qu'il faut faire quelque chose d'autre.

                                      Où j'ai mal fait !? Pas touché à httpd.conf ni Apache

                                      pho.ini dans wamp 2.2

                                      <-------------------------------------->

                                      http://php.net/date.timezone
                                      date.timezone = Europe/Paris

                                      http://php.net/date.default-latitude
                                      date.default_latitude = 31.7667

                                      http://php.net/date.default-longitude
                                      date.default_longitude = 35.2333

                                      http://php.net/date.sunrise-zenith
                                      date.sunrise_zenith = 90.583333

                                      http://php.net/date.sunset-zenith
                                      date.sunset_zenith = 90.583333

                                      <----------------------------------->

                                      J'ai arrêté wamp j'ai fait restartalservices, redémarre

                                      ET 3 FOIS HELAS J' AI TOUJOURS LE MEME MESSAGE D' ERREUR ci dessus

                                      QUE FAUT T IL FAIRE SVP c'est pour mon travail

                                      M Firouz





                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        2 mai 2015 à 23:38:52

                                        php.ini.......

                                        editer php.ini

                                        php.ini

                                        1. <tt>cd /etc</tt>
                                        2. <tt>sudo cp php.ini.default php.ini</tt>
                                        3. <tt>sudo chmod ug+w php.ini</tt>
                                        4. <tt>sudo chgrp staff php.ini</tt>
                                        5. Editer <tt>php.ini</tt> 
                                          date.timezone = "Europe/London"
                                          error_reporting  =  E_ALL
                                          display_errors = On
                                          html_errors = On
                                          extension_dir = "/usr/lib/php/extensions/no-debug-non-zts-20100525"
                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          29 juillet 2015 à 18:56:27

                                          php -i | grep "Loaded Configuration File" doit vous donner le chemin du fichier.

                                          dans mon cas c'était /etc/php5/cli/php.ini

                                          avant :

                                          php -i | grep date.timezone
                                          PHP Warning: Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in Unknown on line 0

                                          date.timezone => no value => no value 

                                          après:

                                          php -i | grep date.timezone
                                          date.timezone => Europe/Paris => Europe/Paris

                                          • Partager sur Facebook
                                          • Partager sur Twitter

                                          PHP 5.3 et date.timezone

                                          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                          × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                          • Editeur
                                          • Markdown