Partage
  • Partager sur Facebook
  • Partager sur Twitter

Problème avec Symfony

    15 septembre 2021 à 9:44:29

    Bonjour,

    J'essaye depuis quelques jours d'installer Symfony sur mon ordinateur. Je rencontre un gros problème que je n'arrive pas à résoudre, c'est que le serveur ne fonctionne pas une fois lancé. C'est à dire que le serveur est rechercher indéfiniment sans rien trouver. Je n'ai ni message d'erreur sur la page qui continue perpétuellement de se charger.

    Comme le montre l'image ci-dessous, voici ce que m'affiche le terminal. Malheureusement, je n'arrive pas à comprendre le réel problème.

    Si l'un d'entre vous saurez résoudre ou a déjà rencontrer ce problème, je suis preneur pour élucider ce dernier.

    Merci à vous

    • Partager sur Facebook
    • Partager sur Twitter
      15 septembre 2021 à 11:15:19

      Les messages d'erreurs indiquent que tu essaies d'accéder à des routes qui n'existent pas.

      Si tu essaie d'aller sur http://127.0.0.1:8000/home , ça devrait fonctionner puisque on peut voir dans le terminal qu'il a trouver une route nommer "home".

      Tu peux aussi faire un php bin/console debug:router pour voir les routes existantes sur ton projet.

      • Partager sur Facebook
      • Partager sur Twitter
        15 septembre 2021 à 11:38:39

        MathiasMicheli a écrit:

        Les messages d'erreurs indiquent que tu essaies d'accéder à des routes qui n'existent pas.

        Si tu essaie d'aller sur http://127.0.0.1:8000/home , ça devrait fonctionner puisque on peut voir dans le terminal qu'il a trouver une route nommer "home".

        Tu peux aussi faire un php bin/console debug:router pour voir les routes existantes sur ton projet.


        J'ai oublié de préciser que cela me fait pareil quand j'accède à cette route. J'ai un chargement en cours qui dure indéfiniment. Le terminal ne m'indique pas de message d'erreur.

        Voici les routes existantes sur mon serveur.

        • Partager sur Facebook
        • Partager sur Twitter
          15 septembre 2021 à 11:41:52

          Salut

          Apparemment, tu as installé une pile serveur (XAMPP) que tu tentes d'utiliser, mais en plus tu as démarré un serveur PHP embarqué, et tu mélanges les méthodes d'accès des deux. Arrête de lancer le serveur depuis la ligne de commandes si tu fais fonctionner XAMPP.

          P.S. : des images pour lire du texte, c'est comme des partitions de musique pour écouter quelque chose : c'est pas pratique. Pourquoi ne pas copier le texte de la console et le coller (quitte à le mettre sous forme de code pour conserver les tableaux), plutôt que de prendre une capture d'écran et l'envoyer ? Quand tu envoies des messages WhatsApp ou des SMS, tu les écris à la main et tu les prends en photo ?

          -
          Edité par Ymox 15 septembre 2021 à 11:42:54

          • Partager sur Facebook
          • Partager sur Twitter
            15 septembre 2021 à 22:40:07

            Bonjour,

            Mauvais titre

            Le titre est un élément important qui ne doit pas être négligé. N'oubliez pas cette règle simple : le titre idéal résume la question que vous allez poser en une petite phrase. Il doit permettre aux visiteurs de se repérer facilement dans le forum visité et d'identifier le sujet à sa seule lecture.

            Vous pouvez utiliser divers préfixes comme [Erreur], [MySQL], [Compatibilité], etc... Aussi, pensez à consulter les règles propres à chaque forum (visibles dans les topics épinglés en haut des sections).

            De plus, choisir un bon titre permet de rendre plus faciles les recherches des autres membres.

            Les titres de type "besoin d'aide" ou "problème" ne sont pas tolérés.

            Merci de modifier votre titre. Pour cela, éditez le premier message de votre sujet.

            (titre originel : Problème avec Symfony)

            • Partager sur Facebook
            • Partager sur Twitter

            Pas d'aide concernant le code par MP, le forum est là pour ça :) (en plus je n'y connais rien en C)

            Problème avec Symfony

            × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
            • Editeur
            • Markdown