Partage
  • Partager sur Facebook
  • Partager sur Twitter

Probleme de balise Block

Je ne comprends vraiment pas...

Sujet résolu
2 janvier 2006 à 1:47:36

Bonjour/soir. :ninja:

J'ai un probleme plutot génant sur mon site, composé de 3 <p> avec des float left, pour former un equivalent de tableau à 3 collones.
Seulement, voilà mon probleme :

<div class='news'>
Tout un tas de texte là
<form>
Un formulaire ici
</form>
Encore du texte
</div>

Et le css qui va avec :

.news{
        border:5px #274C01 ridge;
        background:url("bgnews.jpg");
        color:white;
}

Rien de plus basique.
Seulement, lorsque la balise <form> s'ouvre (ou n'importe quelle autre balise block : <h1>, <ul>...) on dirait que le <div> se ferme o_O , plus de texte en blanc, plus de fond, plus de bordure, et ca ne reprends pas à la fermeture du <form>

Je ne comprends absolument pas d'où vient ce probleme. :o
Quelqu'un a t'il la solution ?

Merci.
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 2:36:14

On peut avoir unscreenshoot de ce que sa fait stp ?
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 2:44:54

Voilà, donc, ici, c'est un <form> qui pose problème.

:(

Image utilisateur

Voilà... j'ai surligné le texte sinon il est en noir ^^

EDIT : Bah, c'est plus clair comme ça ^^ ?
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 2:49:53

Je comprend ton problème sur le text, mais pas sur ton screenshoot....
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 2:59:20

Je n'aime pas poster pour ne rien dire, mais j'ai edité le message précédent et mis de nouvelles infos sur la capture ^^
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 3:30:12

euh... essai avec un repeat x sur ton background...
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 3:38:15

Bonsoir,

essaye en metant ton texte dans des balise <p>
<div class='news'>
<p>Tout un tas de texte là</p>
<form>
Un formulaire ici
</form>
<p>Encore du texte</p>
</div>
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 13:39:35

Rien de mieux avec les <p> :(
Le repeat-x ne change rien à part qu'il pete encore plus mon design :p

Ce n'est quand même pas normal...
Peut être une histoire de float, je vous donne la structure du site :

<div class='menugauche'>
<!--Menu 1-->
<img src='mh.gif' alt=''>
<p class='menuM'><br />
...Menu
</p>
<img src='mb.gif' alt=''><br /><br />
<!--Menu 2-->
<img src='mh.gif' alt=''>
<div class='menuM'>
</div>
<img src='mb.gif' alt=''>
</div>
<div class='centre'>
...Include de diverses pages
</div>
<div class='parts'>
<img src='mh.gif' alt=''>
<p class='menuM'><br />Partenaires<br />
</p>
<img src='mb.gif' alt=''>
</div>


Et le css qui va avec :

.menugauche{
        width:200px;
        float:left;
}
.parts{
        margin-left:5%;
        width:200px;
        float:left;
}
.centre{
        width:49%;
        float:left;
        margin-left:5%;
}
.menuM{
        background:url("mm.gif") repeat-y top left;
        margin-top:-20px;
        margin-bottom:0px;
        width:200px;
        text-align:center;
}
.news{
        border:5px #274C01 ridge;
        background:url("bgnews.jpg");
        color:white;
}
  • Partager sur Facebook
  • Partager sur Twitter

Probleme de balise Block

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown