Partage
  • Partager sur Facebook
  • Partager sur Twitter

Problème de configuration apache ?

Connexion directe à un site web sur un serveur sans accès internet

Anonyme
    27 novembre 2014 à 15:09:16

    Bonjour,

    J'ai un simple cas de problème de configuration, mais je ne suis pas sûr que cela vienne de mon fichier httpd.conf. 

    Je voudrais accéder à un site web sur un serveur B depuis un serveur A qui sont normalement connectés par le port 3128. Je peux accéder au site depuis le serveur B en tapant localhost dans mon navigateur. Cependant, j'obtient une erreur ("le serveur a mis trop de temps sans donner de réponse") depuis le A ou le B si je tape l'adresse IP du server B (XXX.XXX.XX.XXB ou XXX.XXX.XX.XXB:3128). Voici une partie du fichier httpd.conf:

    Listen 80
    Listen 3128
    
    ServerName XXX.XXX.XX.XXB
    DocumentRoot C:/wamp/www/Symfony/web
    
    NameVirtualHost XXX.XXX.XX.XXB:3128
    
    <VirtualHost XXX.XXX.XX.XXB>
       DocumentRoot C:/wamp/www/Symfony/web
       ServerName XXX.XXX.XX.XXB
    </VirtualHost>
    
    NameVirtualHost localhost
    
    <VirtualHost localhost>
       DocumentRoot C:/wamp/www/Symfony/web
       ServerName localhost
    </VirtualHost>

        Avez-vous une idée d'où peut venir l'erreur ? L'accès direct depuis B au site web via son IP devrait-il fonctionner même si B n'est pas relié à internet ?  (quand je ping sa passerelle par défaut, celle-ci n'est pas accessible)

    • Partager sur Facebook
    • Partager sur Twitter
      29 novembre 2014 à 15:33:15

      Tu peux essayer aussi de taper l'adresse ip de ta machine suivit de ":3128"

      Ce qui revient à faire que lorsque tu taperas l'adresse ip dans ton navigateur : xxx.xxx.xxx.xxx:3128

      Il se connectera à l'adresse ip par le port 3128.

      As-tu aussi vérifié que ton port 3128 était ouvert ?

      • Partager sur Facebook
      • Partager sur Twitter
      Les maths ? Il n'y a que ça de vrai.
      Anonyme
        3 décembre 2014 à 10:40:18

        Bonjour,

        Oui, c'est ce que j'écris plus haut: j'ai essayé avec et sans indication du port. Mais le temps d'attente de réponse du serveur atteint le timeout. Par contre si j'utilise un autre port que le 3128, j'ai une erreur directement. D'ailleurs, concernant l'ouverture du port, j'ai vérifé grace à un netstat. Le port est en attente.

        Cela devrait fonctionner si la config était bonne non ? Enfin je veux dire que le fait que le server B ne soit pas connecté à internet ne change rien au fait qu'il devrait être capable de se connecté à lui même via le port 3128 ?

        Merci de ta réponse en tout cas.

        -
        Edité par Anonyme 3 décembre 2014 à 14:38:38

        • Partager sur Facebook
        • Partager sur Twitter
        Anonyme
          3 décembre 2014 à 12:19:57

          J'ai essayé d'autres configurations. Voila mon fichier https.conf: 

          Listen 3128
           
          ServerName serverB
          DocumentRoot C:/wamp/www/Symfony/web
           
          NameVirtualHost serverB:3128
           
          <VirtualHost serverB>
             DocumentRoot C:/wamp/www/Symfony/web
             ServerName serverB
          </VirtualHost>
           
          NameVirtualHost localhost:3128
           
          <VirtualHost localhost:3128>
             DocumentRoot C:/wamp/www/Symfony/web
             ServerName localhost
          </VirtualHost>
          
          NameVirtualHost dev:3128
           
          <VirtualHost dev:3128>
             DocumentRoot C:/wamp/www/Symfony/web
             ServerName dev
          </VirtualHost>

          Et voici mon fichier Host: 

          127.0.0.1       localhost
          127.0.0.1       dev
          XXX.XXX.XX.XXB  serverB

          Je ne peux que me connecter à localhost:3128. Si j'essaie dev:3128 ou XXX.XXX.XX.XXB:3128 je n'ai pas de réponse. 



          -
          Edité par Anonyme 3 décembre 2014 à 13:33:29

          • Partager sur Facebook
          • Partager sur Twitter
            3 décembre 2014 à 19:29:25

            avec l'adresse 192.168... :3128 ?
            • Partager sur Facebook
            • Partager sur Twitter
            Un jour les Valaisans domineront le monde. Mais pas demain, ya apéro
              3 décembre 2014 à 19:46:38

              Tu as peut être un problème de filtrage au niveau de ton routeur. Ton message de A vers B passe car il n'est pas filtré, mais dans l'autre sens si. D'où le problème de temps de réponse. Lance un wireshark sur tes deux machines, et voit ce qu'il se passe des deux cotés
              • Partager sur Facebook
              • Partager sur Twitter
                4 décembre 2014 à 15:14:19

                Utilise Portmapper, tu as quoi comme passerelle ? Fin plutôt quel opérateur as-tu ? Car l'interface NAT d'SFR n'est pas tip-top comparé à Orange..

                Portmapper ouvre les ports sans passer la passerelle. C'est un petit logiciel vraiment sympa, tu le trouveras sur internet ;-)

                • Partager sur Facebook
                • Partager sur Twitter
                Les maths ? Il n'y a que ça de vrai.
                Anonyme
                  5 décembre 2014 à 14:10:08

                  Salut !

                  Je vais jeter un oeil à Portmapper.

                  En fait c'est sur un réseau de servers privés, distribué par ma faculté. J'ai deux adresses IP et deux ordinateurs virtuels qui tournent sur windows server 2008. Je n'ai pas la main sur la config complète (ce qui est le plus frustrant puisqu'il faut compter un mois lorsque l'on émet une simple requête). Bref, ma question du coup est relativement simple:

                  À supposer que la config physique du réseau soit la bonne, est-ce que avec ma config des fichiers httpd.conf et host l'accès de mon site sur B depuis A devrait être possible, en tapant XXX.XXX.XX.XXB:3128 dans le navigateur ? 

                  Merci de vos réponses en tout cas. 

                  • Partager sur Facebook
                  • Partager sur Twitter
                    8 décembre 2014 à 7:51:18

                    J'ai un peu le même problème la ou je suis à cause de mon Université.

                    Tu arrives à accéder à ton site en localhost, car ton pc en voyant la requête localhost ne prends pas la peine de la relayer au routeur. Il connait déjà cette adresse et donc s'occupe tout seul comme un grand de la gestion. C'est pourquoi tu y accède.

                    Maintenant, le réseau universitaire. L'adresse que ton serveur obtient est distribué par ton université. Ainsi, pour que ton ordinateur puisse contacter ton serveur, il doit passer par ton routeur, car c'est une adresse qu'il ne connait pas. Si, et c'est surement le cas, le routeur filtre le port que tu utilise, alors tu ne pourras jamais contacter ton serveur.

                    Les seuls solutions qu'ils te restent, c'est de trouver un port ouvert ou d'ouvrir un ticket à ton université, pour qu'ils te disent si c'est possible et comment procéder.

                    • Partager sur Facebook
                    • Partager sur Twitter
                    Anonyme
                      9 décembre 2014 à 13:23:05

                      Bonjour Unisa35,

                      C'est donc forcément un problème de configuration du réseau. J'ai ouvert un ticket auprès de mon université et voici ce qu'il m'ont répondu (après un mois):

                      - Les deux serveurs se trouvent sur le même VLAN et ont donc une liaison directe. Les deux ordinateurs ont une adresse IP publiques et donc une connexion à internet. (ce qui est déjà étrange puisque le server B ne peut pas pinguer sa passerelle)

                      - Une activation du pare-feu doit être approuvé par les administrateurs réseau. (normalement, les ports sont bien configurés, à part sur le serveur A qui devrait aussi avoir le 443 pour SLL coté internet, mais je m'occuperai de ca plus tard)

                      Donc mon problème principal est représenté par l'impossibilté du serveur B à acceder à sa passerelle. Si je débloque ca, tout devrait rouler.

                      • Partager sur Facebook
                      • Partager sur Twitter
                      Anonyme
                        9 décembre 2014 à 16:18:18

                        Ah et au fait, je peux pinger le server B depuis B. Est-ce normal ?

                        En fait une chose dont je ne suis pas sûr c'est lorsque je tape sur mon navigateur depuis le server B sa propre adresse IP, est-ce qu'il va le chercher à travers le routeur ou est-ce qu'il connait déjà sa propre IP ? Est-ce le même fonctionnement avec le PING ?

                        • Partager sur Facebook
                        • Partager sur Twitter
                          10 décembre 2014 à 16:29:09

                          Il va taper sa propre adresse IP, donc c'est comme si il ping 127.0.0.1.

                          Donc forcément il connait son adresse vu que c'est le localhost ^^

                          C'est peut-être un problème de règle.. Vérifier si le serveur ne bloque pas les connexions entrantes ?

                          • Partager sur Facebook
                          • Partager sur Twitter
                          Les maths ? Il n'y a que ça de vrai.
                            10 décembre 2014 à 20:32:57

                            Le serveur B est une VM de ton serveur A?
                            • Partager sur Facebook
                            • Partager sur Twitter
                            Anonyme
                              17 décembre 2014 à 17:04:48

                              Unisa35 a écrit:

                              Le serveur B est une VM de ton serveur A?

                              Non les deux serveurs sont deux VM différentes... Je ne sais pas si elles sont sur les mêmes machines mais ca n'importe peu.

                              géogéo a écrit:

                              Il va taper sa propre adresse IP, donc c'est comme si il ping 127.0.0.1.

                              Donc forcément il connait son adresse vu que c'est le localhost ^^

                              C'est peut-être un problème de règle.. Vérifier si le serveur ne bloque pas les connexions entrantes ?


                              Ok c'est bien ce qu'il me semblait. J'ai peu de doute que le serveur bloaue car j'ai levé tous les par-feux et utilisé sensiblement le même fichier httpd.conf que sur un autre serveur qui fonctionne. De plus, l'administrateur réseau m'a conseillé de vérifié la config de la carte réseau sur le serveur B, et elle est exactement la même que sur le serveur A. Enfin il m'a confirmé que les deux serveurs devraient avoir une connexion à Internet. 

                              Je sèche...


                              -
                              Edité par Anonyme 17 décembre 2014 à 17:05:56

                              • Partager sur Facebook
                              • Partager sur Twitter
                                10 janvier 2015 à 21:20:06

                                As-tu vérifié les classes ? Est-ce que les deux serveurs ont la même classe d'adresse ip ? 

                                Sont-ils tous les deux en classe A par exemple ? C'est un problème fréquemment rencontré le type d'adressage IP.

                                • Partager sur Facebook
                                • Partager sur Twitter
                                Les maths ? Il n'y a que ça de vrai.

                                Problème de configuration apache ?

                                × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                • Editeur
                                • Markdown