Partage
  • Partager sur Facebook
  • Partager sur Twitter

Probleme HIGHT/LOW Arduino (Inversé)

Probleme Arduino

Sujet résolu
    28 décembre 2012 à 16:12:25

    Bonjour/bonsoir

    Je viens tout juste de m'acheter une carte Arduino mega. Dans le programme à chaque fois que je met "HIGHT" en valeur, la LED ne s'allume pas, mais quand je met "LOW" elle s'allume o_O

    J'ai la dernière version du logiciel.
    Voici le code que j'ai utilisé :

    int led = 5;
    
    
    void setup() {                
     
      pinMode(led, OUTPUT);     
    }
    
    
    void loop() {
      
      digitalWrite(led, HIGH);   /
                
    }
    


    Quelqu'un pourait m'aider ?

    Merci.
    • Partager sur Facebook
    • Partager sur Twitter
      28 décembre 2012 à 16:53:34

      Le comportement est normal si ta LED est branché en ayant la cathode vers la broche de Arduino.
      • Partager sur Facebook
      • Partager sur Twitter
        28 décembre 2012 à 16:56:25

        Ouf, vous me rassurer : )
        Dans une LED la cathode est du coté de sa sortie ?
        • Partager sur Facebook
        • Partager sur Twitter
          28 décembre 2012 à 17:18:31

          Ca dépend, libre à toi de choisir, mais une explication se trouve ici et dans la partie précédente
          • Partager sur Facebook
          • Partager sur Twitter

          Probleme HIGHT/LOW Arduino (Inversé)

          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
          × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
          • Editeur
          • Markdown