Partage

Problème logo font-awesome

Sujet résolu
12 juin 2018 à 10:12:14

Bonjour à tous , alors voilà j'ai récupéré le CDN sur le site officiel de Font-awesome , j'inclus donc mes icones dans le header. Maintenant le problème , le site fonctionne en localhost mais pas en production , aucune erreur dans la console et pas de code en particulier à montrer si ce n'est le CDN + les icones de Twitter Facebook et Linkedin. Merci de votre aide !!

PS: les icones apparaissent sous forme de carrés en production

Vous êtes demandeur d'emploi ?
Sans diplôme post-bac ?

Devenez Développeur web junior

Je postule
Formation
en ligne
Financée
à 100%
12 juin 2018 à 10:15:07

Bonjour,

Impossible de te répondre sans voir ton code ou, mieux encore, ta page en ligne.

Recherche l'avis de développeurs front : Devenir un meilleur dev front ?
12 juin 2018 à 10:22:13

Mewen_bzh a écrit:

Bonjour,

Impossible de te répondre sans voir ton code ou, mieux encore, ta page en ligne.


Bonjour , désolé te donne mon site , mais rien de particulier dans le code je pense ! (pas d'erreurs selon moi)

https://matheozeller.fr/

Staff 12 juin 2018 à 10:27:34

Bonjour,

tu utilises la version 5 de FontAwesome sur ton site : la syntaxe a un peu changé. Relis https://fontawesome.com/how-to-use/svg-with-js#basic-use (surtout la partie "Styles & Prefixes").

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
12 juin 2018 à 10:32:47

Lamecarlate a écrit:

Bonjour,

tu utilises la version 5 de FontAwesome sur ton site : la syntaxe a un peu changé. Relis https://fontawesome.com/how-to-use/svg-with-js#basic-use (surtout la partie "Styles & Prefixes").

Bonjour je comprend qu'il manque des choses apparemment , mais comment expliquez-vous que cela fonctionne en localhost?? 

Staff 12 juin 2018 à 11:15:49

Le lien vers le CDN était exactement le même en local ?
Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
12 juin 2018 à 11:21:04

Lamecarlate a écrit:

Le lien vers le CDN était exactement le même en local ?

Exactement oui, puisque la page en prod est ma page en local que j'ai push :S

12 juin 2018 à 13:17:25

J'ai récemment ce problème aussi, que les icones viennent de fontawesome, icomoon, fontello, ou autre ; au premier chargement, les icones ne sont pas chargées (carré blanc), mais aucune erreur de chargement à déplorer. En revanche, elles apparaissent dès le soft refresh du navigateur. Je n'ai toujours pas trouvé d'origine.
Il n'y a pas de mauvais navigateur, il n'y a que du mauvais code !
12 juin 2018 à 14:13:34

Edit : le problème venait du client FTP qui ne récupérait pas mon fichier local !
Staff 12 juin 2018 à 14:22:18

Le fichier local ? Quel fichier local ?
Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
13 juin 2018 à 14:15:18

Lamecarlate a écrit:

Le fichier local ? Quel fichier local ?

Ben le fichier ou je code pour tester avant d'envoyer en prod ! ^^

Staff 13 juin 2018 à 14:17:37

Ah, je pensais que tu parlais du fichier css de FontAwesome que tu aurais mis en local en plus du CDN - et je prenais peur :p
Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
14 juin 2018 à 12:46:26

Lamecarlate a écrit:

Ah, je pensais que tu parlais du fichier css de FontAwesome que tu aurais mis en local en plus du CDN - et je prenais peur :p


Non c'est stupide de faire ca ! En tout cas problème résolu merci de votre aide
14 juin 2018 à 14:13:52

Non en fait c'est loin d'être stupide. 

Cela permet d'avoir un fallback pour le moment où le site de Font-Awesome tombe en rade. Cela évite d'avoir des icônes qui ne s'affichent plus sur ton site.

Cela arrive relativement rarement mais c'est déjà arrivé par le passé, c'est l'inconvénient de se reposer sur des services externes. Et cela évite de devoir expliquer à un client mécontent pourquoi son site ne s'affiche plus correctement et que l'on ne peut rien faire d'autre qu'attendre.

Recherche l'avis de développeurs front : Devenir un meilleur dev front ?
14 juin 2018 à 16:05:56

Mmmh oui, sauf que les deux seront chargés, et que suivant le CDN, la version pourrait différer de celle en local (exemple si on charge jquery-latest.js). Du coup, je recommande plutôt d'avoir toujours les dépendances en local, et jamais sur un CDN. :)
Il n'y a pas de mauvais navigateur, il n'y a que du mauvais code !
15 juin 2018 à 10:32:07

rhooManu a écrit:

Mmmh oui, sauf que les deux seront chargés, et que suivant le CDN, la version pourrait différer de celle en local (exemple si on charge jquery-latest.js). Du coup, je recommande plutôt d'avoir toujours les dépendances en local, et jamais sur un CDN. :)


Oui enfin question rapidité pour un simple exo , je vais pas m'embêter à DL du local ... ^^

Problème logo font-awesome

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown