Partage
  • Partager sur Facebook
  • Partager sur Twitter

Problème réseau - VPN et réseau local

Sujet résolu
    16 juillet 2021 à 18:16:11

    Bonjour à tous,

    Je me trottine la tête depuis 2/3 jours et à force de pratiquer, j'en suis venu à être perdu ... :euh: Je vous explique mon problème.

    Equipements :

    • Serveur OpenVPN sur PC > Ubuntu 20.04
    • Routeur Mikrotik pour la création d'un sous réseau*
    • Box Internet
    • Client OpenVPN sur PC distant > Windows 10
    ------------------------------------------------------------------------------------------------------------------------

    Donc la connexion entre Client OpenVPN (PC distant) <-> Serveur OpenVPN : OK

    ------------------------------------------------------------------------------------------------------------------------

    Création d'un sous réseau grâce à mon routeur c'est à dire :
    • Réseau 1 : 192.168.1.0/24
    • Réseau 2 : 192.168.2.0/24

    Suite à cela, mon serveur OpenVPN obtient par le biais d'un DHCP Server configuré dans le Mikrotik l'@IP 192.168.2.3

    Un autre PC lambda reçoit également l'@IP 192.168.2.4

    *J'ai dû créer un sous réseau car le réseau où est situé mon PC distant (192.168.1.0/24) = réseau de chez moi (192.168.1.0/24)
    ----------------------------------------------------------------------------------------------------------------------


    Depuis mon routeur Mikrotik, via un terminal :

    • ping 192.168.2.3 et 192.168.2.4 : OK (j'ai envie de dire logique car les 2 machines sont connectées au routeur) :D

    Depuis mon serveur OpenVPN :

    • ping 192.168.2.4 et 192.168.1.x : OK

    Depuis ma machine distante : 

    • ping 192.168.2.3 : OK
    • ping 192.168.2.4 : KO

    Etant donné que la connexion est établie entre le client OpenVPN (PC distant) <-> serveur OpenVPN alors le ping de l'@IP du serveur OpenVPN est fonctionnel depuis le PC distant mais non fonctionnel pour les autres équipements de mon sous réseau ... J'aimerais pouvoir ping/accéder à l'ensemble de mes équipements dans le sous réseau que j'ai créé chez moi en 192.168.2.x.


    S'agit-il d'un problème de routage ? J'ai creusé et fais des tentatives en vain ...


    Aidez moi s'il vous plait :( en vous remerciant par avance.

    -
    Edité par diegoteix7 16 juillet 2021 à 18:18:21

    • Partager sur Facebook
    • Partager sur Twitter
      17 juillet 2021 à 22:06:53

      Hello, je ne suis pas sûr de ton setup, mais c'est peut être juste le forwarding de ton serveur OpenVPN qui n'est pas activé ?

      Ton client distant a-t'il bien une interface (virtuelle) avec une adresse en 192.168.2.x ?

      Edit: s'il a bien un adresse en 192.168.2.x, peux-tu vérifier s'il a obtenu la route vers 192.168.2.x via cette interface ? Sinon il faut configurer OpenVPN pour qu'il push cette route ;)

      -
      Edité par FantasMaths 17 juillet 2021 à 22:08:45

      • Partager sur Facebook
      • Partager sur Twitter
        18 juillet 2021 à 9:02:57

        Hello FantasMatsh,

        Tout d'abord, je te remercie pour ta réponse et ton aide. J'ai quelques notions en réseau mais je suis encore loin d'être un expert ...

        mais c'est peut être juste le forwarding de ton serveur OpenVPN qui n'est pas activé ?

        Comment puis-je vérifier ceci ? o_O

        Ton client distant a-t'il bien une interface (virtuelle) avec une adresse en 192.168.2.x ?

        Non, mon client distant possède bien une interface virtuelle mais en 10.25.0.x (réseau VPN), cette @IP lui a été fournit par le serveur OpenVPN

        peux-tu vérifier s'il a obtenu la route vers 192.168.2.x via cette interface ?

        Voici le résultat : 




        En vous remerciant pour votre aide ! :honte:

        • Partager sur Facebook
        • Partager sur Twitter
          18 juillet 2021 à 10:57:32

          Bonjour,

          diegoteix7 a écrit:

          mais c'est peut être juste le forwarding de ton serveur OpenVPN qui n'est pas activé ?

          Comment puis-je vérifier ceci ? o_O

          Sur le serveur, vérifie la configuration de netfilter avec iptables:

          iptables -nvL # filter
          iptables -t nat -nvL # nat
          
          

          ou si tu utilises ufw (qui me semble être le front-end de netfilter par défaut sur cette distrib):

          ufw status verbose

           Et vérifie que le routage est activé (valeur 1):

          cat /proc/sys/net/ipv4/ip_forward

          Pour activer le routage:

          echo 1 > /proc/sys/net/ipv4/ip_forward

          Pour configurer le pare-feu, ça dépend de comment sont fait les choses. Mais une configuration de ce type (ci-dessous) devrait fonctionner:

          Disons que l'interface avec l'adresse 192.168.2.3 se nomme eth2 et que celle du tunnel se nomme tun0:

          # Politique de DROP par défaut
          iptables -P FORWARD DROP
          # Autorise le routage de ce qui vient de tun0 et qui va vers eth2 (en fonction de la table de routage du serveur)
          iptables -A FORWARD -i tun0 -o eth2 -j ACCEPT
          # Autorise le routage de ce qui vient de eth2 et qui va vers tun0
          iptables -A FORWARD -i eth2 -o tun0 -j ACCEPT
          # Fait de la NAT pour tout le trafic ayant pour source 10.25.0.0/24 et qui sort par eth2 (car les clients routeront sinon leur trafic de réponse vers la passerelle par défaut indiquée dans les options DHCP fournie par le routeur Mikrotik fort probablement)
          iptables -t nat -A POSTROUTING -s 10.25.0.0/25 -o eth2 -j MASQUERADE

          Cette configuration n'est que temporaire et sera réinitialisé au prochain redémarrage. Je te laisse chercher comment la rendre persistante.

          Si tu utilises ufw, ça doit être plus simple (mais je connais po ^^ ).

          Rien à voir avec ta demande et ce n'est pas gênant mais tu as des routes un peu étranges comme 10.25.0.4/30 on-link... Et globalement toutes les routes en 10.25.0.x/32 on-link n'ont aucun intérêt vu que tu as 10.25.0.0/24 on-link. Ça vient de la conf du VPN?



          -
          Edité par KoaTao 18 juillet 2021 à 10:58:11

          • Partager sur Facebook
          • Partager sur Twitter
            18 juillet 2021 à 10:59:32

            Hello,

            Désolé je n'ai pas pensé à mettre les commandes :( pour le forwarding tu as un tuto là : https://www.networkinghowtos.com/howto/enable-ip-forwarding-on-ubuntu-13-04/

            Le souci potentiel que tu as, si ce n'est pas le forwarding, c'est le routage des paquets dans le sens retour : les ordinateurs sur ton réseau local ne savent pas forcément à qui envoyer les paquets à destination de 10.25/16. Peux tu afficher la table de routage d'un pc sur ce réseau ? Autrement, tu peux ping une machine depuis ta machine distante et voir avec Wireshark si tu observes des paquets arriver.


            Édit : tu pourras sûrement régler la route sur ton routeur Microtik (tu routes 10.25/16 vers ton serveur openvpn)

            Édit : Grilled :D

            -
            Edité par FantasMaths 18 juillet 2021 à 11:03:12

            • Partager sur Facebook
            • Partager sur Twitter
              18 juillet 2021 à 16:16:50

              Hello les experts, :magicien:

              Merci encore de creuser avec moi au sujet de mon problème.;)

              Donc concernant le forwarding, je vous confirme que : net.ipv4.ip_forward = 1


              Voici la table de routage d'une machine connectée à mon réseau local en 192.168.2.0/24 :

              En vous remerciant.

              EDIT : 

              Hello @KoaTao,

              Je te remercie, tu as solutionné mon problème ! You are a Genius :magicien:

              En fait il s'agissait d'un problème firewall du côté du serveur OpenVPN.

              Bravo et merci !

              -
              Edité par diegoteix7 18 juillet 2021 à 16:48:01

              • Partager sur Facebook
              • Partager sur Twitter

              Problème réseau - VPN et réseau local

              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
              × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
              • Editeur
              • Markdown