Partage
  • Partager sur Facebook
  • Partager sur Twitter

[Qt][DLL]Liste des DLL sous Qt 5.0.2

Plus besoin de chercher !

    3 mai 2013 à 22:53:44

    Salut tout le monde !

    Afin d'éviter la création de sujets sur la demande des DLL a utiliser sous la dernière version de Qt, j'ai décidé de toutes les regrouper ici. En effet, avec la transition de Qt 4.8 à Qt 5, beaucoup de monde a été surpris avec le nombre de DLL nécessaire. Également, beaucoup de monde suivant le tutoriel sur ce site se demande ou est le problème : le tutoriel indique que 3 DLL, celle originalement nécessaire sous Qt 4.8. Voici donc la liste des DLL nécessaire :

    • Qt5Core.dll
    • Qt5Gui.dll
    • Qt5Widgets.dll
    • D3DCompiler_43.dll
    • icudt49.dll
    • icuin49.dll
    • icuuc49.dll
    • libEGL.dll
    • libgcc_s_sjlj-1.dll
    • libGLESv2.dll
    • libstdc++-6.dll
    • libwinphthread.dll

    Ceci est le minimum syndical pour une application avec une interface graphique, dans mon cas je n'ai pas pu faire moins. Ensuite, en fonction des fonctionnalités de votre logiciel, il peut se rajouter :

    • Qt5CLucene.dll
    • Qt5Concurrent.dll
    • Qt5Declaratived.dll
    • Qt5Designer.dll
    • Qt5DesignerComponents.dll
    • Qt5Help.dll
    • Qt5Multimedia.dll
    • Qt5MultimediaQuick_p.dll
    • Qt5MultimediaWidgets.dll
    • Qt5Network.dll
    • Qt5OpenGL.dll
    • Qt5PrintSupport.dll
    • Qt5Qml.dll
    • Qt5Quick.dll
    • Qt5QuickParticle.dll
    • Qt5QuickTest.dll
    • Qt5Script.dll
    • Qt5ScriptTools.dll
    • Qt5Sql.dll
    • Qt5Svg.dll
    • Qt5Test.dll
    • Qt5V8.dll
    • Qt5WebKit.dll
    • Qt5WebKitWidgets.dll
    • Qt5Widgets.dll
    • Qt5Xml.dll
    • Qt5XmlPatterns.dll

    A noter que pour chacune de ces DLL ainsi que Qt5Gui.dll, Qt5Core.dll et Qt5Widgets.dll il existe une version 'd' (exemple : Qt5Guid.dll, Qt5Cored.dll).

    Si vous utilisez le designer de Qt, vous devrez y insérer les DLL du designer aussi je pense.

    Toutes les DLL sont facilement trouvable dans :

    ['DossierOuSeTrouveQt']/['Version']/mingw['Version']_['Archi']/bin

    Drôle de chemin, non ? x)

    Pour ceux qui ont des problème ou pour une quelconque raison, j'ai mis une archives en ligne. Elle contient le "minimum syndical" (36 mb) : http://www.mediafire.com/download.php?zk2t7zztrvxdgso

    Lorsque on utilise toute les DLL, on dépasse le 1,4 Gb, donc attention !

    Cordialement,

    En espérant avoir été utile

    -
    Edité par Imote 4 mai 2013 à 20:53:18

    • Partager sur Facebook
    • Partager sur Twitter
    Toi, moi, nous. Nous somme tous les même. Respectons nous.
    Anonyme
      4 mai 2013 à 11:23:44

      Un grand merci a toi

      -
      Edité par Anonyme 4 mai 2013 à 11:24:39

      • Partager sur Facebook
      • Partager sur Twitter
      Anonyme
        4 mai 2013 à 11:26:03

        Salut, comme ce sujet va être utile à pas mal de monde avant la mise à jour du tuto, je le passe en post-it. :)

        • Partager sur Facebook
        • Partager sur Twitter
        Anonyme
          4 mai 2013 à 11:29:22

          J'ai rajouté toute les dlls mais j'ai cette erreur : This application has requested the Runtime to terminate it in a unusual way

          -
          Edité par Anonyme 4 mai 2013 à 11:29:46

          • Partager sur Facebook
          • Partager sur Twitter
            4 mai 2013 à 11:36:12

            c'est logique même avec un programme affiche fenêtre mon  projet à une taille 300Mg e quelque

            -
            Edité par serviceplus 13 mai 2013 à 18:50:59

            • Partager sur Facebook
            • Partager sur Twitter
              4 mai 2013 à 19:18:01

              programme-zero a écrit:

              J'ai rajouté toute les dlls mais j'ai cette erreur : This application has requested the Runtime to terminate it in a unusual way

              -
              Edité par programme-zero il y a environ 7 heures


              Idem, en rajoutant uniquement le minimum syndical (+ les quelques autres qui m'étaient demandées), j'avais cette erreur. J'ai donc pris toutes les DLL comme une brute, et ça marchait. Mais c'est légèrement abusif.
              • Partager sur Facebook
              • Partager sur Twitter
                4 mai 2013 à 20:37:02

                Gloubichou a écrit:

                programme-zero a écrit:

                J'ai rajouté toute les dlls mais j'ai cette erreur : This application has requested the Runtime to terminate it in a unusual way

                -
                Edité par programme-zero il y a environ 7 heures


                Idem, en rajoutant uniquement le minimum syndical (+ les quelques autres qui m'étaient demandées), j'avais cette erreur. J'ai donc pris toutes les DLL comme une brute, et ça marchait. Mais c'est légèrement abusif.


                Tu as utilisé le designer ? Si oui, et si tu les as pas inclus, il est nécéssaire d'inclure les DLL lié au designer je suppose ;)
                • Partager sur Facebook
                • Partager sur Twitter
                Toi, moi, nous. Nous somme tous les même. Respectons nous.
                Anonyme
                  4 mai 2013 à 23:37:36

                  Avec toute les dlls de qt (2 go) J'ai une erreur point d'entré introuvable dans libGLESv2d.dll --'
                  • Partager sur Facebook
                  • Partager sur Twitter
                    6 mai 2013 à 23:12:43

                    Bonjour a tous, même après avoir mis tous les dll cela marche chez moi mes chez mes amis cela marque This application has requested the Runtime to terminate it in a unusual way .  

                    J'ai utilisé le designer, savez vous ou sont ses dll?

                    Merci

                    • Partager sur Facebook
                    • Partager sur Twitter
                      7 mai 2013 à 16:21:16

                      "C:\Qt\Qt5.0.2\5.0.2\mingw47_32\plugins" des Dll ce trouve ici, mon problème (le même que toi) vennait de là.

                      Il faut les laissé dans le dossier, tu aurra donc ton .exe, ses dll à coté et les dossier tu répertoire plugin avec leur dll dedans (ceux dont tu as besoin)

                      Exemple :

                      tonProgramme.exe

                      tesDll.dll

                      /platforms/qminimal.dll

                      /platforms/qwindows.dll

                      -
                      Edité par armadon13127 7 mai 2013 à 16:22:26

                      • Partager sur Facebook
                      • Partager sur Twitter
                        7 mai 2013 à 17:43:14

                        Trop tard, je suis passé a Qt 4.8.4

                        Merci quand meme

                        • Partager sur Facebook
                        • Partager sur Twitter
                          12 mai 2013 à 11:58:54

                          Attention, j'ai eu le même problème que certain d'entre vous. Il faut inclure libEGL.dll . Le .exe ne le demande pas, mais il est nécessaire sinon le ne démarre pas
                          • Partager sur Facebook
                          • Partager sur Twitter
                          Toi, moi, nous. Nous somme tous les même. Respectons nous.
                            12 mai 2013 à 21:49:17

                            oui c'est vrai je l'avais oublié celui là :lol:
                            • Partager sur Facebook
                            • Partager sur Twitter
                              26 mai 2013 à 10:17:19

                              Perso il me demande libwinphthread.dll mais je ne le trouve pas dans tout mon disque C:/ est ce que quelqu'un saurait ou je peut le trouver ?

                              Merci d'avance !

                              PS: Comparé aux anciènnes versions, c'est un peu abusé le nombre de DLLs qu'il faut pour pouvoir distribuer son programme non ?

                              -
                              Edité par Darioo2 26 mai 2013 à 10:17:46

                              • Partager sur Facebook
                              • Partager sur Twitter
                                29 mai 2013 à 14:22:03

                                C'est bon, merci pour le lien des Dll qui m'a bien aidé !

                                Par contre, une fois dé-zippé ça fait près de 109Mo ... ça fait un peu beaucoup quand on veut simplement faire un mini programme avec Gui. c'est dommage parce que ça fait quand même pas mal parce que mon programme fait 98Ko et il faut que j'embarque 109Mo avec pour qu'il puisse fonctionner ...

                                Du coup je me pose la question si dans certains cas, il ne vaudrais pas mieux développer sous 4.8.4 plutôt que sous 5.0.2 ?

                                • Partager sur Facebook
                                • Partager sur Twitter
                                  29 mai 2013 à 20:27:30

                                  Darioo2 a écrit:

                                  C'est bon, merci pour le lien des Dll qui m'a bien aidé !

                                  Par contre, une fois dé-zippé ça fait près de 109Mo ... ça fait un peu beaucoup quand on veut simplement faire un mini programme avec Gui. c'est dommage parce que ça fait quand même pas mal parce que mon programme fait 98Ko et il faut que j'embarque 109Mo avec pour qu'il puisse fonctionner ...

                                  Du coup je me pose la question si dans certains cas, il ne vaudrais pas mieux développer sous 4.8.4 plutôt que sous 5.0.2 ?


                                  La version 4.8.4 est encore très très utilisé, et est à mon avis mieux, du à plusieurs détails, dont celui ci.
                                  Donc si !
                                  • Partager sur Facebook
                                  • Partager sur Twitter
                                  Toi, moi, nous. Nous somme tous les même. Respectons nous.
                                    29 mai 2013 à 21:15:16

                                    C'est surtout que la mise à jour prend du temps et que les gens n'ont pas encore fait la transition.

                                    Parce que 109 Mo, c'est pas un problème avec Qt 5, mais probablement parce que tu inclues des libs inutiles et que tu es en mode débug. Chez moi, l'ensemble de toutes les libs (plus de 37 libs) fait que 91,2 Mo... et j'imagine pas un programme utiliser toutes les libs de Qt

                                    Perso, j'utilise Qt 5 depuis longtemps et j'ai trouvé que les différences avec Qt 4 étaient tellement minime (Qt 5, c'est beaucoup de changement d'architecture interne) que ça valait pas le coup de rester sur Qt 4

                                    • Partager sur Facebook
                                    • Partager sur Twitter
                                    Pour poser des questions ou simplement discuter informatique, vous pouvez rejoindre le discord NaN.
                                      31 mai 2013 à 15:07:34

                                      Pourtant j'ai décompressé le zip dirrectement dans le répertoire de mon appli et j'ai 109Mo, peut être que j'ai une Dll qui trainait déjà dedans ...

                                      C'est les 37 libs compressés qui font 91,2Mo

                                      Sinon, j'ai installé les 2 versions de Qt, la 4.8.4 et la 5.0.2 comme ça je pourrais choisir au besoins.

                                      Merci de ton aide !

                                      • Partager sur Facebook
                                      • Partager sur Twitter
                                        31 mai 2013 à 15:55:07

                                        Tu n'as que les DLL de Qt5? car chez moi y en à pour 86Mo pour tout les DLL principaux, sachant que je doute que tu les utilises tous.

                                        Je pense comme gbdivers que tu as un problème de DLL inutile ou que tu es en debug.

                                        Donc vérifie que ce que tu as ne finisse pas par d, par exemple QWidgetd.dll, il faut te mettre en release et utilisé ceux sans le d comme QWidget.dll ce sera beaucoup plus légé.

                                        • Partager sur Facebook
                                        • Partager sur Twitter
                                          11 juin 2013 à 19:53:31

                                          J'ai suivi tous les conseils ici et pour résumer (*), car j'avais également 

                                          This application has requested the Runtime to terminate it in a unusual way .  

                                          aux "minimum syndical" il faut ajouter le dossier platforms avec dedans :

                                          • qminimal.dll
                                          • qwindows.dll

                                          ensuite il faudra aussi :

                                          •  libEGL.dll

                                          tout en veillant à les prendre dans le même répertoire à chaque fois.

                                          (*) : imote, armadon131
                                          PS : imote dans le minimum syndical Qt5Widgets.dll à sa place, mais  pas en plus dans la 2e liste.
                                          • Partager sur Facebook
                                          • Partager sur Twitter
                                            11 juin 2013 à 20:33:07

                                            Changements effectué, merci
                                            • Partager sur Facebook
                                            • Partager sur Twitter
                                            Toi, moi, nous. Nous somme tous les même. Respectons nous.
                                              12 juin 2013 à 0:07:26

                                              Bonjour à tous,

                                              c'est logique que Qt5.1  avec un programme affiche fenêtre mon  projet à une taille 300Mg e quelque

                                              et si possible vous pouvez me passe une liste d'une autre IDE pour C++ s'il vous palit.....

                                              -
                                              Edité par serviceplus 12 juin 2013 à 0:09:04

                                              • Partager sur Facebook
                                              • Partager sur Twitter
                                                12 juin 2013 à 9:16:41

                                                Je n'ai pas compris ta première phrase, pour la liste tu as par exemple :

                                                - Eclipse C++

                                                - Code::Blocks

                                                - Microsoft Visual Studio 2010 Express (et surement le 2012)

                                                • Partager sur Facebook
                                                • Partager sur Twitter
                                                  12 juin 2013 à 15:25:24 - Message modéré pour le motif suivant : Message complètement hors sujet


                                                  Anonyme
                                                    12 juin 2013 à 16:59:30

                                                    Merci de créer un nouveau sujet pour répondre à ta question, en utilisant les balises de code et en indiquant ce qui ne va pas

                                                    • Partager sur Facebook
                                                    • Partager sur Twitter
                                                      14 juin 2013 à 16:30:33

                                                      programme-zero a écrit:

                                                      J'ai rajouté toute les dlls mais j'ai cette erreur : This application has requested the Runtime to terminate it in a unusual way

                                                      -
                                                      Edité par programme-zero le 4 mai 2013 à 11:29:46



                                                      • Partager sur Facebook
                                                      • Partager sur Twitter
                                                      My name ? I've had a few. You can call me root.
                                                        14 juin 2013 à 16:33:42

                                                        Si tu a rencontré cette erreur, c'est que tu n'a pas installer les libraries d'éxécution de Microsoft Visual Studio.

                                                        Et oui ! Qt 5.0.2 nécessite ces libraries d'éxécution pour que le programme puisse être éxécuter.

                                                        Tu peux le télécharger à ce lien : https://qt-project.org/downloads.

                                                        Va dans la section "Other Download" et sélectionne la version de visual studio que tu a besoin (pour Qt 5 ou Qt 4).

                                                        -
                                                        Edité par Irrlicht 14 juin 2013 à 16:43:38

                                                        • Partager sur Facebook
                                                        • Partager sur Twitter
                                                        My name ? I've had a few. You can call me root.
                                                          14 juin 2013 à 16:35:37



                                                          -
                                                          Edité par Irrlicht 25 octobre 2013 à 18:56:29

                                                          • Partager sur Facebook
                                                          • Partager sur Twitter
                                                          My name ? I've had a few. You can call me root.
                                                            14 juin 2013 à 16:37:00

                                                            Si un point d'entré est introuvable dans une(des) dll(s), réinstinalle Qt. Il y a du avoir un problème lors de l'extraction des fichiers lors de l'installation.
                                                            • Partager sur Facebook
                                                            • Partager sur Twitter
                                                            My name ? I've had a few. You can call me root.
                                                              9 juillet 2013 à 16:11:54

                                                              Pour info, la nouvelle version de Qt possède maintenant icu..51.dll pour remplacer les 49

                                                              • Partager sur Facebook
                                                              • Partager sur Twitter

                                                              [Qt][DLL]Liste des DLL sous Qt 5.0.2

                                                              × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                                                              × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
                                                              • Editeur
                                                              • Markdown