Partage

qu'est ce qui bloque les "à" "é" sur un site web?

les "à' et les "é" ne s'affichent pas

11 août 2017 à 6:20:12

Bonjour à tous, 

qu'est ce qui bloque les "à" "é" sur un site web? en fait ils ne s'affichent même pas !

j'ai tenté le "Quelques mots à propos de moi" au lieu de "Quelques mots à propos de moi" mais le "à" ne s'affiche pas...

A quoi cela est il dû?
Voici le head de ma page : 



<!DOCTYPE html>
<html lang="fr">
<head>
    <title>About</title>
    <meta charset="utf-8">
    <link rel="stylesheet" type="text/css" media="screen" href="css/reset.css">
    <link rel="stylesheet" type="text/css" media="screen" href="css/grid_12.css">
    <link rel="stylesheet" type="text/css" media="screen" href="css/style.css">
    <link href='http://fonts.googleapis.com/css?family=Lato:300italic' rel='stylesheet' type='text/css'>
    <script src="js/jquery-1.7.min.js"></script>
    <script src="js/jquery.easing.1.3.js"></script>
    <script src="js/cufon-yui.js"></script>
    <script src="js/cufon-replace.js"></script>
    <script src="js/Bilbo_400.font.js"></script>
    <!--[if lt IE 8]>
       <div style=' clear: both; text-align:center; position: relative;'>
         <a href="http://windows.microsoft.com/en-US/internet-explorer/products/ie/home?ocid=ie6_countdown_bannercode">
           <img src="http://storage.ie6countdown.com/assets/100/images/banners/warning_bar_0000_us.jpg" border="0" height="42" width="820" alt="You are using an outdated browser. For a faster, safer browsing experience, upgrade for free today." />
        </a>
      </div>
    <![endif]-->
    <!--[if lt IE 9]>
           <script type="text/javascript" src="js/html5.js"></script>
        <link rel="stylesheet" type="text/css" media="screen" href="css/ie.css">
    <![endif]-->
</head>

j'ai tenté de mettre : 

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />



mais ça ne change rien.

pouvez vous m'aider?


ps : je suis sous chrome 


merci !!!

Staff 11 août 2017 à 7:41:16

Bonjour,

la première version de la meta charset est correcte. En revanche, là où ça doit coincer, c'est l'encodage de ton fichier. Il faudrait le réenregistrer en UTF-8 sans BOM. La méthode diffère selon les logiciels utilisés, quel est le tien ?

Autre chose : les JS, c'est mieux de les mettre tous au bas de la page, juste avant la balise de fermeture de body. Comme ça leur chargement se fait en dernier (oui, les navigateurs sont linéaires), et il n'impacte pas l'affichage de la page.

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
13 août 2017 à 23:09:24

Bonjour ;)

Ça ne fonctionne pas.

Je te donne l'URL entière en dev :

aurelie-sap75.fr/start/start/site/index.html

"Derniers evnements" à droite, le "è" n'est pas pris en compte :(

Ps : mon outil de dev est dreamweaver, et avec celui-ci j'ai jamais eu de problème d'encodage. De plus, l'aspect de ce site est un template recuperé sur le web

Merci encore !

-
Edité par oceane751 13 août 2017 à 23:12:59

Staff 13 août 2017 à 23:12:52

Ça ne fonctionne pas : qu'as-tu fait exactement ? Tu n'as pas répondu à ma question, quel est ton éditeur de code ?
Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
13 août 2017 à 23:13:17

Ps : mon logiciel est dreamweaver et j'ai jamais eu de problème d'encodage avec cet outil... de plus la charte graphique je l'ai récupérée sur le web...

J'ai mis tous mes script avant la fermeture body...

Désolée mais je ne peux pas répondre à tes messages, faut que j'attends 24h, donc je suis obligée de modifier le message précédent.. 

-
Edité par oceane751 13 août 2017 à 23:21:44

14 août 2017 à 0:13:42

Hello,
Je n'ai pas vu dans le code quoi que ce soit qui peut expliquer ton souci...
Du coup, la font que tu utilises, contient-elle les caractères accentués ? (Je commence par le plus absurde, mais sait-on jamais)
Ensuite, as-tu tenté de vider le cache de ton navigateur ? (combien de fois mes modifs étaient pas prises en compte à cause du contenu du cache)

Je ne ferai aucune remarque sur la forêt de !important dans le code (les joies de Dreamweaver)o_O
Avec l'inspecteur d'éléments on voit bien que le texte voulu est "évènement", mais la transcription dans la balise canvas ne passe pas. Peut etre creuser la doc de ce côté là ;)

-
Edité par Tydresic 14 août 2017 à 0:25:20

Ce qui se comprend aisément s'énonce clairement / DocPHP / DocHTML/CSS/JS
14 août 2017 à 0:51:38

Salut,

En supprimant l'effet "cufon" et en ajoutant la règle "font-family: 'Bilbo', cursive;" (comme conseillé par google font) à .top-1, l'accent s'affiche.

Eviter d'abuser de try...catch avec PDO, vous vous en sentirez mieux. le bienfait n'est jamais perdu
14 août 2017 à 4:21:55

WillyKouassi a écrit:

Salut,

En supprimant l'effet "cufon" et en ajoutant la règle "font-family: 'Bilbo', cursive;" (comme conseillé par google font) à .top-1, l'accent s'affiche.


Merci pour ta réponse.

Mais tout est géré par des canvas.. je fais comment? :/

14 août 2017 à 8:55:05

Salut,

la partie canvas des fonts est gérée dans le fichier cufon-replace.js , donc tu peux retirer ce fichier et gérer tes fonts avec le css

-
Edité par WillyKouassi 14 août 2017 à 9:04:10

Eviter d'abuser de try...catch avec PDO, vous vous en sentirez mieux. le bienfait n'est jamais perdu
14 août 2017 à 11:30:05

C'est ce que j'ai fait mais la font disparait

WillyKouassi a écrit:

Salut,

la partie canvas des fonts est gérée dans le fichier cufon-replace.js , donc tu peux retirer ce fichier et gérer tes fonts avec le css

-
Edité par WillyKouassi il y a environ 1 heure


j'ai fait ça: 

<link href="https://fonts.googleapis.com/css?family=Bilbo" rel="stylesheet" type="text/css">
   	<script src="js/jquery-1.7.min.js"></script>
    <script src="js/jquery.easing.1.3.js"></script>
    <script src="js/cufon-yui.js"></script>
    <script src="js/cufon-replace.js"></script>
  <script src="js/tms-0.4.1.js"></script>

mais ma font disparaît ..

-
Edité par oceane751 14 août 2017 à 11:39:07

14 août 2017 à 11:53:10

il y a tout de même cufon (cufon-yui/cufon-replace.js) dans les js , c'est pas ce que j'ai dit...

J'ai conseillé de laisser tomber cufon et de passer le css pour gérer la police puisque tu as déjà chargé la  police Bilbo

Eviter d'abuser de try...catch avec PDO, vous vous en sentirez mieux. le bienfait n'est jamais perdu
14 août 2017 à 13:57:40

Donc je supprime cufon et je gère le font en css?
14 août 2017 à 15:44:14

Oui et il ne suffit pas de charger la police pour que la mise en forme se fasse de manière automatique, indique dans ton fichier css, les éléments qui doivent avoir cette police en utilisant la règle font-family: 'Bilbo', cursive;

-
Edité par WillyKouassi 14 août 2017 à 15:44:45

Eviter d'abuser de try...catch avec PDO, vous vous en sentirez mieux. le bienfait n'est jamais perdu

qu'est ce qui bloque les "à" "é" sur un site web?

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown