Partage
  • Partager sur Facebook
  • Partager sur Twitter

SwiftMailer , symfony 4 gmail comment réussir

je vous aide à paramétrer la brique logicielle avec gmail

Sujet résolu
12 octobre 2019 à 18:26:03

Salut , c'est juste pour vous montrer comment paramétrer gmail avec swiftmailer avec symfony 4 ,parce quer la doc officielle c'est de la bonne grosse merde !!

dans config/package/swiftmailer.yaml

vous mettez :

swiftmailer:

spool: { type: 'memory' }
transport : gmail
host: smtp.gmail.com
port: 465
auth_mode: login
username: monadresseemail@gmail.com
password: mdp
encryption: ssl
stream_options:
ssl:
allow_self_signed: true
verify_peer: false
verify_peer_name: false

voilà parce que le  fichier .env c'est pas possible. la doc est à chier

Salut!

oubliez pas de cliquer sur  j'aime si je vous ai aidé !

-
Edité par alex5956 12 octobre 2019 à 18:52:42

  • Partager sur Facebook
  • Partager sur Twitter
12 octobre 2019 à 20:58:58

Salut, pourquoi dans le env c'est pas possible ?

  • Partager sur Facebook
  • Partager sur Twitter
12 octobre 2019 à 21:11:13

salut,

configure ton gmail correctement avant de dire que la doc de symfony c'est de la merde

pour infos, j'ai pratiquement toujours parvenus à mes fins avec la doc et l'aide du forum OC

regarde la mail intitulé alerte sécurité que tu as reçu de gmail...

-
Edité par AaFredericHusson 12 octobre 2019 à 21:12:50

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

12 octobre 2019 à 21:13:06

AaFredericHusson a écrit:

salut,

configure ton gmail correctement avant de dire que la doc de symfony c'est de la merde

pour infos, j'ai pratiquement toujours parvenus à mes fins avec la doc et l'aide du forum OC


Tu aurais pu jouer le jeu, des fois qu'on rigole un peu ;)

Puis julp serait arrivé et PAFFF :D

  • Partager sur Facebook
  • Partager sur Twitter
12 octobre 2019 à 21:15:03

@christouphe toute mes excuse j'en suis sincèrement désolé hihi

oh c'est pas peine perdu vas savoir

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 13:22:27

le .env je l'écris tel quel soit il dit que j'arrive pas à joindre le smtp gmail , soit il y a un pb avec le paramètre ssl

j'ai

 ERROR     [app] Exception occurred while flushing email queue: Connection could
 not be established with host smtp.gmail.com [ #0]

avec ça=>

MAILER_URL=gmail://username:password@localhost?encryption=tls&auth_mode=oauth

avec ce site =>https://symfony.com/doc/current/email.html

-
Edité par alex5956 13 octobre 2019 à 13:28:18

  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 13:38:30

euh...

je sais pas d'ou tu sort ça mais probablement pas de la doc officielle...

car la tu mélange la commande gmail et smtp

pour gmail c'est ça:

MAILER_URL=gmail://username:password@localhost

d'ailleurs je vois pas l'utilité de la doc pour ça c'est déjà expliqué dans ton .env pour preuve:

###> symfony/swiftmailer-bundle ###
# For Gmail as a transport, use: "gmail://username:password@localhost"
# For a generic SMTP server, use: "smtp://localhost:25?encryption=&auth_mode="
# Delivery is disabled by default via "null://localhost"
MAILER_URL=smtp://localhost
###< symfony/swiftmailer-bundle ###




  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:03:44

rien avoir je viens rééssayer en testant avec swiftmailer:email:send la doc est bien à chier
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:09:27

MAILER_URL=gmail://username:password@localhost

voilà comment ont configure

vérifie ton gmail dans tes mails reçu et envoyé avant de dire que ça fonctionne pas...

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:22:27

oui !! c'est ce que j'ai fais avec un mdp d'appli et ça ne fonctionne pas  avec le  .env

en username j'ai mis mon adresse gmail avec le nom de domaine bien entendu

-
Edité par alex5956 13 octobre 2019 à 14:23:59

  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:26:28

ah bah forcément si tu met l'adresse mail au lieu de l'username

exemple

MAILER_URL=gmail://test343:123456789@localhost

et non:

MAILER_URL=gmail://test343@gmail.com:123456789@localhost




-
Edité par AaFredericHusson 13 octobre 2019 à 14:28:48

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:29:49

 username is your full Gmail or Google Apps email address
MAILER_URL=gmail://username:password@localhost
   
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:31:30

Salut moi quand je fait ça, ça marche hein, la doc elle explique bien comment faire :/

MAILER_URL=gmail://email_complet@gmail.com:mot_de_passe@localhost


  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:33:37

^^ c'est ce que je fais depuis le  début ! donc non ! et dans le yaml ?

-
Edité par alex5956 13 octobre 2019 à 14:34:52

  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:35:13

l'username correspond à ton username gmail et non ton adresse mail complète

fais un teste avant de dire que ça ne vas pas

si je l'ai fait ainsi c'est que ça fonctionne...

tu doit renseigner les identifiants que tu utilise pour te connecter à ton gmail...

MAILER_URL=gmail://fredy6786:xxxxx@localhost



-
Edité par AaFredericHusson 13 octobre 2019 à 14:40:14

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:37:31

haahahah XDXD tu m'ad dis si tu mets l'email au lieu de l'user blabla et maintentant tu me dis de mettre l'username gmail alors QUE c'est l'adresse mail
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:38:41

Il faut pas oublier d'activé dans gmail  autorisé les connexion non sécurisé car elle interdise l’accès via SMTP
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:43:16

non toujours pas , montres un peu tes yaml stp

  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:43:27

@alex5956

c'est l'username et non l'adresse mail regarde mon code j'ai laissé expres mon username

et tu n'as pas à toucher à ton yaml

vérifie tes logs, et ton gmail

swiftmailer.yaml

swiftmailer:
    url: '%env(MAILER_URL)%'
    spool: { type: 'memory' }



-
Edité par AaFredericHusson 13 octobre 2019 à 14:47:38

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:51:45

dac ok mais je le connais comment ? l'username ? prenom.nom ? déjà essayé
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 14:54:23

tu connais pas ton username?

comment tu fait pour te connecter à gmail?

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 14:59:25

si je le connais mais ça ne fonctionne pas , toujours le même pb !même message d'erreur je ne peux pas à partir du .env
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 15:06:23

et sur gmail ça dis quoi?

pas de message reçu de leurs part?

  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

13 octobre 2019 à 16:00:25

non y a que par le yaml que ça marche
  • Partager sur Facebook
  • Partager sur Twitter
13 octobre 2019 à 16:10:17

si tu le dit...
  • Partager sur Facebook
  • Partager sur Twitter

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça

14 octobre 2019 à 13:09:00

Bon les gars je vous remercie quand même de m'avoir aidé même si ça n'a pas marché

ciao merci !

Cordialement

  • Partager sur Facebook
  • Partager sur Twitter
29 octobre 2019 à 14:23:18

Salut @ tous,

je reviens sur ce sujet car je suis tombé sur l'os et je l'ai mangé :D

Le problème de connexion apparut dans SF:

Exception occurred while flushing email queue: Failed to authenticate on SMTP server with username "<GAMIL_LOGIN>" using 1 possible authenticators. Authenticator LOGIN returned Expected response code 235 but got code "535", with message "535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials v8sm16832263wra.79 - gsmtp 

Ce cas se produit lorsque vous activez l'authentification en 2 étapes sur google.

Pour contourner, il vous faut donc:

###> symfony/swiftmailer-bundle ###
# For Gmail as a transport, use: "gmail://username:password@localhost"
# For a generic SMTP server, use: "smtp://localhost:25?encryption=&auth_mode="
# Delivery is disabled by default via "null://localhost"
MAILER_URL=gmail://<GMAIL_LOGIN>:<GMAIL_APPLICATION_PASSWORD>@localhost
###< symfony/swiftmailer-bundle ###

Vous pouvez ensuite envoyer les mails en applicant la conf ci-desous dans le fichier config/packages/swiftmailer.yaml (en respectant l'indentation):

swiftmailer:
    url: '%env(MAILER_URL)%'
    spool: { type: 'memory' }
    transport : gmail
    host: smtp.gmail.com
    port: 465
    auth_mode: login
    username: <GMAIL_LOGIN>@gmail.com
    password: <GMAIL_PASSWORD>
    encryption: ssl
    stream_options:
        ssl:
            allow_self_signed: true
            verify_peer: false
            verify_peer_name: false

En espérant que ça aide ;)

-
Edité par christouphe 29 octobre 2019 à 14:39:59

  • Partager sur Facebook
  • Partager sur Twitter
4 novembre 2019 à 9:38:07

.... pas la peine de paraméter le .env si tout est dans le yaml dans ce cas

-
Edité par alex5956 4 novembre 2019 à 9:38:52

  • Partager sur Facebook
  • Partager sur Twitter
4 novembre 2019 à 9:49:12

Salut !

alex5956 a écrit:

.... pas la peine de paraméter le .env si tout est dans le yaml dans ce cas

Tout à fait d'accord.

Qui plus est, comme signalé en privé à christouphe, swiftmailer.yaml n'est pas ignoré par défaut, donc le risque de pousser votre adresse mail et son mot de passe sur votre VCS est réel. Je sais par expérience que sur Github et BitBucket, les logs et diffs ne sont pas supprimés même si vous supprimez les commits incriminés du repository, donc pour masquer ces données dans les diffs, pour le cas où vous avez malencontreusement poussé ce qui n'aurait pas dû l'être, il n'y a actuellement à ma connaissance pas d'alternative à la suppression complète du repository sur la plateforme de collaboration.

alex5956 a écrit:

heiiin ??? non même aps de git dans ct'histoire !! dans le .env @localhost ne veut rien dire le service gmail est chez google , pas possible avec ce qu'il y a dans la doc pour que ça marche !!

Etrange que ça fontionne chez moi alors. La documentation me passe au-dessus comme la station spatiale internationale, pourtant. Est-ce que tu peux m'expliquer comment tu fais, que je puisse faire faux moi aussi ?

-
Edité par Ymox 11 novembre 2019 à 22:51:50

  • Partager sur Facebook
  • Partager sur Twitter
OC à changerFAQ PHP • Et avant celaTutoriel WAMP • Code illisible ? Un p'tit 👍 ici@Zeste de Savoir
11 novembre 2019 à 21:31:30

heiiin ??? non même aps de git dans ct'histoire !! dans le .env @localhost ne veut rien dire le service gmail est chez google , pas possible avec ce qu'il y a dans la doc pour que ça marche !!
  • Partager sur Facebook
  • Partager sur Twitter