Partage
  • Partager sur Facebook
  • Partager sur Twitter

Unity et Blender : Comment désactiver le rose ?

Et comment activer les modèles correctement

Sujet résolu
    15 novembre 2020 à 11:10:06

    Bonjour à tous,

    Je suis actuellement sur un projet avec Unity et j'utilise Blender pour créer mes assets en 3d.

    Ma configuration :

    - Ubuntu 18.04

    - Blender 2.90

    - Unity 2019.4.13f1

    Donc, j'ai créé un modèle 3d avec Blender et j'y ai appliqué une texture via l'onglet Matériaux > Surface > Couleur de base > Texture image, puis j'ai choisi ma texture. J'ai vérifié, elle s'applique bien sur ce fichier.

    Ensuite, j'ai importé ce modèle avec Unity (au format .blend) ; il a donc crée une copie du modèle dans le dossier du projet. Or, quand j'ouvre cette copie, le modèle s'affiche dans un rose pas très joli... Alors que la texture est bien correcte !

    Le pire est à venir : Quand j'importe le modèle dans Unity, il s'affiche sans aucune texture, et n'apparaît même pas dans la fenêtre de jeu ! Quelqu'un pourrait-il m'aider ? (je sais que ça fait beaucoup de problèmes en même temps, mais je débute et je ne trouve AUCUN tutoriel là-dessus !)

    • Partager sur Facebook
    • Partager sur Twitter
      18 novembre 2020 à 11:09:34

      J'ai résolu tous les problèmes !

      Par contre, je suis désolé d'avoir créé ce sujet pour rien !

      -
      Edité par NoelNatur 19 novembre 2020 à 10:18:01

      • Partager sur Facebook
      • Partager sur Twitter
        19 novembre 2020 à 10:39:17

        Bonjour,

        Déplacement vers un forum plus approprié

        Le sujet est déplacé de la section Graphisme 3D vers la section Mapping & modding


        NoelNatur a écrit:

        J'ai résolu tous les problèmes !

        Par contre, je suis désolé d'avoir créé ce sujet pour rien !

        Il ne le serait pas si tu expliquais comment tu as résolu tes problèmes. C'est à ça que sert un forum avant tout : partager !

        • Partager sur Facebook
        • Partager sur Twitter

        FAQ 3D || Discord 3DFR || OC Tweak script

          22 décembre 2020 à 18:22:18

          -L0Lock- a écrit:

          Il ne le serait pas si tu expliquais comment tu as résolu tes problèmes. C'est à ça que sert un forum avant tout : partager !

          Tu as tout à fait raison !

          En fait, il fallait que je coche la case "Fichier > Données externes > Empaqueter automatiquement dans le .blend" et mettre la texture dans le même dossier que le modèle.

          • Partager sur Facebook
          • Partager sur Twitter

          Unity et Blender : Comment désactiver le rose ?

          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
          × Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
          • Editeur
          • Markdown