Partage
  • Partager sur Facebook
  • Partager sur Twitter

Validation compromise

Trois erreurs sans solution

13 janvier 2006 à 20:09:55

Bonjour à tous ! :p

Je veux rendre ma page valide en XHTML 1.1 strict. J'ai enlevé la grande majorité des erreurs, mais il en subsiste trois que je n'arrive pas à résoudre :

<lien url="http://validator.w3.org/check?uri=http%3A%2F%2Fwww.jap-on.com%2F&charset=%28detect+automatically%29&doctype=XHTML+1.1">Page de validation de mon site</lien>

Les lignes de code correspondantes sont :

Ligne 25 :

Citation

<script language="javascript">

( Rien à la ligne 26 comme indiqué o_O )

Lignes 68 à 85 :

Citation

<script language="JavaScript" type="text/javascript">
function closeAd()
{
var object = "pub";
if (document.layers && document.layers[object])
{
document.layers[object].visibility = 'hidden';
}
else if (document.all)
{
document.all[object].style.visibility = 'hidden';
}
else if (document.getElementById)
{
document.getElementById(object).style.visibility = 'hidden';
}
}
</script>



Lignes 98 à 130 :

Citation

<table>
<tr>
<td>
<a href="http://www.jap-on.com/index.php" onmouseover="i000001.src='http://www.jap-on.com/design/accueil1.jpg'" onmouseout="i000001.src='http://www.jap-on.com/design/accueil0.jpg'"><img src="http://www.jap-on.com/design/accueil0.jpg" name="i000001" alt="Accueil"/></a>
</td>
<td>
<a href="http://www.jap-on.com/japon.php" onmouseover="i000002.src='http://www.jap-on.com/design/japon1.jpg'" onmouseout="i000002.src='http://www.jap-on.com/design/japon0.jpg'"><img src="http://www.jap-on.com/design/japon0.jpg" name="i000002" alt="Japon"/></a>
</td>
<td>
<a href="http://www.jap-on.com/animes.php" onmouseover="i000003.src='http://www.jap-on.com/design/animes1.jpg'" onmouseout="i000003.src='http://www.jap-on.com/design/animes0.jpg'"><img src="http://www.jap-on.com/design/animes0.jpg" name="i000003" alt="Animés - Mangas - DDL"/></a>
</td>
<td>
<a href="http://www.jap-on.com/cuisine.php" onmouseover="i000004.src='http://www.jap-on.com/design/cuisine1.jpg'" onmouseout="i000004.src='http://www.jap-on.com/design/cuisine0.jpg'"><img src="http://www.jap-on.com/design/cuisine0.jpg" name="i000004" alt="Cuisine"/></a>
</td>
<td>
<a href="http://www.jap-on.com/japonais.php" onmouseover="i000005.src='http://www.jap-on.com/design/japonais1.jpg'" onmouseout="i000005.src='http://www.jap-on.com/design/japonais0.jpg'"><img src="http://www.jap-on.com/design/japonais0.jpg" name="i000005" alt="Japonais"/></a>
</td>
<td>
<a href="http://www.jap-on.com/musique.php" onmouseover="i000006.src='http://www.jap-on.com/design/musique1.jpg'" onmouseout="i000006.src='http://www.jap-on.com/design/musique0.jpg'"><img src="http://www.jap-on.com/design/musique0.jpg" name="i000006" alt="Musique"/></a>
</td>
<td>
<a href="http://www.jap-on.com/cinema.php" onmouseover="i000007.src='http://www.jap-on.com/design/cinema1.jpg'" onmouseout="i000007.src='http://www.jap-on.com/design/cinema0.jpg'"><img src="http://www.jap-on.com/design/cinema0.jpg" name="i000007" alt="Cinéma"/></a>
</td>
<td>
<a href="http://www.jap-on.com/jeuxvideo.php" onmouseover="i000008.src='http://www.jap-on.com/design/jeuxvideo1.jpg'" onmouseout="i000008.src='http://www.jap-on.com/design/jeuxvideo0.jpg'"><img src="http://www.jap-on.com/design/jeuxvideo0.jpg" name="i000008" alt="Jeux Vidéo"/></a>
</td>
<td>
<a href="http://www.jap-on.com/forum.php" onmouseover="i000009.src='http://www.jap-on.com/design/forum1.jpg'" onmouseout="i000009.src='http://www.jap-on.com/design/forum0.jpg'"><img src="http://www.jap-on.com/design/forum0.jpg" name="i000009" alt="Forum"/></a>
</td>
<td>
<a href="http://www.jap-on.com/boutique.php" onmouseover="i000010.src='http://www.jap-on.com/design/boutique1.jpg'" onmouseout="i000010.src='http://www.jap-on.com/design/boutique0.jpg'"><img src="http://www.jap-on.com/design/boutique0.jpg" name="i000010" alt="Boutique"/></a>
</td></tr>
</table>



Vous aurez remarqué que pour la dernière erreur, il y a dix fois la même ligne de code, mais seule la première pose problème ! o_O

Edit : Si un gentil modo pouvait rectifier le titre, petite faute de frappe .. :p
[Edit] Nyro Xeo > Voilà, je suis le gentil modo :)
Edit 2 : Merci gentil modo ^^ ( Tu es rapide en plus o_O )
  • Partager sur Facebook
  • Partager sur Twitter

Validation compromise

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown