Partage
  • Partager sur Facebook
  • Partager sur Twitter

VLAN TP-Link

Architecture + configuration

    22 août 2020 à 14:00:17

    Bonjour à tou(te)s,


    Je n'arrive pas à configurer les VLANs sur un switch TP-Link TL-SG105E (5 ports, et ensuite des switchs classiques en aval des ports 1, 2 et 3) :
    Firmware Version 1.0.0 Build 20171214 Rel.70092
    Hardware Version TL-SG105E 3.0

    Mon routeur est aussi un TP-Link Archer C20 :

    Firmware Version : 0.9.1 4.16 v0001.0 Build 181213 Rel.63587n

    Hardware Version : Archer C20 v4 00000004


    Le cahier des charges (raccordement coté Switch manageable) :
    Port 1 = VLAN "Maison"
    Port 2 = VLAN "Travail"
    Port 3 = VLAN "Invites"
    Port 4 = NAS + Imprimante
    Port 5 = Routeur

    Je souhaite faire communiquer :
    a/ 1 <-> 4 <-> 5
    b/ 2 <-> 4 <-> 5
    c/ 3 <-> 5
    d/ 4 <-> 5 (j'imagine que cette condition est induite par "a/" et "b/", mais j'aimerais confirmation)

    En language français :
    1) Les équipements Maison / Pro / Invités / NAS+Imprimante peuvent tous avoir accès au WAN via le routeur
    2) Maison ne peut pas voir Pro ni Invités (valable dans les 2 sens Voir / Être vu)
    3) Pro ne peut pas voir Invités (valable dans les 2 sens)
    4) le NAS+Imprimante doit pouvoir avoir accès et être accessible depuis Maison et Pro, mais pas par les invités. Par contre il doit pouvoir sortir sur le WAN (Quickconnect Synology)



    Et le problème (partie1) :
    Je ne sais pas quoi faire avec les notions de Tag / Untagg / PVID (je pensais avoir trouvé un solution sur un forum avec quelqu'un qui avait une problématique proche de la mienne, mais chez moi ça bloque)
    Pour mieux visualiser, 2 captures d'écrans de 2 essais de configuration non concluant
    J'ai lu quelque part qu'une machine (PC) qui ne sait pas tagger doit forcément être raccordée sur un port "Untagged" ;
    J'ai vu aussi que certains switchs ne savent pas gérer des ports untagg sur plusieurs VLAN ; => Je pense (et j'èspère) que le mien sait gérer car il me laisse la possibilité de configurer comme cela
    Ou encore que le mode tagg permet d'avoir un serveur pouvant communiquer avec plusieurs VLANs sans que ces VLANs ne puissent dialoguer entre eux ; => On s'approche quand même de mon cahier des charges
    J'ai vu un tas de définition pour les termes Tagg, Untagg, PVID... Je ne les mets volontairement pas ici pour éventuellement avoir ces définitions sous une autre tournure.

    La suite du problème (Partie 2) :

    J'ai posté mon problème sur un autre forum et la seule réponse que j'ai eu est "Il faut utiliser le routeur pour faire des communication inter VLANs", hors ce point n'avait jamais été évoqué dans les différents sujets que j'ai lus avant de créer mon post. J'ai donc poussé mes recherches sur cette partie la, j'ai notamment trouvé ces 2 sujets :

    https://openclassrooms.com/forum/sujet/routage-inter-vlan-dans-meme-plage-ip-possible

    https://openclassrooms.com/forum/sujet/routage-intervlan-pc-qui-ping-pas-a-un-autre-vlan

    Je pensais dans un premier temps aborder le sujet comme suit :
    Etape 1 : Définir son architecture physique (A ce niveau la pas de problème, du moins je crois pas LoL)
    Etape 2 : Créer les VLANs et ensuite associer les PVID (Coté VLAN je pense être OK, mes recherches me laissent penser que je dois bien créer des VLANs pour le NAS tout seul et pour le routeur tout seul ; coté PVID je sais pas trop, je raisonne dans mon cas de figure comme suit "1 port physique = 1 PVID", le raisonnement ne serait pas le même si j'avais le même cahier des charges mais avec un switch 16 ports par exemple, où plusieurs ports physiques seraient associés au même PVID)
    Etape 3 : Configurer les Tagg / Untagg / Not member => La c'est le drame 

    MAIS, il semblerait que je doive integrer la partie routeur, mais avec les 2 sujets que j'ai posté ci-dessus j'ai l'impression que mon architecture ne semble pas pouvoir résoudre mon cahier des charges ; Je ne sais pas comment associer :

    Routage + Port Tagged + Port Untgged + PVID

    Ci-dessous, 2 screenshots de 2 configurations non concluantes (sans tenir compte de la partie routage que j'ignorais à ce moment)

    En complément d'info :

    - Mon serveur DHCP est mon routeur

    - J'ai fixé l'adresse IP de pratiquement tous mes équipement entre 192.168.0.1 -> 192.168.0.240 ; et DHCP 192.168.0.241 -> 192.168.0.250

    - Je peux si besoin répartir mes VLANs sur 192.168.x.z pour VLAN1, 192.168.y.z pour VLAN2 ect..., mais dans ce cas comment va se comporter le DHCP ? et si le routeur est en 192.168.0.1, les équipements du VLAN 192.168.10.x devront avoir un masque de sous réseau en 255.255.0.0 ?

    Merci pour vos lumières :)

    Roman

    • Partager sur Facebook
    • Partager sur Twitter
      28 février 2021 à 8:22:00

      Regarde sur https://www.fingerinthenet.com/vlan
      • Partager sur Facebook
      • Partager sur Twitter

      VLAN TP-Link

      × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
      • Editeur
      • Markdown