Partage
  • Partager sur Facebook
  • Partager sur Twitter

Wamp 3.0.6 MSVCR110.dll manquant

fichier MSVCR110.dll introuvable

Sujet résolu
19 décembre 2017 à 17:54:39

Bonjour à tous, 

Dernièrement je me suis lancé dans la création de site en Php et j'ai suivis le tutoriel sur la conception de site dynamique avec Php MySql et Appache.

Lorsque j'ai installé la dernier version de Wamp 3.0.6 (j'ai suivie la procédure d'installation bien comme il le faut) impossible de l'ouvrir. Au double clique cela m'affiche un message d'erreur disant que le fichier MSVCR110.dll est introuvable. Je voudrais remédier à ce problème mais je ne sais pas quoi faire :(

je possède Windows 10 professionnel 64 bits. 

J'aimerai corriger ce problème le plus vite possible pour un travail scolaire

Merci de votre aide

  • Partager sur Facebook
  • Partager sur Twitter
19 décembre 2017 à 18:02:34

Salut,

J'ai eu le souci récemment en installant WAMP sur un poste du boulot.

J'ai téléchargé les dll manquantes sur le net (de mémoire il en manquait trois chez moi), par exemple : http://www.telecharger-dll.fr/recherche-fichier-dll?dll_name=MSVCR110

Il suffit ensuite de mettre la dll manquante dans C:\Windows\System32 et C:\Windows\SysWOW64 (pour les versions 64 Bits).

  • Partager sur Facebook
  • Partager sur Twitter
19 décembre 2017 à 18:53:58

Merci 

mais cette fois j'ai une autre erreur. Ça dit que l'application n'a pas réussi à démarrer correctement (0xc000007b) 

Je ne sais pas c'est quoi le problème :(

-
Edité par QasOs 19 décembre 2017 à 18:57:31

  • Partager sur Facebook
  • Partager sur Twitter
20 décembre 2017 à 9:10:57

Salut,

D'après ce sujet du forum officiel WAMP : http://forum.wampserver.com/read.php?1,149503

Ce message d’erreur peut apparaître sur les systèmes 64 bits, lorsque le redistributable Microsoft Visual C++ n’est pas configuré correctement. Les paquetages VC++ doivent être installés AVANT de lancer l'installation de Wampserver, laquelle doit être lancée "en tant qu'administrateur".

Commence par vérifier que tous les paquetages VC++ sont bien installés et avec les dernières versions. Pour ce faire, utilise l'outil de vérifications des paquetages VC installés. Cet outil est dispo sur le site de WAMP à l'adresse http://wampserver.aviatechno.net/files/tools/check_vcredist.exe

Tous les paquetages sont disponibles à l'adresse http://wampserver.aviatechno.net dans la section Visual C++ Redistribuable Packages.

  • Partager sur Facebook
  • Partager sur Twitter
21 décembre 2017 à 2:11:50

J'ai réussis à installer wampserver sans erreur, seulement mon icone dans la barre des tache reste orange (et pas verte selon le tutoriel)

Je peux tout de même accéder à mon localhost et naviguer dans les options de l'icone.

Est-ce un problème dont je devrait m'en soucier ?

merci pour ton aide

parfait j'ai trouvé le probleme, merci pour ton aide

-
Edité par QasOs 21 décembre 2017 à 5:57:54

  • Partager sur Facebook
  • Partager sur Twitter
21 décembre 2017 à 8:55:03

N'h"site pas à expliquer ton problème et la façon de le résoudre, cela servira si quelqu'un rencontre le même souci un jour... ;)
  • Partager sur Facebook
  • Partager sur Twitter
29 décembre 2017 à 4:20:02

oui pardon pour l'attente je n'avais pas vue ton message. 

Enfait, j'ai seulement télécharger les librairies manquante comme celle que tu m'a donner et je les ai mis dans mon  repertoire windows system32 et WOW64 :)

  • Partager sur Facebook
  • Partager sur Twitter
29 décembre 2017 à 11:13:31

Salut !

C'est la pire des solutions que de prendre chaque fichier manquant et de le placer "quelque part", sincèrement. Tu n'as aucune certitude que ce que tu as téléchargé est bien ce dont tu avais besoin et ne fait que ça, et en plus ton système ne sait pas vraiment que ce dont il pourrait avoir besoin est bien installé (non, copier-coller des fichiers n'est pas une installation). La réponse mentionnant le serveur officiel et les paquetages à installer est bien plus pertinente et sûre à mon avis.
Maintenant, si vous ne tenez pas trop à l'intégrité de vos ordinateurs, ce sont les vôtres après tout…

Ah non, il y en a un qui semble appartenir à une entreprise.

Si vous voulez refaire ça proprement, vous pouvez partir à la chasse aux fichiers que vous avez téléchargés un à un pour les enlever avant d'installer quoi que ce soit.

  • Partager sur Facebook
  • Partager sur Twitter
29 décembre 2017 à 17:34:03

Oui je sais mais les packages étaient impossible à installer dans mon cas.

Dans le site de miscrosoft y'en avait 3 mais 2 seulement d'entre eux était installés et windows n'a pas voulu installer celui avec l'extention .arm alors j'ai procédé à la méthode dure, je n'ai pas le choix

  • Partager sur Facebook
  • Partager sur Twitter
30 décembre 2017 à 23:12:14

Ah… Ben tu n'installes que deux d'entre eux si tu es sur un ordinateur à architecture 64 bits (pas la version ARM), et seulement la version x86 pour du 32 bits. ARM est une "architecture particulière" de processeur, plus ou moins au même titre que x86 (32 bits) et x64 (64 bits).

  • Partager sur Facebook
  • Partager sur Twitter
31 décembre 2017 à 5:44:10

oui j'ai installé les deux mais malheureusement au cours de l'installation de wampServer ca m'afficher souvant l'erreur du fichier .dll qui manquait
  • Partager sur Facebook
  • Partager sur Twitter
31 décembre 2017 à 9:39:26

Note bien que pour WampServer, il te faut installer 10 versions vu que tu sembles être en 64 bits, soient les versions 32 et 64 bits de cinq versions de Microsoft Visual C++ Redistribuable (abrégé VC). Apparemment tu n'as pas installé les deux versions pour VC11 (2010), sans quoi ton ordinateur n'aurait pas continué à te dire que ce fichier manquait.

Tu as tout ce qu'il faut si tu lis ce qui est expliqué lors de l'installation de WampServer, que tu regardes les premier et troisième liens dans ce message, ou encore que tu regardes ce tableau

-
Edité par Ymox 31 décembre 2017 à 9:41:19

  • Partager sur Facebook
  • Partager sur Twitter
10 septembre 2018 à 2:56:09

Bonjour j'ai le même problème comment puis-je  faire ?
  • Partager sur Facebook
  • Partager sur Twitter
V.L
10 septembre 2018 à 10:59:51

@Luc-RenéVanderlinden la solution est donnée par Ymox dans le message précédent

Bonjour,

Déterrage

Citation des règles générales du forum :

Avant de poster un message, vérifiez la date du sujet dans lequel vous comptiez intervenir.

Si le dernier message sur le sujet date de plus de deux mois, mieux vaut ne pas répondre.
En effet, le déterrage d'un sujet nuit au bon fonctionnement du forum, et l'informatique pouvant grandement changer en quelques mois il n'est donc que rarement pertinent de déterrer un vieux sujet.

Au lieu de déterrer un sujet il est préférable :

  • soit de contacter directement le membre voulu par messagerie privée en cliquant sur son pseudonyme pour accéder à sa page profil, puis sur le lien "Ecrire un message"
  • soit de créer un nouveau sujet décrivant votre propre contexte
  • ne pas répondre à un déterrage et le signaler à la modération

Je ferme ce sujet.

  • Partager sur Facebook
  • Partager sur Twitter