• 8 heures
  • Facile

Ce cours est visible gratuitement en ligne.

course.header.alt.is_video

course.header.alt.is_certifying

J'ai tout compris !

Mis à jour le 16/08/2017

Installez vos outils

Connectez-vous ou inscrivez-vous gratuitement pour bénéficier de toutes les fonctionnalités de ce cours !

Prêts à embarquer dans le monde des heureux codeurs en Ruby ?  

Commencez par vous munir des outils de base que je vais vous présenter ici pour coder des merveilles !  :magicien: 

First things first: la console et l'éditeur de texte

Avant toute chose, vous allez avoir besoin de vous servir de 2 outils tout au long de ce cours : 

1er outil : une console (principalement pour exécuter du code Ruby)

Vous en avez une déjà installée sur votre machine, elle sera différente selon votre OS (Mac, Linux, Windows...) mais les commandes de base seront sensiblement les mêmes.

2ème outil : Un éditeur de texte (pour écrire du code Ruby)

Dans ce cours, j'utiliserai Vim, mais vous pouvez choisir n'importe quel autre éditeur que vous préférez ! 

Si vous n'êtes pas familier avec ces outils, ne vous inquiétez pas, je ne vais pas vous demander d'être un expert : vous aurez juste besoin de quelques bases pour pouvoir faire des actions simples avec. Pour cela, je vous invite à consulter les introductions à la console et à l'éditeur de texte de mon cours sur Git. 

Et maintenant, installons l'outil le plus important de ce cours : Ruby ! 

Installez Ruby

Nous allons installer la version 2.2.0 de Ruby que nous utiliserons dans ce cours. 

Mac OS

Vérifiez votre version de Ruby

Il se trouve que Ruby est installé de base sur Mac OS. Par contre il se peut que vous n’ayez pas la bonne version. Pour vérifier la version, lancez l’application “Terminal” que vous pouvez trouver dans le dossier 'Utilitaires' de vos Applications ou bien en faisant une recherche avec spotlight. 

Terminal dans Applications/Utilitaires
Terminal dans Applications/Utilitaires

Une fois votre Terminal lancé, tapez la commande suivante :

ruby -v

Si vous avez une version postérieure à 2.0.0, tout va bien, vous pouvez passer à la suite ! Par contre si vous avez une version plus ancienne, vous allez devoir faire les actions suivantes.

Mettez à jour votre version si besoin 

Tout d’abord, installez homebrew , qui est un gestionnaire de packages qui nous permettra d’installer le reste de nos outils. Pour cela, tapez dans la console :

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Ensuite, nous allons utiliser la commande brew pour installer rbenv, une solution permettant de gérer plusieurs versions de Ruby :

brew install rbenv ruby-build
echo 'if which rbenv > /dev/null; then eval "$(rbenv init -)"; fi' >> ~/.bashprofile
source ~/.bashprofile

Enfin, vous allez pouvoir utiliser rbenv pour installer la version 2.2.0 de Ruby :

rbenv install 2.2.0
rbenv global 2.2.0

Vous pouvez vérifier que vous avez la bonne version de Ruby en lançant la même commande que tout à l’heure :

ruby -v

Si tout s'est bien passé, la console devrait vous retourner la version 2.2.0.

Linux

Il est possible que Ruby soit déjà installé sous votre distribution de Linux. Vérifiez que vous avez une version supérieure à 2.0.0 en lancant la commande suivante dans une console :

ruby -v

Si vous obtenez une erreur ou un numéro de version antérieur à 2.0.0, installez la version 2.2.0 de Ruby en suivant ici la procédure adaptée à votre distribution.

Windows

Rendez vous sur Ruby Installer pour télécharger la dernière version de Ruby. Le site vous fournira un fichier .exe , lancez le et suivez les instructions qui vous seront données ! 

Et voilà, vous êtes équipés ! Vous êtes fins prêts à découvrir vos premières variables de Ruby...

Exemple de certificat de réussite
Exemple de certificat de réussite