Partage
  • Partager sur Facebook
  • Partager sur Twitter

Allumer un appareil lorsqu'un autre est allumé

    24 avril 2019 à 20:37:50

    Bonjour,

    TL;DR en bas de ce long texte si vous voulez aider en risquant de ne pas vouloir connaitre toute mon histoire :p

    Je restitue le contexte de ma question : Je souhaite allumer automatiquement une bande de leds lumineuses lorsque j'allume ma télévision, et que lorsque j'éteins la télé, les leds font de même.

    J'explique un peu mon raisonnement :

    En premier lieu, j'ai pensé utilisé un tore électromagnétique pour mesurer le courant passant dans les fils électriques de la télé, pour ensuite envoyer cette valeur à un arduino puis actionner un relais via ce dernier. Je me suis finalement dit qu'il y avait plus simple à faire, l'arduino nécessitant une alimentation externe que je ne pouvais pas me permettre d'installer.

    J'ai donc pensé à un système passif et me suis orienté vers une résistance de shunt, que j'ai choisi de dimensionner afin d'actionner directement le relais 5V/230V lorsque la télévision consomme sa puissance nominale (elle est donnée à 150W max pour 230V sur la plaque signalétique de la télé).

    Selon mes calculs, une résistance d'environ 7,5 ohm permettrait d'avoir environ 5V à ses bornes afin d'actionner mon relais qui fermerait le contact pour allumer les LEDS. Les 5V sont donc "pris" de la tension aux bornes de la télévision, mais une chute de tension de 5V sur un réseau de 230V est pour mon contexte négligeable.

    Un de mes récents posts lié à ma problématique : https://openclassrooms.com/forum/sujet/tension-de-commutation-relais-5v?page=1#message-93108489

    J'ai donc assemblé mon petit capteur de courant maison et l'ai testé avec un batteur électrique consommant 170W environ, et ça fonctionne, le relais se ferme lorsque j'allume le batteur et se réouvre lorsque j'éteins le batteur.

    MAIS, malheureusement mon système ne fonctionne pas lorsqu'il est branché sur la télé.

    J'ai donc effectué quelques mesures de consommation de la télé pour voir si elle consommait bien 150W comme annoncé, et c'était bien le cas. Cependant quand je reviens quelques minutes plus tard, la puissance consommée par la télévision est très inattendue :

    Toutes les secondes environ, je relève les valeurs suivantes : 60W, 150W, 210W, 60W, 150W, 210W, 60W, 150W, 210W, etc.

    Est-ce que mon appareil de mesure est défectueux, je ne pense pas, mais gardons cette hypothèse de coté au cas où.

    Je n'ai pas fait les mesures lorsque la télé était raccordée à mon système, si la puissance mesurée oscillait bien comme la sonde le disait, je pense que les leds clignoteraient littéralement, mais je n'ai pas les moyens de vérifier cette théorie pour l'instant (je n'ai pas la susdite télé sous la main).

    Bref, toutes ces mesures me laissent penser que je peux tout de même redimensionner mon système pour qu'il soit compatible avec divers appareils ayant une consommation comprise entre 60W et ??W (je ne l'ai pas calculé). Pour tout ça j'ai pensé pouvoir adapter mes résistances afin d'obtenir une certaine tension à leurs borne, cette fois-ci variable, entre 7 et ??V (je ne l'ai pas calculé), tension que je maintiendrai à 5V via un classique régulateur de tension L7805CV.

    Cependant, lorsque je fais mes calculs, je ne trouve aucune solution viable, mon dernier calcul en date (avoir 7V aux bornes du régulateur 5V lorsque 70W "parcourent" ma résistance de shunt) me donne une tension aux bornes de ma résistance de 20V, ce qui enlève donc 20V pour la télé qui ne sera alimentée plus qu'en 200V, ce qui est limite.

    Ma question TL;DR : 

    Comment faire pour détecter l'allumage d'un appareil électrique (mesurer une consommation de courant non nul) et actionner un relais lorsque l'appareil mesuré est allumé ?

    Est-ce que ma longue réflexion jusqu'ici était bien tenté mais mal calculée/réalisée, ou alors ignoble ? J'ai fouillé un peu sur le net et ait vu quelques solutions, mais il me semble que je ne les ai pas retenues car pas tout à fait adaptées à ma problématique, ou bien le problème n'était pas totalement résolu.

    Je remercie ceux qui ont tout lu et qui pourront m'aider ! :D

    A+ !

    • Partager sur Facebook
    • Partager sur Twitter
      24 avril 2019 à 23:46:49

      Bonjour, si c’est une télévision récente elle a probablement un port usb.

      Si oui, il est probable que lorsque la télé est allumée, elle délivre du 5V sur USB, sinon il y a 0V.

      • Partager sur Facebook
      • Partager sur Twitter
        25 avril 2019 à 17:18:29

        Bonjour,

        Merci pour l'idée, mais je ne souhaite pas raisonner comme cela, premièrement car la télévision n'est pas pourvue de port USB, je pourrais certes peut-être m'en sortir avec un autre port alimenté par la télé, mais je souhaiterai dimensionner ce projet de telle façon à ce qu'il soit facilement adaptable pour n'importe quel appareil, le plus simplement possible.

        Physiquement, mon système est intégré dans un boitier avec une prise male pour l'arrivée du courant secteur et deux prises femelles : une pour la sortie de l'appareil "maître" et une autre pour l'appareil "esclave", piloté par le maître.

        Si vous avez d'autres idées, :ange:

        • Partager sur Facebook
        • Partager sur Twitter

        Allumer un appareil lorsqu'un autre est allumé

        × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
        • Editeur
        • Markdown