Partage
  • Partager sur Facebook
  • Partager sur Twitter

Arduino Nano Téléversement

???

    18 avril 2019 à 11:37:07

    Bonjour,

    Cela fait quelques années que je programme avec arduino

    Aujourd'hui, je m'y remets avec mes petits arduino nano

    J'ai juste un bouton qui fait écrire "ok" dans le port série, un truc de base.

    Le problème que je rencontre est lors du téléversement, il m'affiche ceci :

    Arduino : 1.8.9 (Windows 10), Carte : "Arduino Nano, ATmega328P"
    
    Le croquis utilise 1972 octets (6%) de l'espace de stockage de programmes. Le maximum est de 30720 octets.
    Les variables globales utilisent 190 octets (9%) de mémoire dynamique, ce qui laisse 1858 octets pour les variables locales. Le maximum est de 2048 octets.
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xc9
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xc9
    Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.
    
    Ce rapport pourrait être plus détaillé avec
    l'option "Afficher les résultats détaillés de la compilation"
    activée dans Fichier -> Préférences.
    

    Si quelqu'un a déjà rencontré cette erreur, qu'il se manifeste et merci d'avance à tous ceux qui m'aideront à résoudre mon problème

    • Partager sur Facebook
    • Partager sur Twitter
      19 avril 2019 à 0:17:35

      Bonjour,

      cela arrive souvent lorsque tu as la console d'ouvert. Le port de communication de ta nano est en quelque sorte déjà utilisé, et n'est donc pas disponible pour téléversement.

      Pour ma pars sous W7 & sauf rare exception, je peux garder la console ouverte en arrière plan, et téléversé mon code sur la carte, et revenir sur la fenêtre de la console lorsque le téléversement est fini...

      • Partager sur Facebook
      • Partager sur Twitter

      Arduino Nano Téléversement

      × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
      • Editeur
      • Markdown