Partage
  • Partager sur Facebook
  • Partager sur Twitter

Problème de backgroundimage

Incompréhensible :(

Sujet résolu
1 janvier 2006 à 12:20:37

Bonjour et surtout bonne année.

J'ai un problème sur la page que j'essaye de faire, j'ai suivit (enfin je pense) les directives des cours de ce site mais pourtant la backgroundimage ne s'affiche pas et le div en tête est donc invisible :


#en_tete
{

width: 744px;
height: 150px;
background-image: url('images/headerworldedit001.jpg');
background-repeat: no-repeat;
margin-bottom: 2px
}


<div id="en_tete"</div>


C'est sans doute tout bête mais là ...
  • Partager sur Facebook
  • Partager sur Twitter
1 janvier 2006 à 12:22:30

<div id="en_tete"></div>
  • Partager sur Facebook
  • Partager sur Twitter
1 janvier 2006 à 12:25:03

:D J'ai trop forcé sur le champagne hier soir :(
Mais c'est pas la seule fois où ça marche pas ... Et puis l'image ne s'affiche toujours pas ...
  • Partager sur Facebook
  • Partager sur Twitter
1 janvier 2006 à 12:27:20

background-image: url('images/headerworldedit001.jpg');

==>

background-image: url("images/headerworldedit001.jpg");
  • Partager sur Facebook
  • Partager sur Twitter
1 janvier 2006 à 12:30:33

Salut !!!

Bonne année à toi aussi ^^

Quelle est la dimesion de ton image ?
Si elle fait exactement la dimension de ton div, enlèves le no-repeat.

Citation : Worldedit


background-image: url('images/headerworldedit001.jpg');

==>

background-image: url("images/headerworldedit001.jpg");



Je dirais même encore mieux :

background-image: url(images/headerworldedit001.jpg);
  • Partager sur Facebook
  • Partager sur Twitter
1 janvier 2006 à 12:31:48

Ok merci ... C'est normal que le CSS une fois mis à jour n'altère pas tout de suite le HTML ?
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 12:38:49

En fait non ça ne marche toujours pas ...
dans mon header :

#en_tete
{

width: 748px;
height: 154px;
background-image: url(images/headerworldedit001.jpg);
margin-bottom: 2px
}



<div id="en_tete"></div>
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 12:45:10

Ajoute un ";" à la fin de ton code ca marchera peut-être...

EDIT: il faut aussi mettre des guillemets pour l'url de ton image: en gros ca donnc ça:

#en_tete
{

width:748px;
height:154px;
background-image:url("images/headerworldedit001.jpg");
margin-bottom:2px;
}


Verifie également les dimentions et l'extention de ton image (*.jpg à la place de *.gif ou autre... ;) ).
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 15:17:29

:(
Non ça marche toujours pas ...
Les dimensions de l'image sont pourtant les mêmes que celles inscrites dans mon en_tête ...
L'extension est la même ...
  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 15:29:13

Salut,

Décris précisément l'arborescence de ton site où sont placés tes différents éléments, car je ne vois qu'une erreur provenant de ce côté là.

Ton répertoire images est placé où par rapport à ta feuille de style ?

Dans le même répertoire ?
Ou dans un répertoire dans un niveau supérieur ?


  • Partager sur Facebook
  • Partager sur Twitter
2 janvier 2006 à 15:58:12

En fait j'ai écrit le lien entièrement et ça a marché je vous remercie tous pour votre aide :)
  • Partager sur Facebook
  • Partager sur Twitter

Problème de backgroundimage

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
× Attention, ce sujet est très ancien. Le déterrer n'est pas forcément approprié. Nous te conseillons de créer un nouveau sujet pour poser ta question.
  • Editeur
  • Markdown