• 12 heures
  • Moyenne

Ce cours est visible gratuitement en ligne.

course.header.alt.is_video

course.header.alt.is_certifying

J'ai tout compris !

Mis à jour le 07/03/2022

Configurez le routage de votre routeur

Connectez-vous ou inscrivez-vous gratuitement pour bénéficier de toutes les fonctionnalités de ce cours !

Comprenez le fonctionnement d’un routeur

Pour éviter qu’un routeur ne transfère un paquet n’importe où, il doit déterminer le meilleur chemin (la route) pour le paquet à prendre. À l’inverse d’un commutateur (sauf le commutateur de niveau 3 qui fait office de routeur), un routeur relie plusieurs réseaux entre eux. Il dispose donc de plusieurs interfaces appartenant chacune à un sous-réseau différent.

Lorsqu'un routeur reçoit un paquet sur une interface, il détermine quelle interface il doit utiliser pour transférer le paquet vers sa destination. L’interface qu’utilise le routeur pour transférer le paquet peut être :

  • la destination finale (on parle alors de routeur d’extrémité) ;

  • mais aussi un réseau connecté à un autre routeur utilisé pour atteindre le réseau de destination.

Le meilleur chemin dans la table de routage sera la correspondance la plus longue. Il vous suffit donc de prendre le préfixe le plus long :

Entrées de route

Longueur du préfixe

Adresse en notation binaire

1

172.16.0.0/12

10101100.00010000.00000000.00001010

2

172.16.0.0/18

10101100.00010000.00000000.00001010

3

172.16.0.0/26

10101100.00010000.00000000.00001010

Il en sera de même avec les routes en IPv6. Si un paquet arrive en 2001:db8:c000::99, le routeur a comme table de routage :

Entrées de route

Longueur du préfixe

Correspondance

1

2001:db8:c000::/40

Correspond à 40 bits

2

2001:db8:c000::/48

Correspond à 48 bits

3

2001:db8:c000:5555::/64

Bien que 64 bits, ne correspond pas à cause du sous-réseau

Les tables de routage se remplissent de plusieurs manières :

  • Les réseaux directement connectés sont des réseaux configurés sur les interfaces actives d’un routeur. Un réseau directement connecté est ajouté à la table de routage lorsqu’une interface est configurée avec une adresse IP et un masque de sous-réseau (longueur du préfixe) et lorsqu’elle est active (up).

  • Les réseaux distants sont des réseaux qui ne sont pas directement connectés au routeur, le routeur apprend des réseaux distants de deux manières différentes :

    • Routes statiques : Ajoutées à la table de routage lorsqu’une route est configurée manuellement.

    • Protocoles de routage dynamique : Ajoutés à la table de routage lorsque les protocoles apprennent dynamiquement sur le réseau distant. Les protocoles de routage dynamiques comprennent OSPF (Open Shortest Path First) et EIGRP (Enhanced Interior Gateway Routing Protocol), ainsi que plusieurs autres.

  • Une route par défaut spécifie un routeur de tronçon suivant à utiliser lorsque la table de routage ne contient pas de route spécifique correspondant à l’adresse IP de destination. La route par défaut peut être saisie manuellement sous la forme de route statique, ou apprise automatiquement à partir d’un protocole de routage dynamique.

Configurez les routes de votre routeur

Maintenant que vous savez comment fonctionnent les routeurs, vous allez configurer les tables de routage de vos routeurs. Pour vous aider, j’ai schématisé nos 3 routeurs.

Trois routeurs ?

Eh oui, n’oubliez pas votre commutateur de niveau 3 qui fera office de routeur :

Illustration du schéma réseau du routage de l’entreprise
Schéma réseau du routage de l’entreprise

Bon, vous avez donc 3 tables de routage à remplir, et nous allons les remplir manuellement.

Voici comment vous allez les remplir, mais commencez par la table de routage du routeur VPN :

Réseau destination

Masque de sous-réseau

Passerelle

0.0.0.0

0.0.0.0

10.0.0.1

Wow, mais c’est super simple 😊 !

En effet, vous avez utilisé une route par défaut car votre routeur est situé à l’extrémité du réseau. Donc pour aller ailleurs que sur votre sous-réseau (192.168.110.0/24), vous êtes obligé de passer par la passerelle d’adresse IP 10.0.0.1 

Bon, vous remarquerez également que vous n’avez pas besoin de spécifier les réseaux directement connectés, car le routeur les connaît déjà !

Allez, je vous montre comment configurer une route par défaut : il suffit de taper la commande suivante :

RouteurVPN(config)# ip route 0.0.0.0 0.0.0.0 10.0.0.1

Bon, c’est super, mais vous allez aller un petit peu plus loin, avec la configuration d’une table de routage en IPv6 😱 ! Ne vous inquiétez pas, je vous montre comment faire.  Mais il faut d’abord activer le routage IPv6 et spécifier la route par défaut !

RouteurVPN(config)# ipv6 unicast-routing
RouteurVPN(config)# ipv6 route ::/0 2001:db8:acad:1001::1

La seule différence, en plus du fait d’utiliser ipv6 à la place d’ip, est le format de la route par défaut : ::/0.

Je vous montre cette configuration en vidéo :

Bon maintenant, vous allez configurer le routeur de l’entreprise et c’est (un tout petit) plus compliqué car ce n’est plus un routeur d’extrémité.  Il faut donc spécifier plusieurs routes.

Allez, je vous laisse chercher un peu ce que sera la table de routage du routeur de la métropole.

Vous avez terminé ? (En IPv4, bien sûr 😋) :

Réseau destination

Masque de sous-réseau

Passerelle

192.168.110.0

255.255.255.0

10.0.0.2

0.0.0.0

0.0.0.0

192.168.10.2

Facile, non ? En utilisant une route par défaut, vous n’avez besoin que de rajouter le réseau distant et c’est tout !

Bon allez, voici la configuration avec les commandes :

RouteurVPN(config)# ip route 192.168.110.0 255.255.255.0 10.0.0.2
RouteurVPN(config)# ip route 0.0.0.0 0.0.0.0 192.168.10.2
RouteurVPN(config)# ipv6 unicast-routing
RouteurVPN(config)# ipv6 route 2001:db8:acad:110::0/64 
2001:db8:acad:1001::2
RouteurVPN(config)# ipv6 route ::/0 2001:db8:acad:10::2

Allez, maintenant, il faut configurer le commutateur de niveau 3 sauf que vous ne l’avez pas encore touché ! Pour information, il faut respecter les 3 étapes suivantes pour configurer convenablement un routeur (ou un commutateur de niveau 3) :

  1. Donner un nom d’hôte.

  2. Configurer les interfaces.

  3. Configurer la table de routage.

Pour vous aider, je vous propose le schéma précédent précisant désormais le nom des interfaces :

Illustration du schéma réseau du routage de l’entreprise avec le nom des interfaces
Schéma réseau du routage de l’entreprise avec le nom des interfaces

On peut considérer, à juste titre, que le commutateur de niveau 3 est un routeur d’extrémité car il se situe en bout du réseau. Le routage avec les différents sous-réseaux de l’entreprise sera assuré grâce au routage inter-VLAN.

La table de routage du commutateur de niveau 3 sera donc plutôt simple :

Réseau destination

Masque de sous-réseau

Passerelle

0.0.0.0

0.0.0.0

192.168.10.1

Voici les commandes à taper pour le commutateur de niveau 3 (la commande ip routing permet d’activer le routage IPv4 sur un commutateur de niveau 3) :

Switch(config)# hostname SwitchL3
SwitchL3(config)# interface g1/0/1
SwitchL3(config-if)# no switchport
SwitchL3(config-if)# ip address 192.168.10.2 255.255.255.0
SwitchL3(config-if)# ipv6 address 2001:db8:acad:10::2/64
SwitchL3(config-if)# exit
SwitchL3(config)# ip routing
SwitchL3(config)# ip route 0.0.0.0 0.0.0.0 192.168.10.1
SwitchL3(config)# ipv6 unicast-routing
SwitchL3(config)# ipv6 route ::/0 2001:db8:acad:10::1

Allez, une petite vidéo pour vous montrer cette configuration :

En résumé

Vous avez vu dans ce chapitre :

  • Un routeur permet de choisir le meilleur chemin pour qu’un paquet arrive à sa destination finale et ce, grâce à sa table de routage. 

  • La configuration et l’affichage de la table de routage d’un routeur.

Maintenant que vous savez configurer un routeur, vous allez pouvoir vérifier son fonctionnement dans le prochain chapitre 😀 !

Exemple de certificat de réussite
Exemple de certificat de réussite