Partage
  • Partager sur Facebook
  • Partager sur Twitter

Impossible d'accéder à mon projet avec apache

    13 août 2022 à 6:17:24

    Bonjour tout le monde. Je veux installer un serveur apache local avec une pilelamp. J'utilise Ubuntu ( j'utilise la dernière version disponible ). J'ai suivi un tutoriel que j'ai trouvé sur la documentation française donc voici ce que j'ai fait :

    J'ai entré la commande suivante dans le terminal pour installer les outils essentiels.

    sudo apt install apache2 php libapache2-mod-php mysql-server php-mysql

    Ensuite j'ai installé phpmyadmin Il semble que ça a fonctionné et je peux y accéder via localhost/phpmyadmin, je pense donc avoir fait les choses correctement (localhost fonctionne, j'arrive sur la page d'accueil d'Apache).

    Le problème est d'accéder à mon projet via le navigateur. Comme le dit le tutoriel, j'ai créé un fichier de configuration pour donner les informations à Apache sur l'emplacement de mon projet, le tutoriel dit de créer le fichier de configuration dans /etc/apache2/sites-available/ mon fichier est nommé location.com.conf ( le fichier du tutoriel est nommé example.com.conf )

    J'ai ceci dans ce fichier :

    <VirtualHost *:80>
        ServerName location.com
        ServerAlias www.location.com
        DocumentRoot "/var/www/location/"
        <Directory "/var/www/location/">
            Options FollowSymLinks
            AllowOverride all
            Require all granted
        </Directory>
        ErrorLog /var/log/apache2/error.location.com.log
        CustomLog /var/log/apache2/access.location.com.log combined
    </VirtualHost>

    J'ai placé le dossier de mon projet dans /var/www/ ( et le nom du projet est "location" donc le chemin complet de mes fichiers de mon projet est /var/www/location/ ). Voici une capture d'écran si ça peut vous aider :


    J'ai également exécuté les commandes suivantes après ça  : ( Parce qu'ils ont dit de le faire dans le tutoriel, d'après ce que j'ai compris après quelques recherches elles permettent d'activer le projet pour apache ) :

    sudo a2ensite location.com

    sudo systemctl reload apache2

    Il semble reconnaître la signification de location.com car si j'essaie de le faire plusieurs fois, il me dit qu'il est déjà activé (et si j'essaie par exemple sudo a2ensite thrkrthrth.com, il me dit qu'il ne sait pas ce qu'est thrkrtf...).

    Le problème est que lorsque j'essaie d'aller sur localhost/location ou localhost/location.com ou 127.0.0.1/location ou 127.0.0.1/location.com cela ne fonctionne tout simplement pas, voici une capture d'écran si cela peut aider :

    J'obtiens ce résultat à chaque fois (j'ai aussi essayé juste location.com ou www.location.com, je sais que c'est stupide mais ça aurait pu marcher, j'arrive évidemment sur un site  nommé location.com).

    Est-ce que quelqu'un pourrait me venir en aide s'il-vous-plaît ?

    Merci à vous,

    Très cordialement et avec tout mon respect,

    • Partager sur Facebook
    • Partager sur Twitter
      13 août 2022 à 19:38:12

      Bonjour,

      et si tu passe par localhost, tu le vois dans la liste de t'es sites ?

      As-tu fait un alias dans ton fichier Host ?

      sudo gedit \etc\hosts

      127.0.0.1 location.com

      Voici un tutoriel complet pour réaliser la mise en place d'un virtualhost.

      https://docs.rackspace.com/support/how-to/set-up-apache-virtual-hosts-on-the-ubuntu-operating-system/

      -
      Edité par 1nsan3 13 août 2022 à 19:50:29

      • Partager sur Facebook
      • Partager sur Twitter
        16 août 2022 à 7:25:04

        1nsan3 a écrit:

        Bonjour,

        et si tu passe par localhost, tu le vois dans la liste de t'es sites ?

        As-tu fait un alias dans ton fichier Host ?

        sudo gedit \etc\hosts

        127.0.0.1 location.com

        Voici un tutoriel complet pour réaliser la mise en place d'un virtualhost.

        https://docs.rackspace.com/support/how-to/set-up-apache-virtual-hosts-on-the-ubuntu-operating-system/

        -
        Edité par 1nsan3 13 août 2022 à 19:50:29

        Bonjour 1nsan3 merci beaucoup pour ta réponse rapide. Désolé d'avoir pris du temps à répondre. Je ne voyais aucun site apparaître sur la page apache, simplement une page indiquant "It works" mais pas de liste de sites comme je pouvais le voir lorsque j'utilisais wampserver sur windows et que j'allais dans mon localhost par exemple. A un moment donné, par hasard j'ai modifié une ligne d'un fichier de configuration de apache, le fichier apache2.conf

        j'y avais vu ceci :

        <Directory /var/www/html/>
        	Options Indexes FollowSymLinks
        	AllowOverride None
        	Require all granted
        </Directory>
        

        Et sans trop savoir ce que je faisais mais juste pour voir si ça changeait quelque chose j'ai remplacé /var/www/html par /var/www en me disant que peut-être qu'il ne regardait pas mon dossier location car il considérait que sa racine était en quelque sorte /var/www/html et que mon projet n'était que dans /var/www/ un niveau trop haut en quelque sorte, à ma grande surprise ça semble avoir "résolu" le problème ( enfin l'avoir "résolu", je sais que toute déviance à la normalité est anormale en ingénierie logicielle et que ce comportement n'est pas le comportement normal car même si je peux aller sur phpmyadmin maintenant en allant sur localhost/www/phmyadmin je sais que ce que j'ai fais n'est pas la manière normale de faire donc je ne considère pas le problème comme étant vraiment résolu pour le moment ).

        Excuse moi si ma question te semble stupide mais je suis encore un débutant, est-ce que tu voulais vraiment bien dire "sudo gedit \etc\hosts" ? Car dans le tutoriel j'ai l'impression que les slash sont dans l'autre sens, je ne voudrai pas commettre une erreur bloquante, merci à toi d'avance



        • Partager sur Facebook
        • Partager sur Twitter
          16 août 2022 à 14:08:56

          Salut,

          oui effectivement c'est bien des slash et pas des backslash 

          • Partager sur Facebook
          • Partager sur Twitter

          Impossible d'accéder à mon projet avec apache

          × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
          • Editeur
          • Markdown