Partage

Problème affichage icône font-awesome

Sujet résolu
17 mai 2017 à 19:46:19

J'ai souhaité inséré des icônes de réseaux sociaux sur la bannière de mon site web (en construction) en téléchargeant font-awesome et en suivant les instructions.

Mais, pour l'instant l'icône de Facebook n'apparaît pas :

Le code qui contient la bannière se trouve sur le fichier banner.php  :

<head>
	<link rel="stylesheet" href="../../font-awesome/css/font-awesome.min.css">
</head>

	<section id="banner" class="hidden-xs col-sm-12 col-md-12 col-lg-12">
    <ul class="col-sm-12 col-md-12 col-lg-12 banner-social">
        <li><span class="fa fa-facebook" aria-hidden="true"></span></li>
        <li>Twitter</li>
        <li>Google+</li>
    </ul>
    <div class="col-sm-12 col-md-12 col-lg-12 banner-title">Benoît Soubeyran</div>
    <div class="col-sm-12 col-md-12 col-lg-12 banner-slogan">Documentaliste-Informaticien</div>
    </section>

Ça ne peut pas être un problème d'adressage puisqu'à la racine on a bien :

  • un dossier font-awesome>css>font-awesome.min.css
  • et un dossier php>inc>banner.php
17 mai 2017 à 20:09:28

T'as essayé avec la balise <i> au lieu d'un span ?
Staff 18 mai 2017 à 8:25:14

Bonjour,

est-ce que le fichier CSS de FontAwesome est correctement chargé ? Ça peut se voir dans l'outil de développement web, soit dans l'onglet console, soit dans l'onglet réseau.

Pas d'aide concernant le code par MP ni par mail, le forum est là pour ça :) Postez votre code html et css (bouton '</>') !!
18 mai 2017 à 9:17:52

Bonjour,

@EdwinRed, <i> ou <span>, même combat.

@Benoit, c'est un problème d'adressage, comme te le suggère Lamecarlate de regarder dans l'inspecteur de code, partie Console. Y t il une erreur?

-
Edité par Lord Morpheus 18 mai 2017 à 9:20:24

Lord Morpheus, Seigneur Morphée, Dieu Grecs des Songes, Fils de la Nuit et du Sommeil
18 mai 2017 à 12:09:10

Lord Morpheus a écrit:

@EdwinRed, <i> ou <span>, même combat.

Exact, c'est juste que sur le site de font-awesome, il est dit "we like the <i> tag for brevity, but using a <span>is more semantically correct".

Lamecarlate a écrit:

est-ce que le fichier CSS de FontAwesome est correctement chargé ? Ça peut se voir dans l'outil de développement web, soit dans l'onglet console, soit dans l'onglet réseau.

Exact, autant pour moi, il s'agit bien d'un problème d'adressage, d'après Firebug (que je commence à utiliser) :

 À  la ligne 2 de banner.php, pour que les icônes apparaissent, il faut en en fait mettre  :

<head>
	<link rel="stylesheet" href="font-awesome/css/font-awesome.min.css">
</head>




Mais comme banner.php ne se trouve pas dans le dossier racine, ça me semblait bizarre de mettre dans href directement le sous-dossier "font_awesome" sans passer par un retour vers la racine.

-
Edité par Benoit Soubeyran 18 mai 2017 à 12:12:44

Problème affichage icône font-awesome

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown