Partage

Problème connexion https, contenu mixte wordpress

Sujet résolu
13 septembre 2017 à 12:14:17

Bonjour,

J'ai récemment créer un site pour un client, et j'ai établi une connexion sécurisée https:// sur la plateforme de mon hébergeur (lws). Mon site a été fait sur wordpress et fonctionne correctement.  Mais depuis que j'ai rajouté un carrousel d'images, mon site ne s'affiche plus en https car il y a du contenu mixte. Le problème vient donc de l'adresse des images qui sont dans le dossier wp-content, qui devrait pourtant être en https comme tout le site en général... Est-il possible de recréer une connexion https pour mes images sans casser les liens établis? (il y a déjà beaucoup d'images sur le site).

Le site: https://epurnet.com/

Merci de votre réponse!

Jordy P.
13 septembre 2017 à 12:54:18

Tu a bien tous réglé:

https://wpformation.com/wordpress-http-https/

Principalement la partie:

"Déménager WordPress de HTTP --> HTTPS

Pour placer votre WordPress en HTTPS, nous l'avons vu, vous devez nécessairement obtenir un certificat SSL pour votre nom de domaine, l'installer sur le serveur et enfin changer les permaliens du site de HTTP en HTTPS.

Tous les liens dans WordPress (tels que les images jointes, CSS des thèmes, fichiers JavaScript) sont liés à l'URL d'installation, aussi pour changer votre WordPress de http en https, l'URL d'installation doit être changée: de http://monsite.comen https://monsite.com

Connectez-vous à votre tableau de bord WordPress et accédez àRéglages>>Général. Assurez-vous que l' adresse de WordPress (URL) et l'adresse du site (URL) soient bien en https."

13 septembre 2017 à 14:35:16

A noter qu'il faut aussi passer la base de données à la moulinette (via SRDB par exemple), pour remplacer les anciennes URLS en http://www.monsite.com vers la même URL en https de type https://www.monsite.com

Oui, WordPress stocke en dur dans la base des URL.

-
Edité par Darev 13 septembre 2017 à 14:43:45

13 septembre 2017 à 19:40:50

Merci de votre aide!

J'ai testé avec firebug en remplaçant l'adresse url des images par https et les images fonctionnaient, du coup j'ai installé le plugin SSL Insecure Content, et tout est rentré dans l'ordre! Les images ont enfin une URL en https et l'ensemble du site aussi!

Merci de votre aide! :)

Jordy P.

Problème connexion https, contenu mixte wordpress

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown