Partage
  • Partager sur Facebook
  • Partager sur Twitter

Problème d'affichage mode maths (LateX)

    24 mars 2020 à 21:13:27

    Bonjour, 

    Je suis actuellement en train de rédiger un rapport en LateX et l'affichage de mes équations laisse vraiment à désirer : 

    Que faut-il faire pour améliorer la mise en page ? (j'aimerais bien que les lettres indices et les exposants soient plus petits et qu'ils ne coupent pas les lettres à coté)

    J'ai essayé de trouver un moyen pour changer la police du mode maths, mais je n'ai pas réussi (je débute). 

    Merci d'avances pour vos réponses. 

    • Partager sur Facebook
    • Partager sur Twitter
      25 mars 2020 à 10:31:41

      Salut,

      Quel code utilises tu ? Normalement le résultat devrait être beaucoup mieux.

      \[
         P = P_1 R_L R_D^2 \ln \left(1 + \frac{1}{R_L R_D^2}\right) 
      \]
      
      • Partager sur Facebook
      • Partager sur Twitter
      Tutoriel Ruby - Bon tutoriel C - Tutoriel SDL 2 - Python avancé - Faîtes un zeste, devenez des zesteurs
        25 mars 2020 à 14:21:34

        L'affichage reste le même malheureusement :/

        Voilà le code que j'utilise : 

        $$P\bar = P_{1}R_{L}R_{D}^{2}\ln\bigg(1+\frac{1}{R_{L}R_{D}^{2}}\bigg)$$
        
        
        • Partager sur Facebook
        • Partager sur Twitter
          25 mars 2020 à 14:55:28

          Tu compiles ton document comment et quel est ton préambule ?

          PS : il ne faut pas utiliser $$, utilise plutôt \[ et \].

          -
          Edité par yo@n97one 25 mars 2020 à 14:55:58

          • Partager sur Facebook
          • Partager sur Twitter
          Tutoriel Ruby - Bon tutoriel C - Tutoriel SDL 2 - Python avancé - Faîtes un zeste, devenez des zesteurs
            25 mars 2020 à 22:11:38

            J'utilise le préambule par défault de LateX : 

            \documentclass[a4paper,twoside,10pt]{book}
            
            \usepackage[USenglish]{babel} 
            \usepackage[T1]{fontenc}
            \usepackage[ansinew]{inputenc}
            
            \usepackage{lmodern} 
            
            
            \usepackage{graphicx} 
            \usepackage{amsmath}
            \usepackage{amsthm}
            \usepackage{amsfonts}
            \usepackage{graphicx}
            \usepackage{amssymb}
            

            ça marche, merci de l'info ! :) 

            • Partager sur Facebook
            • Partager sur Twitter
              26 mars 2020 à 9:38:21

              Mieux, utilise un environnement

              \begin{align}
               \displaystyle ...
              \end{align}
              • Partager sur Facebook
              • Partager sur Twitter

              Avez-vous entendu parler de Julia ? Laissez-vous tenter ...

                26 mars 2020 à 10:00:23

                Et comment compiles-tu ? Quelle commande utilises-tu ? Le code est correct de mon côté. Sinon, quelques conseils.

                • Pourquoi utiliser ansinew et pas utf8 pour inputenc ?
                • Tu charges deux fois gaphicx.
                • Chargemathtools plutôt que amsmath. Il corrige quelques bugs et rajoute des fonctionnalités intéressantes.
                • Pas la, peine de charger amsfont, il est automatiquement chargé par amssymb.

                @Nozio : pourquoi ce serait mieux d'utiliser align ? Il n'a pas besoin d'aligner des équations. Note que tu n'as pas besoin de \displaystyle dans align, tu es déjà en displaystyle. De plus, on peut dire que \[ \] correspond à utiliser l'environnement displaymath puisque displaymath` est défini de la façon suivante.

                \def\displaymath{\[}
                \def\enddisplaymath{\]\@ignoretrue}
                

                PS : je pose ça là pour l'utilisation des maths en LaTeX.

                -
                Edité par yo@n97one 26 mars 2020 à 10:03:38

                • Partager sur Facebook
                • Partager sur Twitter
                Tutoriel Ruby - Bon tutoriel C - Tutoriel SDL 2 - Python avancé - Faîtes un zeste, devenez des zesteurs
                  2 avril 2020 à 21:46:01

                  Le problème venait effectivement de la compilation, merci beaucoup ! J'ai essayé de compiler en pdf, et l'affichage est niquel.

                  Merci aussi pour ces conseils :) 

                  • Partager sur Facebook
                  • Partager sur Twitter

                  Problème d'affichage mode maths (LateX)

                  × Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
                  • Editeur
                  • Markdown