Partage

Problème pour utiliser une police d'écriture perso

Sujet résolu
2 janvier 2018 à 17:00:02

Bonjour et bonne année ! 

Je me heurte à un problème depuis quelques heures, en effet, j'ai téléchargé une police d'écriture personnalisée et, je ne sais pas si c'est un problème de chemin d'accès mais elle ne veut pas s'afficher à l'écran.

Voici mon code css:

body { 
    font-family: 'hover_classic_literegular';
}

@font-face {
    font-family: 'hover_classic_literegular';
    src: url('./font/hover/hover-classic-lite-webfont.woff2') format('woff2'),
         url('./font/hover/hover-classic-lite-webfont.woff') format('woff');
    font-weight: normal;
    font-style: normal;
}

Est-ce un problème de chemin d'accès ? Sachant que les fichiers sont situés de telle sorte:

PortfolioProjet -> index.html

                     -> CSS ->style.css

                     -> font ->hover->les fameuses polices

Ce n'est pas un problème de link html/css puisque toutes mes autres propriétés sont fonctionnelles...

Merci d'avance pour vos retours.



2 janvier 2018 à 17:08:12

Bonjour,

Pour commencer je te conseille de mettre ton font-face tout en haut, avant ta règle pour le body.

Ensuite, étant que tes polices sont dans un dossier parent, tu devrais relire ce point du cours : https://openclassrooms.com/courses/apprenez-a-creer-votre-site-web-avec-html5-et-css3/creer-des-liens#/id/r-1609670

-
Edité par Mewen_bzh 2 janvier 2018 à 17:12:13

Recherche l'avis de développeurs front : Devenir un meilleur dev front ?
2 janvier 2018 à 17:16:24

Merci beaucoup !!! Je n'avais pas compris cela en effet, tout fonctionne maintenant, super aide !

Problème pour utiliser une police d'écriture perso

× Après avoir cliqué sur "Répondre" vous serez invité à vous connecter pour que votre message soit publié.
  • Editeur
  • Markdown